Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 1448509 - Fix for Bug #1415153 causes application crashes ( Need to unpush the patch )
Fix for Bug #1415153 causes application crashes ( Need to unpush the patch )
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: motif (Show other bugs)
7.3
x86_64 Linux
urgent Severity urgent
: rc
: ---
Assigned To: Carlos Soriano
Desktop QE
: ZStream
: 1429298 (view as bug list)
Depends On:
Blocks: 1420851 1479818 1484714 1484715
  Show dependency treegraph
 
Reported: 2017-05-05 11:34 EDT by jigar
Modified: 2018-05-10 04:26 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Red Hat Enterprise Linux 7.3 provided a patch that fixed a bug regarding arrow keys that did not work when navigating in drop-down menus, but another problem occurred. Previously, removing widgets that used the Motif libraries caused some applications to terminate unexpectedly under certain circumstances. With this update, applications that use Motif no longer crash in the described situation.
Story Points: ---
Clone Of:
: 1484714 1484715 (view as bug list)
Environment:
Last Closed: 2018-04-10 13:58:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0959 None None None 2018-04-10 13:59 EDT

  None (edit)
Description jigar 2017-05-05 11:34:27 EDT
Description of problem: In Bug 1415153, the patch which was pushed to fix the issue while navigating drop down menus with arrow keys, started causing two new issues : 

[1] The patch (motif-2.3.4-8.1.el7_3.x86_64) that should fix this issue causes application crashes. We have confirmed that it really is the patch that causes the crashes.

The crash seems be related with removing a widgets.

[2] We have also noticed a change in behavior between the two motif packages motif-2.3.4-8 and motif-2.3.4-8.1

With motif-2.3.4-8 the application still has focus after the widget is removed (expected behavior). But with the new patch motif-2.3.4-8.1 the application looses focus after the widget is removed.

Following is the link to errata which was released : 

https://rhn.redhat.com/errata/RHBA-2017-0381.html
 

Version-Release number of selected component (if applicable): motif-2.3.4-8.1


How reproducible: Always


Steps to Reproduce: 

motif-2.3.4-8.1 causes the above mentioned crashes and change in behaviour after installation.


Actual results: The mentioned patch causes applications to crash.


Expected results: The top patch ( motif-2.3.4-8.1 ) needs to be unpushed.


Additional info: This is very high priority as customer's business is highly affected. This would need to go via z-stream or a hotfix packages would be required.
Comment 37 Carlos Soriano 2017-09-18 13:26:14 EDT
Unfortunately the fix broke API, as pointed by the rpmdiff https://errata.devel.redhat.com/rpmdiff/show/181645 so afaik that means it cannot be included.

What's the way forward here to have the fix included, if wanted?
Comment 39 Carlos Soriano 2017-09-19 06:50:25 EDT
After more investigation I was wrong in comment #37, the API is "public" as in they export the symbols for technical reasons, but it's not for public use.

So the update should be fine.
Comment 48 errata-xmlrpc 2018-04-10 13:58:27 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0959
Comment 49 Carlos Soriano 2018-05-10 04:26:32 EDT
*** Bug 1429298 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.