Bug 144853 - Data corruption with sata_sil and 8GB of memory. Duplicated by Vendor
Data corruption with sata_sil and 8GB of memory. Duplicated by Vendor
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Garzik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-11 18:10 EST by Jason Juday
Modified: 2007-11-30 17:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:09:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Juday 2005-01-11 18:10:54 EST
Description of problem:


Version-Release number of selected component (if applicable):
Update 4

How reproducible:
Repoduced numerous times on two systems.

Steps to Reproduce:
1. Have sata_sil drive/controller and 8GB memory.
2. Install Redhat EL3 U3 or U4
3. Reboot and see results!  Data corruption apparent during reboot.
  
EMAIL From VENDOR:


> What exactly would I report to them?  I am not sure how to phrase 
this 
> issue.  Is it using 8GB of memory or???  I have many other systems

Here is the detail. When using the Silicon Image SATA driver 
(sata_sil) under 8GB, data corruption occurs. With 4GB memory, there 
is no problem. You can verify this by removing 4GB from your system 
and reinstall RHEL3. BTW, we use RHEL3 Update 4 (AMD64 edition) for 
testing.

To support 8GB of memory under RHEL3, you will have to use SCSI or 
IDE disk. If you want to use the onboard SATA controller, the machine 
is limited to 4GB for now.

Jeff
Comment 1 Jeff Garzik 2005-02-18 01:03:28 EST
Is this an EM64T (Intel-base x86-64) machine?

It's likely this is a duplicate of bug #132848.
Comment 2 Jason Juday 2005-02-18 14:18:19 EST
This was on an AMD Opteron system, not an EM64T.  We have already 
turned off the SATA controller, installed a SCSI card and SCSI drive, 
and the problem has gone away.
Comment 3 RHEL Product and Program Management 2007-10-19 15:09:25 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.