Bug 144882 - Arping utility hangs if SIGALRM blocked
Arping utility hangs if SIGALRM blocked
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: iputils (Show other bugs)
3.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Radek Vokal
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-12 09:17 EST by Atul Verma
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1085971 (view as bug list)
Environment:
Last Closed: 2005-05-12 04:26:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
C file to reproduce the bug (385 bytes, text/plain)
2005-01-12 09:21 EST, Atul Verma
no flags Details

  None (edit)
Description Atul Verma 2005-01-12 09:17:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Texas 
Instruments; .NET CLR 1.1.4322)

Description of problem:
If "arping" utility is forked (using system() library function) from 
a parent process in which SIGALRM signal is blocked then the system() 
function call never returns.

The problem is that arping utility installs a SIGALRM handler but 
does not bother to unblock it - so its logic does not work if it 
inherited blocked SIGALRM.

Version-Release number of selected component (if applicable):
iputils-20020927-11

How reproducible:
Always

Steps to Reproduce:
1.Block SIGALRM signal
2.Call srping utility ising system() library function
3.Observe that system() function never returns
    

Actual Results:  The process hangs forever

Expected Results:  The process should have exited

Additional info:
Comment 1 Atul Verma 2005-01-12 09:21:58 EST
Created attachment 109666 [details]
C file to reproduce the bug
Comment 2 Radek Vokal 2005-01-17 06:47:18 EST
This comes from your test C code. I see what you mean with SIGALRM
locked but it works on my machine.

# ./mytest1
Executing command [arping -c 1 -I eth0 192.168.1.1]
ARPING 192.168.1.1 from 192.168.1.13 eth0
Unicast reply from 192.168.1.1 [00:10:4B:6B:18:87]  5.317ms
Sent 1 probes (1 broadcast(s))
Received 1 response(s)
System call returned with status 0

# rpm -q iputils
iputils-20020927-19 (includes updated ifenslave, might fix the issue)

Comment 3 Radek Vokal 2005-05-12 04:26:32 EDT
retested, problem not found

Note You need to log in before you can comment on or make changes to this bug.