Bug 1448885 - [Netvirt][NAT] Floating IP + OpenDaylight when external interface is directly attached to br-int is unreachable when using composable roles
Summary: [Netvirt][NAT] Floating IP + OpenDaylight when external interface is directly...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: opendaylight
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: beta
: 14.0 (Rocky)
Assignee: Josh Hershberg
QA Contact: Itzik Brown
URL:
Whiteboard: Netvirt
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-05-08 13:46 UTC by Itzik Brown
Modified: 2018-10-04 09:40 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1575496 (view as bug list)
Environment:
Last Closed: 2018-10-04 09:40:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenDaylight Bug 8418 0 None None None 2017-05-11 06:31:48 UTC

Description Itzik Brown 2017-05-08 13:46:03 UTC
Description of problem:
When using composable roles (i.e. Having the OpenDaylight controller on a separate node ) to deploy the overcloud there is no connectivity to the Floating IP of an instance when the compute interface facing the external network doesn't have an IP.

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-6.0.0-10.el7ost.noarch

How reproducible:


Steps to Reproduce:
1. Deploy the overcloud using the topology of 1 Controller,1 OpenDaylight controller and 2 compute nodes setting the use_dhcp of the external interface of the compute to false.
2. Launch an instance.
3. Verify there is no connectivity to the instance
4. Do Steps 1-3 but using use_dhcp=True for the external interface of the compute and verify there is a connectivity to the Instance.

Actual results:


Expected results:


Additional info:

Comment 1 Tim Rozet 2017-05-08 15:17:13 UTC
We shouldn't need an IP address on external interface of compute.  This looks like a bug where some flows are missing in OVS, and restarting ODL fixes it.

Comment 2 Itzik Brown 2017-05-10 14:22:46 UTC
When using the bridge br-ex in the compute node - there is no problem.
The problem happens when we have a mapping such as OpenDaylightProviderMappings: "datacentre:eth2"

Comment 3 Tim Rozet 2017-06-30 16:16:09 UTC
(In reply to Itzik Brown from comment #2)
> When using the bridge br-ex in the compute node - there is no problem.
> The problem happens when we have a mapping such as
> OpenDaylightProviderMappings: "datacentre:eth2"

Then this is a bug with using the interface directly on br-int for proivder networks.  Changing the bug title as we should not need an IP on the linux interface.

Comment 4 Nir Yechiel 2017-07-20 09:00:46 UTC
@Itzik, can you confirm the severity of this bug? Should we retest it with RHOSP 12?

Comment 5 Itzik Brown 2017-07-23 07:47:23 UTC
As far as I understand the common approach is using a bridge (e.g. br-ex) and not adding the interface directly to br-int so this is why I think it's a Medium priority.
Regarding RHOSP12 - we need to discuss.

Comment 6 Nir Yechiel 2017-07-23 09:22:31 UTC
@Itzik, can you please review this with Tim and let me know what should be our solution for Pike/RHOSP 12?

Thanks,
Nir

Comment 7 Itzik Brown 2017-07-23 10:21:44 UTC
I'll do.

Comment 8 Nir Yechiel 2017-07-25 14:37:57 UTC
@Josh, per feedback from Tim can you please take a look at this one? We should try to reproduce with Carbon SR1 and fix it if it still exists.

Thanks,
Nir

Comment 19 Josh Hershberg 2018-04-09 05:55:02 UTC
I think we need to understand whether or not we need to support external interfaces on br-int since OoO triple-o does not install things that way.

Comment 31 Josh Hershberg 2018-10-04 09:40:21 UTC
As it turns out, per the opener of this bug, it only occurs when the compute node's external interface is directly attached to br-int. We do not deploy the product this way any more. As such I am closing this bug.


Note You need to log in before you can comment on or make changes to this bug.