Bug 1448945 - Document multipathd reset command
Summary: Document multipathd reset command
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: device-mapper-multipath
Version: 7.4
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: 7.4
Assignee: Steven J. Levine
QA Contact: Lin Li
URL:
Whiteboard:
Depends On: 1416569
Blocks: 1289208 1332226 1384257
TreeView+ depends on / blocked
 
Reported: 2017-05-08 18:41 UTC by Steven J. Levine
Modified: 2017-06-01 14:16 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of: 1416569
Environment:
Last Closed: 2017-05-12 17:19:20 UTC
Target Upstream Version:


Attachments (Terms of Use)

Comment 2 Steven J. Levine 2017-05-12 17:19:20 UTC
Checking into this further, I don't think we need to add anything to the DM multipath manual.

Currently we do not document the multipathd options individually, although we do document how to find the wildcard strings and we also document raw format -- but those are general multipathd usage things rather than specific commands. Instead we refer to the man page:

"The multipathd commands can be used to administer the multipathd daemon. For information on the available multipathd commands, see the multipathd(8) man page."

This is in Section 5.12 here (The multipathd Commands):

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7/html/DM_Multipath/multipathd_commands.html

So if we want to document this specific command we should probably document all the commands (to document this without documenting stats would be confusing), but everything is right there in the man page. 

I'm closing this BZ as not a bug, since I'm the one who opened it in the first place when I editied the release note description for the feature.  We mention this in the release notes.

However:  I don't see this documented in the multipathd man page on the latest 7.4 build I have.  I'll ping Ben about this -- but that's not part of this BZ.

If somebody things I should re-open this BZ or open a separate BZ to provide documentation for all of the multipathd commands in the DM Multipath manual (in addition to the man page), let me know, but I don't know what that would add except perhaps some examples.


Note You need to log in before you can comment on or make changes to this bug.