Bug 144914 - radeon 9800 Pro driver doesn't work - no good widescreen resolutions
radeon 9800 Pro driver doesn't work - no good widescreen resolutions
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: XFree86 (Show other bugs)
3.0
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-12 13:22 EST by Evan Patey
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-07 16:16:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Evan Patey 2005-01-12 13:22:37 EST
Description of problem:

I have several related issues.  1)  The radeon driver does NOT work
with RH EL 3 on AMD64 platform.  I was advised to use the VESA driver
by Tech Support.  2)  No good widescreen resolutions are available. 
I've tried different modelines and configs.  Nothing works which makes
me believe it is a display driver issues or a monitor driver issue. 
I'm trying to obtain 1280x720 on an HDTV monitor using the VGA port.

Tech support told me you could either provide a resolution, a patch or
a new driver.  Please advise on status.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Mike A. Harris 2005-03-07 16:16:54 EST
Radeon 9800 video hardware is not officially supported by RHEL3,
however RHEL 4 which was recently released does officially support
this hardware.

The "vesa" driver is limited to using video modes that are supported
by the video BIOS.  If the BIOS does not support a particular mode,
then it wont work with that mode, even if it is the hardware's
native resolution.  In this case it is a BIOS limitation that only
the BIOS vendor can fix via a BIOS update.  This is a common
problem with Intel graphics hardware in laptops for example.
Widescreen video modes are not "standard" modes, and so very few
BIOSes support them.  As a result, the "vesa" driver will probably
not work for you.

Additionally, the video mode 1280x720 is not a standard video mode,
so the X server may not have it built in and available for use
by the native drivers.  As such, you may need to manually generate
a modeline for 1280x720 by hand using the "gtf" utility included
with X.  You can paste the generated modelines into the X server
config file and try restarting it.  This should work in RHEL4
I believe, but it may not work at all in RHEL3 because the
Radeon 9800 hardware is not officially supported by the RHEL3
"radeon" driver.  You can try it with RHEL3 nonetheless and
see if it happens to work.

Setting status to "NOTABUG".

Note You need to log in before you can comment on or make changes to this bug.