Bug 1449391 - initial-setup.service failed on Minimal raw-xz
Summary: initial-setup.service failed on Minimal raw-xz
Status: CLOSED DUPLICATE of bug 1438046
Alias: None
Product: Fedora
Classification: Fedora
Component: initial-setup   
(Show other bugs)
Version: 26
Hardware: armv7hl
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Martin Kolman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-05-09 21:15 UTC by Alessio
Modified: 2017-05-12 12:43 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-05-12 12:43:20 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alessio 2017-05-09 21:15:43 UTC
Description of problem:

At the end of the boot process of a Raspberry Pi 3 running Minimal image, the initial setup doesn't start.

On subsequent reboots, sometimes the initial setup appears.

Version-Release number of selected component (if applicable):

Fedora 26 armhfp Fedora-Minimal-armhfp-26-20170504.n.1-sda.raw.xz

How reproducible:

Always.

Steps to Reproduce:
1. Boot the Raspberry

Actual results:

[root@localhost ~]# systemctl status initial-setup
● initial-setup.service - Initial Setup configuration program
   Loaded: loaded (/usr/lib/systemd/system/initial-setup.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Wed 2017-03-01 16:43:33 EST; 2 months 8 days ago
  Process: 676 ExecStart=/usr/libexec/initial-setup/run-initial-setup (code=exited, status=208/STDIN)
  Process: 675 ExecStartPre=/bin/plymouth quit (code=exited, status=208/STDIN)
  Process: 668 ExecStartPre=/bin/kill -55 1 (code=exited, status=0/SUCCESS)
 Main PID: 676 (code=exited, status=208/STDIN)

Mar 01 16:43:33 localhost systemd[1]: Starting Initial Setup configuration program...
Mar 01 16:43:33 localhost systemd[675]: initial-setup.service: Failed to set up stdin: Inappropriate ioctl for device
Mar 01 16:43:33 localhost systemd[676]: initial-setup.service: Failed to set up stdin: Inappropriate ioctl for device
Mar 01 16:43:33 localhost systemd[1]: initial-setup.service: Main process exited, code=exited, status=208/STDIN
Mar 01 16:43:33 localhost systemd[1]: Failed to start Initial Setup configuration program.
Mar 01 16:43:33 localhost systemd[1]: initial-setup.service: Unit entered failed state.
Mar 01 16:43:33 localhost systemd[1]: initial-setup.service: Failed with result 'exit-code'.


Expected results:

Initial setup should start.

Additional info:

I don't use an external monitor, but I'm connecting to the device using the serial communication (enable_uart=1 etc.)

Comment 1 Alessio 2017-05-12 12:43:20 UTC

*** This bug has been marked as a duplicate of bug 1438046 ***


Note You need to log in before you can comment on or make changes to this bug.