Bug 1449399 - [abrt] dnfdragora-gui: perform(): __init__.py:250:_handle_dbus_error:dnfdaemon.client.DaemonError: g-io-error-quark: GDBus.Error:org.freedesktop.DBus.Python.dnf.exceptions.RepoError: Traceback (most recent call last):
Summary: [abrt] dnfdragora-gui: perform(): __init__.py:250:_handle_dbus_error:dnfdaemo...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnfdragora
Version: 26
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Björn 'besser82' Esser
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:abebb8bbb799acc8bd0b1b61acf...
: 1460453 1514750 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-05-09 21:22 UTC by Adam Williamson
Modified: 2018-01-01 22:09 UTC (History)
68 users (show)

Fixed In Version: dnfdragora-1.0.1-8.git20171229.24e4647.fc27 dnfdragora-1.0.1-8.git20171229.24e4647.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-31 21:26:08 UTC


Attachments (Terms of Use)
File: backtrace (9.16 KB, text/plain)
2017-05-09 21:22 UTC, Adam Williamson
no flags Details
File: cgroup (289 bytes, text/plain)
2017-05-09 21:22 UTC, Adam Williamson
no flags Details
File: cpuinfo (1.20 KB, text/plain)
2017-05-09 21:22 UTC, Adam Williamson
no flags Details
File: environ (1.42 KB, text/plain)
2017-05-09 21:22 UTC, Adam Williamson
no flags Details
File: mountinfo (3.19 KB, text/plain)
2017-05-09 21:22 UTC, Adam Williamson
no flags Details
File: namespaces (102 bytes, text/plain)
2017-05-09 21:22 UTC, Adam Williamson
no flags Details
File: open_fds (1.06 KB, text/plain)
2017-05-09 21:22 UTC, Adam Williamson
no flags Details

Description Adam Williamson 2017-05-09 21:22:41 UTC
Description of problem:
Appeared on first boot of a bare metal install of Fedora 26 KDE from the 20170508.n.0 x86_64 live image. Note: there was no network connection during install or on post-install boot.

Version-Release number of selected component:
dnfdragora-gui-1.0.1-5.git20170505.2a3b056.fc26

Additional info:
reporter:       libreport-2.9.1
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: perform
exception_type: librepo.LibrepoException
executable:     /usr/bin/dnfdragora-updater
kernel:         4.11.0-0.rc8.git0.1.fc26.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
#1 perform in /usr/lib64/python3.6/site-packages/librepo/__init__.py:1517
#2 _perform in /usr/lib/python3.6/site-packages/dnf/repo.py:229

Comment 1 Adam Williamson 2017-05-09 21:22:47 UTC
Created attachment 1277453 [details]
File: backtrace

Comment 2 Adam Williamson 2017-05-09 21:22:48 UTC
Created attachment 1277454 [details]
File: cgroup

Comment 3 Adam Williamson 2017-05-09 21:22:49 UTC
Created attachment 1277455 [details]
File: cpuinfo

Comment 4 Adam Williamson 2017-05-09 21:22:50 UTC
Created attachment 1277456 [details]
File: environ

Comment 5 Adam Williamson 2017-05-09 21:22:52 UTC
Created attachment 1277457 [details]
File: mountinfo

Comment 6 Adam Williamson 2017-05-09 21:22:53 UTC
Created attachment 1277458 [details]
File: namespaces

Comment 7 Adam Williamson 2017-05-09 21:22:54 UTC
Created attachment 1277459 [details]
File: open_fds

Comment 8 jonandmykaela 2017-06-10 19:23:22 UTC
*** Bug 1460453 has been marked as a duplicate of this bug. ***

Comment 9 Frank365 2017-06-22 12:49:41 UTC
*** Bug 1464111 has been marked as a duplicate of this bug. ***

Comment 10 Frank365 2017-06-22 22:11:41 UTC
*** Bug 1464277 has been marked as a duplicate of this bug. ***

Comment 11 Ryan Farmer 2017-06-26 07:59:54 UTC
Similar problem has been detected:

This happened when I logged in to the June 25th nightly ISO with Cinnamon.

reporter:       libreport-2.9.1
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: perform
exception_type: librepo.LibrepoException
executable:     /usr/bin/dnfdragora-updater
kernel:         4.11.6-301.fc26.x86_64
package:        dnfdragora-gui-1.0.1-5.git20170505.2a3b056.fc26
reason:         __init__.py:250:_handle_dbus_error:dnfdaemon.client.DaemonError: g-io-error-quark: GDBus.Error:org.freedesktop.DBus.Python.dnf.exceptions.RepoError: Traceback (most recent call last):
runlevel:       N 5
type:           Python3
uid:            1000

Comment 12 leigh scott 2017-06-30 16:13:53 UTC
Similar problem has been detected:

Just logged into cinnamon livecd

reporter:       libreport-2.9.1
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: perform
exception_type: librepo.LibrepoException
executable:     /usr/bin/dnfdragora-updater
kernel:         4.11.6-301.fc26.x86_64
package:        dnfdragora-gui-1.0.1-5.git20170505.2a3b056.fc26
reason:         __init__.py:250:_handle_dbus_error:dnfdaemon.client.DaemonError: g-io-error-quark: GDBus.Error:org.freedesktop.DBus.Python.dnf.exceptions.RepoError: Traceback (most recent call last):
runlevel:       N 5
type:           Python3
uid:            1000

Comment 13 Mahdi Adnan 2017-07-03 19:07:01 UTC
*** Bug 1467421 has been marked as a duplicate of this bug. ***

Comment 14 Yamin 2017-07-10 17:07:15 UTC
Similar problem has been detected:

I just logged in for the first time after a fresh installation.

reporter:       libreport-2.9.1
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: perform
exception_type: librepo.LibrepoException
executable:     /usr/bin/dnfdragora-updater
kernel:         4.11.8-300.fc26.x86_64
package:        dnfdragora-gui-1.0.1-5.git20170505.2a3b056.fc26
reason:         __init__.py:250:_handle_dbus_error:dnfdaemon.client.DaemonError: g-io-error-quark: GDBus.Error:org.freedesktop.DBus.Python.dnf.exceptions.RepoError: Traceback (most recent call last):
runlevel:       N 5
type:           Python3
uid:            1000

Comment 15 Douglas 2017-07-12 23:48:33 UTC
*** Bug 1470408 has been marked as a duplicate of this bug. ***

Comment 16 Phil Da Rocha 2017-07-13 12:44:49 UTC
*** Bug 1470674 has been marked as a duplicate of this bug. ***

Comment 17 Paul Bernal 2017-07-13 19:48:12 UTC
*** Bug 1470849 has been marked as a duplicate of this bug. ***

Comment 18 Paul Robertson 2017-07-14 00:21:18 UTC
Similar problem has been detected:

First boot on a live usb and I got the notification that this crashed.

reporter:       libreport-2.9.1
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: perform
exception_type: librepo.LibrepoException
executable:     /usr/bin/dnfdragora-updater
kernel:         4.11.8-300.fc26.x86_64
package:        dnfdragora-gui-1.0.1-5.git20170505.2a3b056.fc26
reason:         __init__.py:250:_handle_dbus_error:dnfdaemon.client.DaemonError: g-io-error-quark: GDBus.Error:org.freedesktop.DBus.Python.dnf.exceptions.RepoError: Traceback (most recent call last):
runlevel:       N 5
type:           Python3
uid:            1000

Comment 19 steven.woods3 2017-07-14 05:43:08 UTC
Similar problem has been detected:

trying to begin installing

reporter:       libreport-2.9.1
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: perform
exception_type: librepo.LibrepoException
executable:     /usr/bin/dnfdragora-updater
kernel:         4.11.8-300.fc26.x86_64
package:        dnfdragora-gui-1.0.1-5.git20170505.2a3b056.fc26
reason:         __init__.py:250:_handle_dbus_error:dnfdaemon.client.DaemonError: g-io-error-quark: GDBus.Error:org.freedesktop.DBus.Python.dnf.exceptions.RepoError: Traceback (most recent call last):
runlevel:       N 5
type:           Python3
uid:            1000

Comment 20 Adan Schwindt 2017-07-15 05:55:27 UTC
*** Bug 1471350 has been marked as a duplicate of this bug. ***

Comment 21 Richard Haakma 2017-07-15 12:32:47 UTC
Similar problem has been detected:

Booting up from ISO image on a USB memory. Error happened after clicking Log On

reporter:       libreport-2.9.1
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: perform
exception_type: librepo.LibrepoException
executable:     /usr/bin/dnfdragora-updater
kernel:         4.11.8-300.fc26.x86_64
package:        dnfdragora-gui-1.0.1-5.git20170505.2a3b056.fc26
reason:         __init__.py:250:_handle_dbus_error:dnfdaemon.client.DaemonError: g-io-error-quark: GDBus.Error:org.freedesktop.DBus.Python.dnf.exceptions.RepoError: Traceback (most recent call last):
runlevel:       N 5
type:           Python3
uid:            1000

Comment 22 Tiberiu Petre 2017-07-15 15:00:52 UTC
*** Bug 1471391 has been marked as a duplicate of this bug. ***

Comment 23 Chris Krum 2017-07-17 14:54:42 UTC
*** Bug 1471877 has been marked as a duplicate of this bug. ***

Comment 24 lsdomingos 2017-07-20 07:22:15 UTC
*** Bug 1473165 has been marked as a duplicate of this bug. ***

Comment 25 Muhammad Hallaj bin Subery 2017-07-22 04:54:03 UTC
*** Bug 1473893 has been marked as a duplicate of this bug. ***

Comment 26 Don Smouse 2017-07-23 05:02:49 UTC
*** Bug 1474005 has been marked as a duplicate of this bug. ***

Comment 27 lsdomingos 2017-07-25 07:12:27 UTC
*** Bug 1474674 has been marked as a duplicate of this bug. ***

Comment 28 klier.daniel.19 2017-07-29 08:45:07 UTC
*** Bug 1476462 has been marked as a duplicate of this bug. ***

Comment 29 Cedric A Johnson Sr 2017-07-29 23:50:45 UTC
*** Bug 1476530 has been marked as a duplicate of this bug. ***

Comment 30 orti1980 2017-08-02 14:03:19 UTC
*** Bug 1477637 has been marked as a duplicate of this bug. ***

Comment 31 Andrey Kruglov 2017-08-05 11:24:31 UTC
*** Bug 1478635 has been marked as a duplicate of this bug. ***

Comment 32 lucbaddalbmen95 2017-08-05 14:47:44 UTC
*** Bug 1478645 has been marked as a duplicate of this bug. ***

Comment 33 BK 2017-08-06 05:32:57 UTC
*** Bug 1478683 has been marked as a duplicate of this bug. ***

Comment 34 revoman 2017-08-07 16:50:04 UTC
*** Bug 1479000 has been marked as a duplicate of this bug. ***

Comment 35 ATLANTIAN KING 2017-08-09 22:49:11 UTC
*** Bug 1480010 has been marked as a duplicate of this bug. ***

Comment 36 orti1980 2017-08-11 16:29:06 UTC
*** Bug 1480666 has been marked as a duplicate of this bug. ***

Comment 37 Miroslav Avramov 2017-08-12 20:30:11 UTC
*** Bug 1480909 has been marked as a duplicate of this bug. ***

Comment 38 klier.daniel.19 2017-08-14 09:42:04 UTC
*** Bug 1481168 has been marked as a duplicate of this bug. ***

Comment 39 corpdanm 2017-08-16 01:10:36 UTC
*** Bug 1481904 has been marked as a duplicate of this bug. ***

Comment 40 Arief Amarullah 2017-08-20 05:46:57 UTC
*** Bug 1483288 has been marked as a duplicate of this bug. ***

Comment 41 vaclav 2017-08-28 04:51:12 UTC
*** Bug 1485775 has been marked as a duplicate of this bug. ***

Comment 42 phcloc 2017-08-29 15:31:43 UTC
*** Bug 1486380 has been marked as a duplicate of this bug. ***

Comment 43 Nur Cholikul Anwar 2017-09-05 02:57:51 UTC
*** Bug 1488282 has been marked as a duplicate of this bug. ***

Comment 44 andrea 2017-09-12 06:47:24 UTC
*** Bug 1490723 has been marked as a duplicate of this bug. ***

Comment 45 Effendi eL'Mut 2017-09-14 11:31:06 UTC
Similar problem has been detected:

After a fresh install, before the initial dnf update took place

reporter:       libreport-2.9.1
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: perform
exception_type: librepo.LibrepoException
executable:     /usr/bin/dnfdragora-updater
kernel:         4.11.8-300.fc26.x86_64
package:        dnfdragora-gui-1.0.1-5.git20170505.2a3b056.fc26
reason:         __init__.py:250:_handle_dbus_error:dnfdaemon.client.DaemonError: g-io-error-quark: GDBus.Error:org.freedesktop.DBus.Python.dnf.exceptions.RepoError: Traceback (most recent call last):
runlevel:       N 5
type:           Python3
uid:            1000

Comment 46 Doncho Gunchev 2017-09-17 16:59:37 UTC
Similar problem has been detected:

I just logged in...

reporter:       libreport-2.9.1
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: perform
exception_type: librepo.LibrepoException
executable:     /usr/bin/dnfdragora-updater
kernel:         4.12.12-300.fc26.x86_64
package:        dnfdragora-gui-1.0.1-5.git20170505.2a3b056.fc26
reason:         __init__.py:250:_handle_dbus_error:dnfdaemon.client.DaemonError: g-io-error-quark: GDBus.Error:org.freedesktop.DBus.Python.dnf.exceptions.RepoError: Traceback (most recent call last):
runlevel:       N 5
type:           Python3
uid:            1000

Comment 47 seikainc 2017-09-20 00:53:33 UTC
*** Bug 1493335 has been marked as a duplicate of this bug. ***

Comment 48 Jesse Kasuku 2017-09-24 06:39:03 UTC
*** Bug 1494918 has been marked as a duplicate of this bug. ***

Comment 49 Vladan Kudlac 2017-09-24 17:06:25 UTC
Similar problem has been detected:

Problem occurs after every startup

reporter:       libreport-2.9.1
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: perform
exception_type: librepo.LibrepoException
executable:     /usr/bin/dnfdragora-updater
kernel:         4.11.8-300.fc26.i686+PAE
package:        dnfdragora-gui-1.0.1-5.git20170505.2a3b056.fc26
reason:         __init__.py:250:_handle_dbus_error:dnfdaemon.client.DaemonError: g-io-error-quark: GDBus.Error:org.freedesktop.DBus.Python.dnf.exceptions.RepoError: Traceback (most recent call last):
runlevel:       N 5
type:           Python3
uid:            1000

Comment 50 Jesse Kasuku 2017-09-26 06:40:54 UTC
*** Bug 1495465 has been marked as a duplicate of this bug. ***

Comment 51 Mike 2017-09-27 18:05:17 UTC
*** Bug 1496555 has been marked as a duplicate of this bug. ***

Comment 52 Yauhen Lazurkin 2017-09-30 07:43:31 UTC
*** Bug 1497405 has been marked as a duplicate of this bug. ***

Comment 53 vikram goyal 2017-10-08 14:05:42 UTC
Similar problem has been detected:

Network was down. This app always crashes when the network is down

reporter:       libreport-2.9.1
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: perform
exception_type: librepo.LibrepoException
executable:     /usr/bin/dnfdragora-updater
kernel:         4.11.11-300.fc26.x86_64
package:        dnfdragora-gui-1.0.1-5.git20170505.2a3b056.fc26
reason:         __init__.py:250:_handle_dbus_error:dnfdaemon.client.DaemonError: g-io-error-quark: GDBus.Error:org.freedesktop.DBus.Python.dnf.exceptions.RepoError: Traceback (most recent call last):
runlevel:       N 5
type:           Python3
uid:            1000

Comment 54 Ihar Hryshko 2017-10-08 15:18:07 UTC
*** Bug 1499557 has been marked as a duplicate of this bug. ***

Comment 55 markeenmelo 2017-10-11 04:03:00 UTC
*** Bug 1500568 has been marked as a duplicate of this bug. ***

Comment 56 Ivon 2017-10-15 12:19:46 UTC
*** Bug 1502245 has been marked as a duplicate of this bug. ***

Comment 57 Jorge Rivera 2017-10-16 03:09:18 UTC
*** Bug 1502388 has been marked as a duplicate of this bug. ***

Comment 58 Jorge Rivera 2017-10-16 15:11:54 UTC
Similar problem has been detected:

Just starting the live usb

reporter:       libreport-2.9.1
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: perform
exception_type: librepo.LibrepoException
executable:     /usr/bin/dnfdragora-updater
kernel:         4.11.8-300.fc26.x86_64
package:        dnfdragora-gui-1.0.1-5.git20170505.2a3b056.fc26
reason:         __init__.py:250:_handle_dbus_error:dnfdaemon.client.DaemonError: g-io-error-quark: GDBus.Error:org.freedesktop.DBus.Python.dnf.exceptions.RepoError: Traceback (most recent call last):
runlevel:       N 5
type:           Python3
uid:            1000

Comment 59 tmccomish 2017-10-21 01:25:03 UTC
*** Bug 1505009 has been marked as a duplicate of this bug. ***

Comment 60 Sr Neko 2017-10-21 18:01:53 UTC
Similar problem has been detected:

me notifico el sistema al iniciar por primera vez fedora

reporter:       libreport-2.9.1
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: perform
exception_type: librepo.LibrepoException
executable:     /usr/bin/dnfdragora-updater
kernel:         4.11.8-300.fc26.x86_64
package:        dnfdragora-gui-1.0.1-5.git20170505.2a3b056.fc26
reason:         __init__.py:250:_handle_dbus_error:dnfdaemon.client.DaemonError: g-io-error-quark: GDBus.Error:org.freedesktop.DBus.Python.dnf.exceptions.RepoError: Traceback (most recent call last):
runlevel:       N 5
type:           Python3
uid:            1000

Comment 61 pcbaker001 2017-10-25 00:21:34 UTC
*** Bug 1506060 has been marked as a duplicate of this bug. ***

Comment 62 tdoom 2017-10-25 21:50:09 UTC
*** Bug 1506397 has been marked as a duplicate of this bug. ***

Comment 63 Evgeniy Kravchenko 2017-10-27 07:32:50 UTC
*** Bug 1506921 has been marked as a duplicate of this bug. ***

Comment 64 Paulim_hed 2017-11-04 03:47:00 UTC
*** Bug 1509503 has been marked as a duplicate of this bug. ***

Comment 65 Vasile-Florin Tarta 2017-11-05 11:38:17 UTC
*** Bug 1509639 has been marked as a duplicate of this bug. ***

Comment 66 Doncho Gunchev 2017-11-10 09:02:43 UTC
Similar problem has been detected:

Most likely I had no Internet connection.

reporter:       libreport-2.9.1
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: perform
exception_type: librepo.LibrepoException
executable:     /usr/bin/dnfdragora-updater
kernel:         4.13.11-200.fc26.x86_64
package:        dnfdragora-gui-1.0.1-5.git20170505.2a3b056.fc26
reason:         __init__.py:250:_handle_dbus_error:dnfdaemon.client.DaemonError: g-io-error-quark: GDBus.Error:org.freedesktop.DBus.Python.dnf.exceptions.RepoError: Traceback (most recent call last):
runlevel:       N 5
type:           Python3
uid:            1000

Comment 67 phyz 2017-11-10 19:21:14 UTC
*** Bug 1512079 has been marked as a duplicate of this bug. ***

Comment 68 riyan 2017-11-12 13:37:50 UTC
*** Bug 1512299 has been marked as a duplicate of this bug. ***

Comment 69 4nndee 2017-11-14 07:25:13 UTC
*** Bug 1512808 has been marked as a duplicate of this bug. ***

Comment 70 Petr Kloutvor 2017-11-16 06:22:27 UTC
*** Bug 1513852 has been marked as a duplicate of this bug. ***

Comment 71 4nndee 2017-11-18 09:28:22 UTC
*** Bug 1514750 has been marked as a duplicate of this bug. ***

Comment 72 John W Smith 2017-12-20 17:28:24 UTC
Similar problem has been detected:

Occurs consistently on boot up

reporter:       libreport-2.9.1
cmdline:        /usr/bin/python3 /usr/bin/dnfdragora-updater
crash_function: perform
exception_type: librepo.LibrepoException
executable:     /usr/bin/dnfdragora-updater
kernel:         4.14.4-200.fc26.x86_64
package:        dnfdragora-gui-1.0.1-5.git20170505.2a3b056.fc26
reason:         __init__.py:250:_handle_dbus_error:dnfdaemon.client.DaemonError: g-io-error-quark: GDBus.Error:org.freedesktop.DBus.Python.dnf.exceptions.RepoError: Traceback (most recent call last):
runlevel:       N 5
type:           Python3
uid:            1000

Comment 73 Fedora Update System 2017-12-29 23:19:35 UTC
dnfdaemon-0.3.18-5.fc27 dnfdragora-1.0.1-8.git20171229.24e4647.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-d66bd84f06

Comment 74 Fedora Update System 2017-12-29 23:25:52 UTC
dnfdaemon-0.3.18-5.fc26 dnfdragora-1.0.1-8.git20171229.24e4647.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-8caadb4a1b

Comment 75 Fedora Update System 2017-12-30 19:52:46 UTC
dnfdaemon-0.3.18-5.fc27, dnfdragora-1.0.1-8.git20171229.24e4647.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-d66bd84f06

Comment 76 Fedora Update System 2017-12-30 20:38:39 UTC
dnfdaemon-0.3.18-5.fc26, dnfdragora-1.0.1-8.git20171229.24e4647.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-8caadb4a1b

Comment 77 Fedora Update System 2017-12-31 21:26:08 UTC
dnfdaemon-0.3.18-5.fc27, dnfdragora-1.0.1-8.git20171229.24e4647.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 78 Fedora Update System 2018-01-01 22:09:57 UTC
dnfdaemon-0.3.18-5.fc26, dnfdragora-1.0.1-8.git20171229.24e4647.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.