Bug 14495 - kudzu cannot detect internal non-PNP modem
kudzu cannot detect internal non-PNP modem
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
7.3
alpha Linux
high Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-23 17:55 EDT by mchampig
Modified: 2014-03-16 22:14 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-17 01:11:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mchampig 2000-07-23 17:55:08 EDT
Kudzu cannot detect an internal ISA Diamond SupraExpress 56i modem. If I configure
the card as PNP though, and set it up with isapnptools, kudzu recognizes the card
as a generic serial modem and I see a record for it in /etc/sysconfig/*.

It's only when I set up the card with hardcoded IRQ and I/O port. This has *always* worked
in this mode since RedHat 4.0 so I know something is not quite right. I set up the card
with IRQ 5 and port 0x3e8 (/proc/ioports and /proc/interrupts shows that this does not
conflict, as does isapnp tools when I set it up as PNP). 

My /etc/rc.serial is as follows:

/bin/setserial /dev/ttyS2 port 0x3e8 irq 5 autoconfig
/bin/stty 115200 < /dev/ttyS2

minicom does see the modem and can dial my ISP with it. kudzu never sees it though.
I ran modemtool to make the symbolic link from /dev/modem.

I then tried to dial out with the modem using rp3 to set up the connection. rp3 never finds
the modem (WTF!!!) despite the symlink and despite checking every /dev/ttyS*.
Again, I should stress that minicom does see the modem and can dial out with it.

The big problem (I think) is that rp3 somehow uses the info that kudzu maintains, and
since kudzu doesn't find the modem, rp3 complains about not detecting a modem.

I should also stress the RH6.x has always worked fine with rp3 and this particular
modem setup.
Comment 1 Bill Nottingham 2000-10-17 01:11:26 EDT
Can you post the strace of running kudzu?
Comment 2 Bill Nottingham 2001-02-01 17:21:09 EST
closing, lack of input in bugzilla.

rp3 doesn't detect it because it uses the kudzu code, IIRC.

Note You need to log in before you can comment on or make changes to this bug.