Bug 1449525 - Set directory ownership in spec file
Summary: Set directory ownership in spec file
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Scott Poore
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-05-10 08:34 UTC by Petr Vobornik
Modified: 2017-08-01 09:50 UTC (History)
6 users (show)

Fixed In Version: ipa-4.5.0-12.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 09:50:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2304 normal SHIPPED_LIVE ipa bug fix and enhancement update 2017-08-01 12:41:35 UTC

Description Petr Vobornik 2017-05-10 08:34:55 UTC
Cloned from upstream: https://pagure.io/freeipa/issue/6927

FreeIPA client package should own `%{python_sitelib}/ipaclient/plugins` directory. There is missing declaration in specfile, which was fixed in 548014f03eeababfd1b49e4bc9ac608633cb9b98 and should be backported to 4.4 and 4.5

Please note that there might be multiple missing directories and we need check missing declarations in specfile.

at least I found:

* ipaclient/install
* ipaclient/remote_plugins
* ipaclient/csrgen

Comment 2 Petr Vobornik 2017-05-10 08:35:12 UTC
Upstream ticket:
https://pagure.io/freeipa/issue/6927

Comment 3 Petr Vobornik 2017-05-10 08:38:07 UTC
It is a spec change. No testing or resp. only regression testing is enough.

Comment 6 Scott Poore 2017-05-25 14:54:53 UTC
Should these directories also be owned by the packages?

[root@rhel7-3 site-packages]# find ipaclient -ls -exec rpm -qf {} \;|grep "is not owned by any package"
file /usr/lib/python2.7/site-packages/ipaclient/remote_plugins/2_114 is not owned by any package
file /usr/lib/python2.7/site-packages/ipaclient/remote_plugins/2_156 is not owned by any package
file /usr/lib/python2.7/site-packages/ipaclient/remote_plugins/2_164 is not owned by any package
file /usr/lib/python2.7/site-packages/ipaclient/remote_plugins/2_49 is not owned by any package

Comment 7 Scott Poore 2017-05-30 15:04:35 UTC
Verified. 

FYI, Martin confirmed that those directories were not necessary for this particular change.  Those are dynamic directories not expected to be used for 3rd party plugins.

Version :: 

ipa-server-4.5.0-13.el7.x86_64


Results ::

See comment #6 above.  Only the remove_plugins/2_* dynamic directories not owned by the package(s).

Comment 8 errata-xmlrpc 2017-08-01 09:50:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2304


Note You need to log in before you can comment on or make changes to this bug.