Bug 144962 - auto-spell and right-clicking stalls the system
auto-spell and right-clicking stalls the system
Status: CLOSED DUPLICATE of bug 124374
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
3
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-12 19:59 EST by Walter J. Mack
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-26 03:47:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Walter J. Mack 2005-01-12 19:59:23 EST
Description of problem:


When auto-spelling is enabled, right-clicking on a mis-spelled word 
makes the PC non-responsive. Memory consumption of writer goes 
through the roof (> 500MB) and sucks up all heap and virtual memory. 
PC becomes non-responsive (not even ctl_alt_f1 works anymore).




Version-Release number of selected component (if applicable):


OpenOffice 1.1.2




How reproducible:


always




Steps to Reproduce:


1.Start writer


2.Make sure auto-spell is enabled


3.write a word mis-spelled (for example helllo)


4.continue typing to have the word underlined (squiggly red line)


5.right-click on the mis-spelled word.


6.




  


Actual results:


observe that drop-down menu is not shown and PC becomes unresponsive.




Expected results:


Expect drop-down menu with spelling suggestion




Additional info:


A similar problem has been reported on OpenOffice for version 1.0.2. 
It also explains a work-around:


The ..../dict/ooo/dictionary.lst file lists DICT en US at least twice 
(there are other duplicated entries in that file too). After deleting 
all entries from the file, except for one copy of each of DICT en US, 
HYPH en US, and THEs en US, the problem disappears.


The problem could therefore be due to either one of the following two 
reasons:


1. OO has a problem with multiple listings in dictionary.lst 
(multiple DICT en US, for example0


2. It hangs on a non-en US entry.




The PC is configured for English/US


The problem occurs on a completely new install of Fedora 3 
(installation started with a completely clean disk).




Suggest that you fix the plain-vanilla dictionary.lst that is 
installed when Fedora 3 installs openoffice.
Comment 1 Sitsofe Wheeler 2005-01-13 03:25:40 EST
This is a dup of bug #124374
Comment 2 Caolan McNamara 2005-01-26 03:47:38 EST

*** This bug has been marked as a duplicate of 124374 ***

Note You need to log in before you can comment on or make changes to this bug.