Bug 144964 - fc3 install fails on disk geometry probe
fc3 install fails on disk geometry probe
Status: CLOSED DUPLICATE of bug 138419
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-12 20:20 EST by Charles Puffe
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-16 12:44:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charles Puffe 2005-01-12 20:20:26 EST
Description of problem:
fc3 install fails on disk geometry probe.  Bug box containing 
text "Assertion (heads < 256) at disk_dos.c:486 in function 
probe_partition_for_geom() failed." appears numerous times when 
partitioning procedure begins, at package installation point bug 
boxes reappear then catastrophic system error occurs.

Drive metrics from dumplog:
ide0: BM-DMA at 0xf000-0xf007, BIOS settings: hda:DMA, hdb:DMA
<6>    ide1: BM-DMA at 0xf008-0xf00f, BIOS settings: hdc:DMA, hdd:DMA
<7>Probing IDE interface ide0...
<4>hda: WDC WD800BB-55JKA0, ATA DISK drive
<4>hdb: WDC WD400BB-00DEA0, ATA DISK drive
<4>Using cfq io scheduler
<4>ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
<7>Probing IDE interface ide1...
<4>hdc: CR-48XGTE, ATAPI CD/DVD-ROM drive
<4>hdd: JLMS XJ-HD166S, ATAPI CD/DVD-ROM drive
<4>ide1 at 0x170-0x177,0x376 on irq 15
<7>Probing IDE interface ide2...
<7>ide2: Wait for ready failed before probe !
<7>Probing IDE interface ide3...
<7>ide3: Wait for ready failed before probe !
<7>Probing IDE interface ide4...
<7>ide4: Wait for ready failed before probe !
<7>Probing IDE interface ide5...
<7>ide5: Wait for ready failed before probe !
<6>hda: max request size: 128KiB
<6>hda: 156301488 sectors (80026 MB) w/2048KiB Cache, 
CHS=65535/16/63, UDMA(100)
<7>hda: cache flushes supported
<6> hda: hda1
<6>hdb: max request size: 128KiB
<6>hdb: 78165360 sectors (40020 MB) w/2048KiB Cache, CHS=65535/16/63, 
UDMA(100)
<7>hdb: cache flushes not supported
<6> hdb: hdb1 hdb2 < hdb5 hdb6 >

hda1 is NTFS 80gb partition of ide0.
hdb1 is NTFS 35gb partition of ide1.
hdb2 is extended partition of ide1 containing hdb5 and hdb6.
hdb5 is ext3 4gb partition of ide1.
hdb6 is swap 1gb partition of ide1.

Error information from the dumplog:
Traceback (most recent call last):
  File "/usr/src/build/475969-i386/install//usr/lib/anaconda/gui.py", 
line 1074, in handleRenderCallback
    self.currentWindow.renderCallback()
  File "/usr/src/build/475969-
i386/install//usr/lib/anaconda/iw/progress_gui.py", line 242, in 
renderCallback
    self.intf.icw.nextClicked()
  File "/usr/src/build/475969-i386/install//usr/lib/anaconda/gui.py", 
line 789, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/src/build/475969-
i386/install//usr/lib/anaconda/dispatch.py", line 171, in gotoNext
    self.moveStep()
  File "/usr/src/build/475969-
i386/install//usr/lib/anaconda/dispatch.py", line 239, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/src/build/475969-
i386/install//usr/lib/anaconda/packages.py", line 551, in 
turnOnFilesystems
    diskset.savePartitions ()
  File "/usr/src/build/475969-
i386/install//usr/lib/anaconda/partedUtils.py", line 715, in 
savePartitions
    disk.commit()
error: Bug: Assertion (heads < 256) at disk_dos.c:486 in function 
probe_partition_for_geom() failed.
Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
attempt installation from cd-rom.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jeremy Katz 2005-01-12 22:07:28 EST

*** This bug has been marked as a duplicate of 138419 ***

Note You need to log in before you can comment on or make changes to this bug.