Bug 14497 - rp3 cannot detect or initialize internal ISA modem
rp3 cannot detect or initialize internal ISA modem
Product: Red Hat Linux
Classification: Retired
Component: rp3 (Show other bugs)
alpha Linux
high Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
Depends On:
  Show dependency treegraph
Reported: 2000-07-23 18:06 EDT by mchampig
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-01-16 19:42:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description mchampig 2000-07-23 18:06:05 EDT
I've been using the same internal ISA Diamond SupraExpress 56i since RedHat 4.0
and only with this release am I having trouble dialing my ISP.

First off, I tried using the modem in PNP mode and used isapnp tools to configure
the modem. IRQ 4 and I/O port 0x3e8 using COM3 (/dev/ttyS2). /proc/ioports and
/proc/interrupts shows the modem set up properly and isapnp finds no conflicts. 
I reboot and kudzu detected the modem and set it up as generic serial modem.
I ran modemtool and it set up the proper symlink.

I then ran the PPP configure tool (rp3/wvdial) to set up dialup to my ISP.
First it tries to detect the modem. It comes back with two radio buttons, one
of them checked, but no text near the check buttons! Whatever. So I leave
it where it's at and on the next screen it opens the modem setup screen.
It had chosen the wrong tty (it said it was on /dev/ttyS0). I set it back to
/dev/ttyS2. I then set up my ISP info (just as I'd always done since the RH6.0
days). I ran the Debug mode to test the dial up procedure. My modem dials
and I'm connected just fine to my ISP. All protocols work fine (ftp/httpd) and I
can ping other machines, pop mail, etc.

Now, the strange thing is this. I can *only* dial up my ISP using the DEBUG
mode. I *cannot* use the usernet utility to dial up. My modem never dials out!!!!
I get a modem initialization error when I try to dial out with any other RH tool.
Only the DEBUG mode in rp3 will allow me to dial in. And as soon as I click
on Cancel or Close the line disconnects. :-(

Something odd happened since RH 6.2 which gives me a bad taste in the mouth
with the whole rp3/wvdial situation. There is something broken badly here and I'll
try to give you more details if I can.
Comment 1 Tim Waugh 2000-08-01 09:45:59 EDT
What does it say in /etc/wvdial.conf?
Comment 2 Michael Fulbright 2001-01-16 19:42:06 EST
Closing due inactivity.

Note You need to log in before you can comment on or make changes to this bug.