Bug 1449752 - blivet-gui desktop file should not be installed by default in Fedora Workstation
Summary: blivet-gui desktop file should not be installed by default in Fedora Workstation
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: blivet-gui
Version: 26
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Vojtech Trefny
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedBlocker
Depends On:
Blocks: F26FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2017-05-10 15:10 UTC by Michael Catanzaro
Modified: 2017-07-06 22:51 UTC (History)
11 users (show)

Fixed In Version: blivet-gui-2.1.5-2.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-07-06 22:51:24 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1462655 None NEW [RFE] Allow removing packages when installing from LiveCD image 2019-10-01 17:16:34 UTC

Internal Links: 1462655

Description Michael Catanzaro 2017-05-10 15:10:45 UTC
Description of problem: blivet-gui has appeared in the default Workstation install of F26 Alpha. The set of applications installed by default is carefully-curated by the Workstation WG, and blivet-gui is not desired.


Version-Release number of selected component (if applicable): F26 alpha


How reproducible: Always


Steps to Reproduce:
1. Boot F26 alpha live USB
2. Visit GNOME Shell overview

Actual results: Notice that blivet-gui is installed and visible in the GNOME Shell overview


Expected results: blivet-gui should not be visible in the GNOME Shell overview


Additional info: I notice that anaconda seems to require blivet-gui to be installed. If it has to be installed for valid technical reasons, then the desktop file will have to be split off into a subpackage that is not installed by default. It's odd to have a package that only installs a desktop file, but it's not unprecedented.

Comment 1 Michael Catanzaro 2017-05-10 15:22:14 UTC
(In reply to Michael Catanzaro from comment #0)
> Additional info: I notice that anaconda seems to require blivet-gui to be
> installed. If it has to be installed for valid technical reasons, then the
> desktop file will have to be split off into a subpackage that is not
> installed by default. It's odd to have a package that only installs a
> desktop file, but it's not unprecedented.

Oh, I should add: the appdata file should go into the subpackage as well, along with the desktop file.

The pattern we've used in the past in these situations is actually a bit different... for Epiphany we have the desktop file and appdata file in the main epiphany package, but the binary and almost everything else in an epiphany-runtime package. Then the epiphany package requires the epiphany-runtime package. That's probably the best thing to do here, so anaconda can continue using blivet-gui by depending on blivet-gui-runtime to keep Anaconda folks happy, without blivet-gui appearing as an installed application so that us Workstation folks stay happy.

Comment 2 Vratislav Podzimek 2017-05-11 08:21:48 UTC
I'm sorry, but this request doesn't make sense to me.

> The set of applications installed by default is carefully-curated by the Workstation WG, and blivet-gui is not desired.

Fair enough, then let's find a technical solution for the application to not be installed in the system at all then (the whole Anaconda and a bunch of other things shouldn't be there too). But having everything installed and just hiding it from users sounds like Windows to me...

Also what is the process to make blivet-gui desired by Workstation WG? It's the only tool capable of working with the default Fedora storage/partitioning scheme and all common workstation storage technologies.

Comment 3 Michael Catanzaro 2017-05-11 12:49:57 UTC
(In reply to Vratislav Podzimek from comment #2)
> Also what is the process to make blivet-gui desired by Workstation WG? It's
> the only tool capable of working with the default Fedora
> storage/partitioning scheme and all common workstation storage technologies.

You can propose it on our Pagure tracker https://pagure.io/fedora-workstation/issues, but I really doubt it would be accepted as we already have an existing (albeit less-capable) disk management tool, GNOME Disks.

(In reply to Vratislav Podzimek from comment #2)
> Fair enough, then let's find a technical solution for the application to not
> be installed in the system at all then (the whole Anaconda and a bunch of
> other things shouldn't be there too). But having everything installed and
> just hiding it from users sounds like Windows to me...

Well yes, we should do that, but I don't think it will be sufficient, because then you won't be able to have Anaconda on the live images. We don't want blivet-gui to appear there either. blivet-gui is now effectively a service used by another application, and as long as that's the case it makes sense to move the desktop launcher and appdata file into a subpackage. Note that we're preparing draft packaging guidelines to encourage this, see https://pagure.io/fedora-workstation/issue/13

Comment 4 Matthias Clasen 2017-05-11 15:05:44 UTC
> It's
> the only tool capable of working with the default Fedora
> storage/partitioning scheme and all common workstation storage technologies.

To be blunt, this is a problem of the default fedora partioning scheme.

Comment 5 Matthias Clasen 2017-05-11 15:08:06 UTC
It has always been a bug that anaconda ends up being installed on the OS after the installation is done. So far, we've ignored it. But if anaconda now pulls in visible applications, we can no longer ignore it.

Comment 6 Petr Schindler 2017-05-22 16:49:21 UTC
Discussed at 2017-05-22 blocker review meeting: [1]. 

This bug was accepted as Final blocker: The Workstation WG has voted that this issue is serious enough to warrant blocking their Edition

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2017-05-22

Comment 7 Michael Catanzaro 2017-05-22 17:04:12 UTC
See also these tracking bugs:

https://pagure.io/fedora-workstation/issue/14
https://pagure.io/fedora-workstation/issue/15

Moving the desktop file to a subpackage is definitely the easiest solution to this problem. It might seem weird to you, but it's often necessary when applications decide to depend on each other. But we're OK with any resolution to this issue so long as blivet-gui does not appear in the shell overview on (a) the Workstation live USB or (b) the installed system.

Comment 8 Adam Williamson 2017-06-14 18:27:56 UTC
Ping? We are now out of Beta stage and onto Final stage. Final blockers need to get resolved. There's no technical barrier to solving this, AFAICS, it just needs someone to decide how exactly they want to achieve the goal, and do it.

Comment 9 Vojtech Trefny 2017-06-19 08:04:00 UTC
Splitting blivet-gui package into "desktop file" and "everything else" is a really bad solution for this problem, but we don't have time for a better one, so I'll do this for Fedora 26 a we'll try to come up with a better solution for Fedora 27 together with Anaconda devs.

Comment 10 Martin Kolman 2017-06-19 10:38:50 UTC
(In reply to Vojtech Trefny from comment #9)
> Splitting blivet-gui package into "desktop file" and "everything else" is a
> really bad solution for this problem, but we don't have time for a better
> one, so I'll do this for Fedora 26 a we'll try to come up with a better
> solution for Fedora 27 together with Anaconda devs.
Yeah, it's really too late for anything else for F26.

But we really need to come up with something else for F27 - just hiding an icon of a useful application but still leaving all of it & it's dependencies installed on the  system is really sub-optimal.

Comment 11 Martin Kolman 2017-06-19 10:45:38 UTC
(In reply to Matthias Clasen from comment #4)
> > It's
> > the only tool capable of working with the default Fedora
> > storage/partitioning scheme and all common workstation storage technologies.
> 
> To be blunt, this is a problem of the default fedora partioning scheme.
So Fedora should use a less capable and less robust partitioning scheme because the default graphical partitioning tool on the Workstation can't fully work with it ? 

That's doesn't make sense to me, especially when there are graphical tools (Blivet GUI) fully supporting the default partitioning scheme that can be used to supplement (or maybe in time even replace ?) the default graphical tools.

Comment 12 Michael Catanzaro 2017-06-23 13:51:56 UTC
Anyway, the default partitioning scheme is not relevant to this issue.

Comment 13 Adam Williamson 2017-06-29 01:17:31 UTC
As we're past final freeze, it'd be good if the proposed fix for this can be implemented as soon as possible, so we can catch any unexpected issues with it. Thanks!

Comment 14 Fedora Update System 2017-06-30 11:25:43 UTC
anaconda-26.21.11-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-88f80a61da

Comment 15 Fedora Update System 2017-06-30 20:26:36 UTC
anaconda-26.21.11-1.fc26, blivet-gui-2.1.5-2.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-88f80a61da

Comment 16 Matthew Miller 2017-07-02 17:59:53 UTC
Confirming that this is not installed by default in RC 1.3.

Comment 17 Kamil Páral 2017-07-03 12:36:58 UTC
Also confirmed.

Comment 18 Fedora Update System 2017-07-06 22:51:24 UTC
anaconda-26.21.11-1.fc26, blivet-gui-2.1.5-2.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.