Bug 144981 - Applications always open new window not a tab (ignoring preferences)
Applications always open new window not a tab (ignoring preferences)
Status: CLOSED DUPLICATE of bug 138789
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Depends On:
  Show dependency treegraph
Reported: 2005-01-13 07:16 EST by Ondrej Svetlik
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:07:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Ondrej Svetlik 2005-01-13 07:16:30 EST
Description of problem:
Script /usr/bin/firefox doesn't open given link in a new tab (set
correctly in preferences) but in a new window. Script
/usr/lib/firefox-1.0/firefox works fine.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. run firefox
2. set it to load new links opened by an application to a new tab
3. from shell run firefox again with some link

Actual results:
Firefox opens a new window with given link.

Expected results:
New tab should be opened in the old window.

Additional info:
To solve this issue try:
rm -f /usr/bin/firefox
ln -s /usr/lib/firefox-1.0/firefox /usr/bin/firefox

This works for me.
Comment 1 Thilo Pfennig 2005-02-19 07:52:46 EST
Does not work for me.

Steps to reproduce:

 1. Open in GNOME "gnome-default-application-properties"
 2. change browser to "firefox -remote 'openURL(%s,new-tab)'
 3. Maybe click a link in evolution

Actual results:

no windows is opening and no tab

Expected results:

new tab is opening

Additional info:
Works via command line. Is this a GNOME problem?

Comment 2 Matthew Miller 2005-02-28 10:38:00 EST

*** This bug has been marked as a duplicate of 138789 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:07:54 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.