This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 144984 - .bash_logout file is different depending on how user created
.bash_logout file is different depending on how user created
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: bash (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-13 09:09 EST by John Horne
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-13 09:58:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Horne 2005-01-13 09:09:04 EST
Description of problem:
Created a non-user account during the installation process. Once FC3
fully installed and rebooted then created another account using
'useradd' command. The .bash_logout file is different in each account.

The installation account .bash_logout file has the size of 24 bytes,
as does the root account one. The account created by useradd uses the
.bash_logout in /etc/skel, and this has a size of 302 bytes since it
includes gpm code.

Version-Release number of selected component (if applicable):
bash-3.0-18
shadow-utils-4.0.3-56
kernel-2.6.10-1.737_FC3

How reproducible:




Steps to Reproduce:
1.Install FC3 and create a non-user account when prompted.
2.After installation and reboot, create another account.
3.If you have FC3 already installed then just create an account with
useradd and compare the .bash_logout to the one in the root account.
  
Actual results:
Files are of different sizes.

Expected results:
Same file should exist in all accounts.

Additional info:
Comment 1 Tim Waugh 2005-01-13 09:58:05 EST
The /etc/skel/.bash_logout file was altered in an update.

Note You need to log in before you can comment on or make changes to this bug.