Bug 1449985 - Suggest CA installation command in KRA installation warning
Summary: Suggest CA installation command in KRA installation warning
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.4
Hardware: Unspecified
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: ipa-qe
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-05-11 09:54 UTC by Abhijeet Kasurde
Modified: 2018-04-10 16:41 UTC (History)
6 users (show)

Fixed In Version: ipa-4.5.4-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 16:40:25 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0918 None None None 2018-04-10 16:41:35 UTC

Description Abhijeet Kasurde 2017-05-11 09:54:50 UTC
Description of problem:
As user, I would like to see CA installation command in KRA installation warning. 

It will be very handy for administrators. The fix for bug will make warning message similar to other installer message where, it suggests command.


# ipa-kra-install
Directory Manager password:

Dogtag CA is not installed. Please install the CA first
The ipa-kra-install command failed. See /var/log/ipaserver-kra-install.log for more information

Version-Release number of selected component (if applicable):
ipa-server-4.5.0-10.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. try install KRA without CA

Actual results:
no command suggestion related to CA installation.

Expected results:
Please install the CA first using `ipa-ca-install'

Comment 2 Petr Vobornik 2017-05-15 15:22:36 UTC
Upstream ticket:
https://pagure.io/freeipa/issue/6952

Comment 4 fbarreto 2017-10-17 14:05:52 UTC
Fixed upstream
master:
https://pagure.io/freeipa/c/48dc9bb9ba86c0708d9042852470f3b968231150

Comment 5 fbarreto 2017-10-17 15:28:47 UTC
Fixed upstream
ipa-4-5:
https://pagure.io/freeipa/c/7fb25bfffd9324021b3951a1418fa84d5ac20f00

Comment 6 fbarreto 2017-10-17 15:30:02 UTC
Fixed upstream
ipa-4-6:
https://pagure.io/freeipa/c/ca09c180a0d751e0e995b83434062bd164021267

Comment 8 Xiyang Dong 2018-01-18 02:19:27 UTC
Verified on ipa-server-4.5.4-8.el7:
:: [  BEGIN   ] :: Running 'ipa-server-install -U             --setup-dns --forwarder=10.16.36.29 -r TESTRELM.TEST             -a Secret123 -p Secret123             --http-cert-file ~/test_ca/servercert.p12             --dirsrv-cert-file ~/test_ca/servercert.p12             --http-pin Secret123             --dirsrv-pin Secret123             --ca-cert-file ~/test_ca/cacert.pem --no-pkinit'

The log file for this installation can be found in /var/log/ipaserver-install.log
==============================================================================
This program will set up the IPA Server.

This includes:
  * Configure the Network Time Daemon (ntpd)
  * Create and configure an instance of Directory Server
  * Create and configure a Kerberos Key Distribution Center (KDC)
  * Configure Apache (httpd)
  * Configure DNS (bind)
.
.
.
==============================================================================
Setup complete

Next steps:
	1. You must make sure these network ports are open:
		TCP Ports:
		  * 80, 443: HTTP/HTTPS
		  * 389, 636: LDAP/LDAPS
		  * 88, 464: kerberos
		  * 53: bind
		UDP Ports:
		  * 88, 464: kerberos
		  * 53: bind
		  * 123: ntp

	2. You can now obtain a kerberos ticket using the command: 'kinit admin'
	   This ticket will allow you to use the IPA tools (e.g., ipa user-add)
	   and the web user interface.

In order for Firefox autoconfiguration to work you will need to
use a SSL signing certificate. See the IPA documentation for more details.

# ipa-kra-install
Directory Manager password: 

Dogtag CA is not installed. Please install a CA first with the `ipa-ca-install` command.
The ipa-kra-install command failed. See /var/log/ipaserver-kra-install.log for more information

Comment 11 errata-xmlrpc 2018-04-10 16:40:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0918


Note You need to log in before you can comment on or make changes to this bug.