Bug 1450015 - Regression in openssl req -x509 in openssl-1.0.2
Summary: Regression in openssl req -x509 in openssl-1.0.2
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: openssl
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Tomas Mraz
QA Contact: Stefan Dordevic
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-05-11 11:51 UTC by Tomas Mraz
Modified: 2017-08-01 18:18 UTC (History)
2 users (show)

Fixed In Version: openssl-1.0.2k-8.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 18:18:39 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1929 0 normal SHIPPED_LIVE openssl bug fix and enhancement update 2017-08-01 18:08:01 UTC

Description Tomas Mraz 2017-05-11 11:51:57 UTC
Description of problem:
The openssl req -x509 now implies -newreq and thus there is no way to convert from existing request to self signed X.509 via openssl req command.

This is regression from 1.0.1 in current 1.0.2 and 1.1.0 releases.

See also https://github.com/openssl/openssl/issues/3396

Comment 4 errata-xmlrpc 2017-08-01 18:18:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1929


Note You need to log in before you can comment on or make changes to this bug.