Bug 145009 - RPM spec file is missing a number of BuildRequires lines
RPM spec file is missing a number of BuildRequires lines
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: am-utils (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-13 13:31 EST by Daniel Berrange
Modified: 2015-01-07 19:09 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-05 16:06:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2005-01-13 13:31:18 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624 Netscape/7.1 (ax)

Description of problem:
I have a minimal RHEL 3 AS, Update 4 installation, and when attempting to run 'rpmbuild --rebuild'  on the am-utils source RPM, it will begin the build process, but fail part way through due to missing tools & libraries. It would appear to need the following additional BuildRequires entries in the specfile:

automake
libtool
bison
flex

Version-Release number of selected component (if applicable):
am-utils-6.0.9-2

How reproducible:
Always

Steps to Reproduce:
1. Install a minimal RHEL 3 AS disto, without automake, libtool, bison or flex
2. Run 'rpmbuild --rebuild' on the am-utils source RPM
3.
  

Actual Results:  The compilation fails part way through

Expected Results:  rpmbuild exits detailing the missing build requirements.

Additional info:
Comment 1 Peter Vrabec 2005-02-23 09:24:46 EST
Are u sure about bison? I had no problem rebuild am-utils without
bison installed.

Comment 2 Daniel Berrange 2005-02-23 11:50:07 EST
Just double checked & yes it does fail for me. Looking more closely at the build
scripts, it appears that am-utils is capable of using either byacc or bison - so
I imagine you have the byacc package installed on your build machine. If I erase
both bison & byacc packages the build fails with

rvr_nfs.c
flex conf_tok.l
mv lex.yy.c conf_tok.c
yacc -d conf_parse.y
make[2]: yacc: Command not found
make[2]: *** [conf_parse.h] Error 127
make[2]: Leaving directory `/home/berrange/rpm/BUILD/am-utils-6.0.9/amd'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/berrange/rpm/BUILD/am-utils-6.0.9'
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.92333 (%build)

So, guess need to figure out whether byacc or bison is the definitive tool for
building am-utils in RHEL & add the BuildRequires to match that choice.
Comment 4 RHEL Product and Program Management 2006-09-05 15:56:24 EDT
The component this request has been filed against is not planned for inclusion
in the next update. The decision is based on weighting the priority and number
of requests for a component as well as the impact on the Red Hat Enterprise
Linux user-base: other components are considered having higher priority and the
number of changes we intend to include in update cycles is limited.
Comment 5 RHEL Product and Program Management 2006-09-05 16:06:25 EDT
Product Management has reviewed and declined this request.  You may appeal this
decision by reopening this request. 

Note You need to log in before you can comment on or make changes to this bug.