Bug 145017 - ant update fails with missing dependencies on fedora-4-0.20050113 x86_64 set
ant update fails with missing dependencies on fedora-4-0.20050113 x86_64 set
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: ant (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Andrew Overholt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-13 14:40 EST by Michal Jaegermann
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-27 19:11:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2005-01-13 14:40:43 EST
Description of problem:

An attempt to run updates using 20050113 package for x86_64
ends up with the following chain of dependencies:

--> Processing Dependency: java-devel for package: ant
--> Processing Dependency: java-1.4.2-gcj-compat = 0:1.4.2.0-37jpp for
package: java-1.4.2-gcj-compat-devel
--> Processing Dependency: eclipse-ecj for package:
java-1.4.2-gcj-compat-devel
Error: missing dep: eclipse-ecj for pkg java-1.4.2-gcj-compat-devel

None of 'eclipse' packages is actually present for x86_64 although
they are there for i386.  Older ant packages did not try to pull
in any eclipse stuff.

Version-Release number of selected component (if applicable):
ant-1.6.2-3jpp_1fc
Comment 1 Andrew Overholt 2005-01-14 11:22:09 EST
We've removed the old ecj package and replaced it with eclipse-ecj. 
Since both eclipse and ecj were being built from the same source, it
made sense to build them from the same srpm.  I hope to have all
architectures covered with the eclipse packages sometime today at
which point this problem will be resolved.  Sorry about that.
Comment 2 Michal Jaegermann 2005-01-27 19:11:46 EST
Starting with a version 3.0.1_fc-5 there are eclipse-ecj, and related,
packages on x86_64 and "missing dep" is resolved.

Note You need to log in before you can comment on or make changes to this bug.