Bug 1450210 - the collection of fact keys and values should be independent of the system locale
Summary: the collection of fact keys and values should be independent of the system lo...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.4
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: rc
: ---
Assignee: Kevin Howell
QA Contact: John Sefler
URL:
Whiteboard:
: 1449839 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-05-11 20:26 UTC by John Sefler
Modified: 2018-02-06 12:09 UTC (History)
3 users (show)

Fixed In Version: subscription-manager-1.19.15-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 19:23:41 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github candlepin subscription-manager pull 1627 None closed 1450210: Make lscpu ignore locale again 2020-09-16 04:45:58 UTC
Red Hat Product Errata RHBA-2017:2083 normal SHIPPED_LIVE python-rhsm and subscription-manager bug fix and enhancement update 2017-08-01 18:14:19 UTC

Description John Sefler 2017-05-11 20:26:39 UTC
Description of problem:
When the facts of a system are collected, the keys (and values) should be independent of the system's locale.


Version-Release number of selected component (if applicable):
[root@jsefler-rhel7 ~]# rpm -q subscription-manager python-rhsm
subscription-manager-1.19.12-1.el7.x86_64
python-rhsm-1.19.6-1.el7.x86_64


How reproducible:


Steps to Reproduce:
[root@jsefler-rhel7 ~]# LC_ALL=ja_JP.UTF-8 subscription-manager facts --list | grep lscpu
lscpu.bogomips: 4799.99
lscpu.byte_order: Little Endian
lscpu.cpu(s): 2
lscpu.cpu_mhz: 2399.998
lscpu.cpu_op-mode(s): 32-bit, 64-bit
lscpu.cpuファミリー: 6
lscpu.flags: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 syscall nx rdtscp lm constant_tsc rep_good nopl eagerfpu pni pclmulqdq ssse3 cx16 sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx hypervisor lahf_lm xsaveopt
lscpu.l1d_キャッシュ: 32K
lscpu.l1i_キャッシュ: 32K
lscpu.l2_キャッシュ: 4096K
lscpu.model_name: Intel Xeon E312xx (Sandy Bridge)
lscpu.numaノード: 1
lscpu.numaノード_0_cpu: 0,1
lscpu.on-line_cpu(s)_list: 0,1
lscpu.socket(s): 2
lscpu.アーキテクチャ: x86_64
lscpu.コアあたりのスレッド数: 1
lscpu.ステッピング: 1
lscpu.ソケットあたりのコア数: 1
lscpu.ハイパーバイザーベンダー: KVM
lscpu.ベンダーid: GenuineIntel
lscpu.モデル: 42
lscpu.仮想化タイプ: 完全仮想化


Actual results:
  above - notice that many key names are in Japanese.  Moreover, there is a value for virtualization_type in Japanese too.

Expected results:
Expected all of the fact keys and value to be...
lscpu.architecture: x86_64
lscpu.bogomips: 4799.99
lscpu.byte_order: Little Endian
lscpu.core(s)_per_socket: 1
lscpu.cpu(s): 2
lscpu.cpu_family: 6
lscpu.cpu_mhz: 2399.998
lscpu.cpu_op-mode(s): 32-bit, 64-bit
lscpu.flags: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 syscall nx rdtscp lm constant_tsc rep_good nopl eagerfpu pni pclmulqdq ssse3 cx16 sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx hypervisor lahf_lm xsaveopt
lscpu.hypervisor_vendor: KVM
lscpu.l1d_cache: 32K
lscpu.l1i_cache: 32K
lscpu.l2_cache: 4096K
lscpu.model: 42
lscpu.model_name: Intel Xeon E312xx (Sandy Bridge)
lscpu.numa_node(s): 1
lscpu.numa_node0_cpu(s): 0,1
lscpu.on-line_cpu(s)_list: 0,1
lscpu.socket(s): 2
lscpu.stepping: 1
lscpu.thread(s)_per_core: 1
lscpu.vendor_id: GenuineIntel
lscpu.virtualization_type: full


Additional info:
This is a regression that was originally reported and fixed in Bug 1225435.

Comment 1 John Sefler 2017-05-11 20:31:53 UTC
This bug is a regression from the RHEL7.3 RHSM packages where the facts collection was successfully independent of the locale as shown below...

[root@jsefler-rhel7 ~]# rpm -q subscription-manager python-rhsm
subscription-manager-1.17.15-1.el7.x86_64
python-rhsm-1.17.9-1.el7.x86_64

[root@jsefler-rhel7 ~]# LC_ALL=ja_JP.UTF-8 subscription-manager facts --list | grep lscpu
lscpu.architecture: x86_64
lscpu.bogomips: 4799.99
lscpu.byte_order: Little Endian
lscpu.core(s)_per_socket: 1
lscpu.cpu(s): 2
lscpu.cpu_family: 6
lscpu.cpu_mhz: 2399.998
lscpu.cpu_op-mode(s): 32-bit, 64-bit
lscpu.flags: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 syscall nx rdtscp lm constant_tsc rep_good nopl eagerfpu pni pclmulqdq ssse3 cx16 sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx hypervisor lahf_lm xsaveopt
lscpu.hypervisor_vendor: KVM
lscpu.l1d_cache: 32K
lscpu.l1i_cache: 32K
lscpu.l2_cache: 4096K
lscpu.model: 42
lscpu.model_name: Intel Xeon E312xx (Sandy Bridge)
lscpu.numa_node(s): 1
lscpu.numa_node0_cpu(s): 0,1
lscpu.on-line_cpu(s)_list: 0,1
lscpu.socket(s): 2
lscpu.stepping: 1
lscpu.thread(s)_per_core: 1
lscpu.vendor_id: GenuineIntel
lscpu.virtualization_type: full

Comment 3 John Sefler 2017-05-11 20:34:08 UTC
This is failing for LANGS... fr_FR  ja_JP  zh_CN  zh_TW

Comment 4 Kevin Howell 2017-05-15 19:39:08 UTC
*** Bug 1449839 has been marked as a duplicate of this bug. ***

Comment 6 Shwetha Kallesh 2017-05-25 11:03:26 UTC
[root@dell-pem610-01 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.9.51.21-1
subscription management rules: 5.15.1
subscription-manager: 1.19.16-1.el7
python-rhsm: 1.19.7-1.el7


[root@dell-pem610-01 ~]# LC_ALL=ja_JP.UTF-8 subscription-manager facts --list | grep lscpu
lscpu.architecture: x86_64
lscpu.bogomips: 4788.32
lscpu.byte_order: Little Endian
lscpu.core(s)_per_socket: 4
lscpu.cpu(s): 16
lscpu.cpu_family: 6
lscpu.cpu_mhz: 2394.163
lscpu.cpu_op-mode(s): 32-bit, 64-bit
lscpu.flags: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm dca sse4_1 sse4_2 popcnt lahf_lm tpr_shadow vnmi flexpriority ept vpid dtherm ida
lscpu.l1d_cache: 32K
lscpu.l1i_cache: 32K
lscpu.l2_cache: 256K
lscpu.l3_cache: 8192K
lscpu.model: 26
lscpu.model_name: Intel(R) Xeon(R) CPU           E5530  @ 2.40GHz
lscpu.numa_node(s): 2
lscpu.numa_node0_cpu(s): 0,2,4,6,8,10,12,14
lscpu.numa_node1_cpu(s): 1,3,5,7,9,11,13,15
lscpu.on-line_cpu(s)_list: 0-15
lscpu.socket(s): 2
lscpu.stepping: 5
lscpu.thread(s)_per_core: 2
lscpu.vendor_id: GenuineIntel
lscpu.virtualization: VT-x

Comment 7 errata-xmlrpc 2017-08-01 19:23:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2083


Note You need to log in before you can comment on or make changes to this bug.