Bug 1450388 - RFE: add logic to tracer to recognize more services
Summary: RFE: add logic to tracer to recognize more services
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: tracer
Version: 25
Hardware: All
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Jakub Kadlčík
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-05-12 12:01 UTC by David Jansen
Modified: 2017-09-06 14:49 UTC (History)
3 users (show)

Fixed In Version: tracer-0.6.13-2.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-06 14:49:38 UTC


Attachments (Terms of Use)

Description David Jansen 2017-05-12 12:01:06 UTC
Description of problem:

Tracer will normally display the commands to restart services. Unfortunately, the logic seems limited and some running services are just mentioned in the section of programs to restart manually, leaving it up to the system manager to figure out how to restart them.

Version-Release number of selected component (if applicable):
tracer-common-0.6.12-4.fc25.noarch


How reproducible:


Steps to Reproduce:
1. Install updates
2. Run 'tracer -r' (or use the dnf plugin)

Actual results:

# tracer -r
You should restart:
  * Some applications using:
      systemctl restart NetworkManager
      systemctl restart accounts-daemon
      systemctl restart atd
      systemctl restart auditd
      systemctl restart crond
      systemctl restart httpd
      systemctl restart irqbalance
      systemctl restart lightdm
      systemctl restart smartd
      systemctl restart sshd
      systemctl restart sssd

  * These applications manually:
      Xorg
      abrt-dbus
      automount
      cupsd
      rsyslogd
      sedispatch
      sssd_be
      sssd_nss
      sssd_pam
      x2gocleansessio


Expected results:
to see all restartable services listed with their systemctl command.

Additional info:

It seems tracer cannot handle the cases where the running daemon doesn't have the exact same name as its systemd service or unit (automount vs autofs, cupsd vs cups), or when a process is actually a subprocess of another daemon (Xorg started from lightdm, and the sssd subprocesses).

Perhaps it would be possible to add some logic here, such as a translation table, or to ask systemd for the master process (perhaps using cgroup?).

Comment 1 Sean O'Keeffe 2017-05-12 12:09:21 UTC
https://github.com/FrostyX/tracer/pull/82 fixes this by using systemd D-Bus API's GetUnitByPID. If you have a chance it test it that would be great!

git clone https://github.com/sean797/tracer.git -b dbus
python bin/tracer.py -ea

Comment 2 David Jansen 2017-05-12 15:22:51 UTC
Yes, that looks like what I hoped to be possible

Comment 3 Fedora Update System 2017-07-26 12:47:06 UTC
tracer-0.6.13-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-6aed43ddbe

Comment 4 Fedora Update System 2017-07-26 23:17:33 UTC
tracer-0.6.13-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-6aed43ddbe

Comment 5 Fedora Update System 2017-08-01 20:03:00 UTC
python-argcomplete-1.7.0-2.el7 tracer-0.6.13-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-6aed43ddbe

Comment 6 Fedora Update System 2017-08-02 21:19:23 UTC
python-argcomplete-1.7.0-2.el7, tracer-0.6.13-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-6aed43ddbe

Comment 7 Fedora Update System 2017-08-21 14:43:23 UTC
tracer-0.6.13-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-1ea755452d

Comment 8 Fedora Update System 2017-08-23 06:33:35 UTC
tracer-0.6.13-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-1ea755452d

Comment 9 Fedora Update System 2017-09-06 14:49:38 UTC
tracer-0.6.13-2.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.