Bug 145039 - Unchanged selinux install needing .rpmnew files, anyway
Summary: Unchanged selinux install needing .rpmnew files, anyway
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-13 21:32 UTC by Brian Fahrlander
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version: RHBA-2005-251
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-18 22:07:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:251 low SHIPPED_LIVE selinux-policy-targeted bug fix update 2005-06-09 04:00:00 UTC

Description Brian Fahrlander 2005-01-13 21:32:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
During a routine 'yum update' I noticed it creating .rpmnew files. 
These (as I understand it) are created when changes to configuration
files have been changed, and a new configuration has been made
available.  This is all well and good- no problem here.

The curiousity is that I've had selinux turned _off_ since the
install; it's not something I feel has matured just yet and I don't
need it, so I let it go.  I can't wait to use it- it's brilliant...but
not just now, and not when I don't need it.

My concern here is that the rpms are refusing to overlay (unchanged)
files unnecessarily.  It's not causing _me_ a problem, but it might
solve something in the future and help out somewhere.

Version-Release number of selected component (if applicable):
selinux-policy-targeted-1.17.30-2.72

How reproducible:
Didn't try

Steps to Reproduce:
1. Update, weeks ago
2. Update, today (getting a new selinux-targeted-policy) 
3. Note the warming from rpm: Warning (filename) created as
(filename).rpmnew
    

Actual Results:  The RPM warning is the concern; without changes, this
shouldn't happen.

Expected Results:  No warnings; just installing the config files over
config files.

Additional info:

Comment 1 Daniel Walsh 2005-01-18 22:07:32 UTC
This is a known problem, that was caused by a conflict of 
selinux-policy-targeted and selinux-policy-targeted-sources.  

If you move the file_contexts.rpmnew over file_contexts and
policy.18.rpmnew over policy.18 the problem should go away.

Comment 2 Brian Fahrlander 2005-01-18 22:55:44 UTC
Ah; ok- I just wanted to make sure the relevant people were aware of
the problem.  Thanks!


Comment 3 Tim Powers 2005-06-09 13:06:08 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-251.html



Note You need to log in before you can comment on or make changes to this bug.