Bug 1450484 - Rpcbind fail to start at boot
Summary: Rpcbind fail to start at boot
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rpcbind
Version: 26
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Steve Dickson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-05-12 18:09 UTC by Maël Lavault
Modified: 2017-11-01 16:37 UTC (History)
3 users (show)

Fixed In Version: rpcbind-0.2.4-8.rc2.fc26 rpcbind-0.2.4-8.rc2.fc27 rpcbind-0.2.4-7.rc2.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-09 23:54:47 UTC
Type: Bug


Attachments (Terms of Use)

Description Maël Lavault 2017-05-12 18:09:58 UTC
Description of problem:

Each time I boot I get those errors from rpcbind:

mai 12 18:51:42 localhost systemd-tmpfiles[364]: Failed to open 'rpcbind.conf': No such file or directory
mai 12 18:51:42 localhost dracut-pre-udev[345]: rpcbind: /run/rpcbind/rpcbind.lock: No such file or directory
mai 12 18:51:42 localhost rpc.statd[368]: Version 2.1.1 starting
mai 12 18:51:42 localhost rpc.statd[368]: Initializing NSM state
mai 12 18:51:42 localhost rpc.statd[368]: Running as root.  chown /var/lib/nfs/statd to choose different user
mai 12 18:51:42 localhost rpc.statd[368]: Failed to register (statd, 1, udp): svc_reg() err: RPC: Remote system error - Connection refused
mai 12 18:51:42 localhost rpc.statd[368]: Failed to register (statd, 1, tcp): svc_reg() err: RPC: Remote system error - Connection refused
mai 12 18:51:42 localhost rpc.statd[368]: Failed to register (statd, 1, udp6): svc_reg() err: RPC: Remote system error - Connection refused
mai 12 18:51:42 localhost rpc.statd[368]: Failed to register (statd, 1, tcp6): svc_reg() err: RPC: Remote system error - Connection refused
mai 12 18:51:42 localhost rpc.statd[368]: failed to create RPC listeners, exiting


Version-Release number of selected component (if applicable):

0.2.4-6.fc26

How reproducible:
Always

Steps to Reproduce:
1. Boot

Comment 1 Steve Dickson 2017-05-19 17:43:10 UTC
(In reply to Maël Lavault from comment #0)
> Description of problem:
> 
> Each time I boot I get those errors from rpcbind:
> 
> mai 12 18:51:42 localhost systemd-tmpfiles[364]: Failed to open
> 'rpcbind.conf': No such file or directory
> mai 12 18:51:42 localhost dracut-pre-udev[345]: rpcbind:
> /run/rpcbind/rpcbind.lock: No such file or directory
Is systemd installed on the system?

Comment 2 Maël Lavault 2017-05-19 17:47:58 UTC
Yes it is a fedora 26 workstation standard installation.

Comment 3 Maël Lavault 2017-05-22 07:25:19 UTC
Same errors with 0.2.4-7.rc1.fc26

Comment 4 Steve Dickson 2017-05-30 16:57:25 UTC
(In reply to Maël Lavault from comment #0)
> Description of problem:
> 
> Each time I boot I get those errors from rpcbind:
> 
> mai 12 18:51:42 localhost systemd-tmpfiles[364]: Failed to open
> 'rpcbind.conf': No such file or directory
>
This is the problem... there should be a 
rpcbind.conf in /usr/lib/tmpfiles.d and there
is not. It should look like this:

# cat rpcbind.conf 
#Type Path         Mode  UID  GID Age Argument
D     /run/rpcbind 0700  rpc  rpc  -  -

Any idea why it's not being installed?

Comment 5 Fedora Update System 2017-05-30 17:04:52 UTC
rpcbind-0.2.4-6.rc2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-94c0774edd

Comment 6 Fedora Update System 2017-05-30 17:05:01 UTC
rpcbind-0.2.4-7.rc2.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-204ada5777

Comment 7 Steve Dickson 2017-05-31 17:45:00 UTC
I mistakenly modified this bz

Comment 8 Maël Lavault 2017-06-05 09:30:31 UTC
I still have the same issue with the update. I do have a rpcbind.conf in /usr/lib/tmpfiles.d:

-rw-r--r-- 1 root root   87 30 mai   18:14 rpcbind.conf

And the file has:

D     /run/rpcbind 0700  rpc  rpc  -  -

Comment 9 Steve Dickson 2017-06-07 20:24:43 UTC
Does the command work?
   /usr/bin/systemd-tmpfiles --create rpcbind.conf

as root?

Comment 10 Maël Lavault 2017-06-08 07:19:48 UTC
Yes it does work. (I mean the command executed and I dont have any message or anything)

Comment 11 Steve Dickson 2017-06-08 14:29:26 UTC
(In reply to Maël Lavault from comment #10)
> Yes it does work. (I mean the command executed and I dont have any message
> or anything)

Is there a /run/rpcbind? If so does rpcbind start up correctly?

Comment 12 Maël Lavault 2017-06-08 14:34:12 UTC
Yes:

drwx------   2 rpc            rpc              40  8 juin  09:22 rpcbind
srw-rw-rw-   1 root           root              0  8 juin  09:22 rpcbind.sock
-rw-r--r--   1 root           root              0  8 juin  09:22 rpc.statd.pid


Rpcbind wasn't running, but if I run it manually it works:

[mlavault@mael-laptop Development]$ systemctl status rpcbind
● rpcbind.service - RPC Bind
   Loaded: loaded (/usr/lib/systemd/system/rpcbind.service; disabled; vendor preset: disabled)
   Active: active (running) since Thu 2017-06-08 16:32:39 CEST; 5s ago
     Docs: man:rpcbind(8)
 Main PID: 16969 (rpcbind)
    Tasks: 1 (limit: 4915)
   CGroup: /system.slice/rpcbind.service
           └─16969 /usr/bin/rpcbind -w -f

juin 08 16:32:39 mael-laptop systemd[1]: Starting RPC Bind...
juin 08 16:32:39 mael-laptop systemd[1]: Started RPC Bind.

Comment 13 Steve Dickson 2017-06-12 13:34:02 UTC
So the process only fails during boot, correct?

If so what are the errors (or reason) being logged
to /var/log/messages?

Comment 14 Maël Lavault 2017-06-12 13:57:37 UTC
Yeah only at boot:

juin 12 10:20:18 localhost kernel: calling  init_sunrpc+0x0/0x6e [sunrpc] @ 349
juin 12 10:20:18 localhost kernel: RPC: Registered named UNIX socket transport module.
juin 12 10:20:18 localhost kernel: RPC: Registered udp transport module.
juin 12 10:20:18 localhost kernel: RPC: Registered tcp transport module.
juin 12 10:20:18 localhost kernel: RPC: Registered tcp NFSv4.1 backchannel transport module.
juin 12 10:20:18 localhost kernel: initcall init_sunrpc+0x0/0x6e [sunrpc] returned 0 after 142 usecs
juin 12 10:20:18 localhost systemd-tmpfiles[356]: Failed to open 'rpcbind.conf': No such file or directory
juin 12 10:20:18 localhost dracut-pre-udev[336]: rpcbind: /run/rpcbind/rpcbind.lock: No such file or directory
juin 12 10:20:18 localhost rpc.statd[360]: Version 2.1.1 starting
juin 12 10:20:18 localhost rpc.statd[360]: Initializing NSM state
juin 12 10:20:18 localhost rpc.statd[360]: Running as root.  chown /var/lib/nfs/statd to choose different user
juin 12 10:20:18 localhost rpc.statd[360]: Failed to register (statd, 1, udp): svc_reg() err: RPC: Remote system error - Connection refused
juin 12 10:20:18 localhost kernel: usb 1-5: new full-speed USB device number 3 using xhci_hcd
juin 12 10:20:18 localhost rpc.statd[360]: Failed to register (statd, 1, tcp): svc_reg() err: RPC: Remote system error - Connection refused
juin 12 10:20:18 localhost rpc.statd[360]: Failed to register (statd, 1, udp6): svc_reg() err: RPC: Remote system error - Connection refused
juin 12 10:20:18 localhost rpc.statd[360]: Failed to register (statd, 1, tcp6): svc_reg() err: RPC: Remote system error - Connection refused
juin 12 10:20:18 localhost rpc.statd[360]: failed to create RPC listeners, exiting

Comment 15 Steve Dickson 2017-06-12 17:12:09 UTC
Is selinux enabled? I wondering if we are seeing bug 1460720

Comment 16 Maël Lavault 2017-06-13 10:54:09 UTC
Nope selinux is disabled

Comment 17 Fedora Update System 2017-09-06 17:49:46 UTC
rpcbind-0.2.4-8.rc2.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-b0b0250df7

Comment 18 Fedora Update System 2017-09-06 17:49:55 UTC
rpcbind-0.2.4-8.rc2.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-2c9ca9589b

Comment 19 Fedora Update System 2017-09-06 17:50:01 UTC
rpcbind-0.2.4-7.rc2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-504aeb74ba

Comment 20 Fedora Update System 2017-09-07 14:32:44 UTC
rpcbind-0.2.4-8.rc2.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-b0b0250df7

Comment 21 Fedora Update System 2017-09-08 00:24:07 UTC
rpcbind-0.2.4-8.rc2.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-2c9ca9589b

Comment 22 Fedora Update System 2017-09-08 01:21:48 UTC
rpcbind-0.2.4-7.rc2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-504aeb74ba

Comment 23 Fedora Update System 2017-09-09 23:54:47 UTC
rpcbind-0.2.4-8.rc2.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 24 Fedora Update System 2017-09-30 06:19:29 UTC
rpcbind-0.2.4-8.rc2.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 25 Fedora Update System 2017-11-01 16:37:56 UTC
rpcbind-0.2.4-7.rc2.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.