Bug 145078 - dvd burner really slow response
dvd burner really slow response
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-13 22:21 EST by Steve Dum
Modified: 2015-01-04 17:15 EST (History)
3 users (show)

See Also:
Fixed In Version: FC4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-29 20:41:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Dum 2005-01-13 22:21:55 EST
Description of problem: In general dvd response is really slow.
As an example: getting drive info from a DVD+-R takes 7 Minutes


Version-Release number of selected component (if applicable):
kernel 2.6.9-1.681_FC3smp

How reproducible: always


Steps to Reproduce:
1. insert pre-written dvd-r or dvd+r media
2. fire up k3b and ask for disk info
3. k3b goes away for 7 Minutes (yes 420 seconds)
   worked correctly with fc1 loaded
  
Actual results: snall speed response


Expected results: few second response

Additional info: dvd drive is Hi-Val "DVD RW 4XMax" (iomagic DD0203)
4x dvd +/-R writer.
No messages are logged in /var/log/messages
stopping haldaemon has no effect on problem
Tracing k3b shows during the long delay it is 
somewhat activily talking to the device
brk(0x9528000)                          = 0x9528000
ioctl(19, CDROM_SEND_PACKET, 0xfefa0110) = 0
ioctl(19, CDROM_SEND_PACKET, 0xfefa02a0) = 0
ioctl(19, CDROM_SEND_PACKET, 0xfefa02a0) = 0
...
Comment 1 Dave Jones 2005-01-13 23:26:29 EST
can you try with the latest kernel & haldaemon updates and see if that
improves things ?
Comment 2 Steve Dum 2005-01-15 00:03:48 EST
2.6.10-1.737_FC3smp kernel shows same behavior.  However, being
impatient and not wanting to wait the *** 7 minutes for it to come back
I just ejected the disk using 'eject cdrom'.  Interesting enough
in the process of doing the eject k3b read the disk info and displayed
it.  I am not sure if I completely understand this, but I assume it 
means some other process is interfering with k3b.  

However on checking this futher it's not consistant.  Occasionally an
eject will trigger something allowing k3b to get diskinfo not not
always.  

One other thing, k3b can get disk info from a DVD+RW disk in about 10
seconds.  lightyears faster than for DVD+R or DVD-R disks.

Also stopping haldaemon has no effect on things.
Comment 3 Dave Jones 2005-07-15 13:40:37 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 4 Steve Dum 2005-07-17 18:26:56 EDT
Unable to test on FC3.  FC4 does not have this problem.

Note You need to log in before you can comment on or make changes to this bug.