Bug 1450818 - Any local user can open a popup window with subscription status
Summary: Any local user can open a popup window with subscription status
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jiri Hnidek
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-05-15 08:51 UTC by Jiri Hnidek
Modified: 2017-08-01 19:23 UTC (History)
2 users (show)

Fixed In Version: subscription-manager-1.19.15-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 19:23:41 UTC
Target Upstream Version:


Attachments (Terms of Use)
rhsm_icon (423.42 KB, image/png)
2017-06-01 13:10 UTC, Rehana
no flags Details
access_denied (315.10 KB, image/png)
2017-06-01 13:10 UTC, Rehana
no flags Details


Links
System ID Priority Status Summary Last Updated
Github candlepin subscription-manager pull 1626 None None None 2017-05-15 10:31:11 UTC
Red Hat Product Errata RHBA-2017:2083 normal SHIPPED_LIVE python-rhsm and subscription-manager bug fix and enhancement update 2017-08-01 18:14:19 UTC

Description Jiri Hnidek 2017-05-15 08:51:31 UTC
Description of problem:
File com.redhat.SubscriptionManager.policy currently allows any local user to open a popup on a user logged in graphic mode. The popup will contain warnings about subscription/entitlements status, but it does not allow any modifications.

Version-Release number of selected component (if applicable):
[root@rhel74 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.9.51.21-1
subscription management rules: 5.15.1
subscription-manager: 1.19.12-1.el7
python-rhsm: 1.19.6-1.el7

How reproducible:
always

Steps to Reproduce:
1. Install build RHEL-7.4-20170504.0 with gnome desktop environment
2. Login using gdm (as not root, but common user)
3. Open gnome-terminal
4. Switch to another user using su command.
5. Run following command in terminal:

busctl call com.redhat.SubscriptionManager /EntitlementStatus com.redhat.SubscriptionManager.EntitlementStatus update_status i <status_num>

status_num can be any number in range: 0-5

Actual results:
Popup window will appear.

Expected results:
No popup window appear, because common user should not be able to trigger this method.

Additional info:
Common user could be able to get status of entitlement using:

busctl call com.redhat.SubscriptionManager /EntitlementStatus com.redhat.SubscriptionManager.EntitlementStatus check_status

Comment 4 Rehana 2017-06-01 13:09:27 UTC
Reproducing the failure:
-======================

subscription management server: 2.0.33-1
subscription management rules: 5.23
subscription-manager: 1.19.9-1.el7
python-rhsm: 1.19.5-1.el7

1:logged in to a gnome session as normal user
2: executed `busctl call com.redhat.SubscriptionManager /EntitlementStatus com.redhat.SubscriptionManager.EntitlementStatus update_status i <num>` (where num is between 0- 5) 
3 Observed that the rhsm_icon window pop-up (rhsm_icon.png)

retesting with:
==============
subscription management server: 2.1.1-1
subscription management rules: 5.23
subscription-manager: 1.19.17-1.el7
python-rhsm: 1.19.8-1.el7

Observed error message "access denied" appeared when tried to follow the same steps. and the rhsm-icon window is NOT displayed (access_denied.png)

Comment 5 Rehana 2017-06-01 13:10:07 UTC
Created attachment 1284138 [details]
rhsm_icon

Comment 6 Rehana 2017-06-01 13:10:37 UTC
Created attachment 1284139 [details]
access_denied

Comment 7 errata-xmlrpc 2017-08-01 19:23:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2083


Note You need to log in before you can comment on or make changes to this bug.