Bug 145083 - Failure to boot, locks up at logon screen after kernel upgrade.
Failure to boot, locks up at logon screen after kernel upgrade.
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-14 02:28 EST by Joseph Morton
Modified: 2015-01-04 17:15 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-05 14:28:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Unsuccessful and successful boots from /var/log/messages (56.69 KB, text/plain)
2005-01-18 11:46 EST, Joseph Morton
no flags Details

  None (edit)
Description Joseph Morton 2005-01-14 02:28:00 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
System works just fine with original kernel 2.6.9-1.667smp.  But after
upgrades to other kernels up to and including 2.6.10-1.737FC3smp
system locks up at boot.  Can still get normal operation with original
kernel though.






Version-Release number of selected component (if applicable):
kernel-2.6.10-1.737_FC3smp

How reproducible:
Always

Steps to Reproduce:
1.Install FC3
2.Upgrade to latest software including kernel
3.Boot system from new kernel
    

Actual Results:  It goes through boot up and briefly displays the
login screen, then infinately scrolls the following:  "HDD: Status
Error  Status = 0x01  { Error }" and "HDD: Status Error error =
0x04Aborted Command."  Keyboard is useless at this point and system
must be restarted.

Expected Results:  Normal login screen should be displayed.

Additional info:

System is an Intel OR840 Workstation board with two 800Mhz PIIIs, 512k
ram consisting of four 128k PC800 ECC modules.  HDD is a WDD 1600.

I tried a complete reinstall with Selinux disabled, but problem is the
same I tried the 2.6.10-1.737FC3 uniprocessor kernel and immediately
got a kernel panic.  I have also tried to roll my own 2.6.10 smp
kernel with a known good config, but it still gives me the scrolling
error.  I even tried my kernel with the -AC8 patch but it didn't
change anything either, I still get the same scrolling error message.
Comment 1 Joseph Morton 2005-01-15 10:20:46 EST
Update to latest kernel 2.6.10-1.741_FC3smp still has problem.

Uniprocessor kernel 2.6.10-1.741_FC3 still kernel panics.  It scrolls
too much by for me to catch, but the last lines are:

Error:  /bin/lvm exited abnormally!
mount:  error 6 mounting ext3
mount:  error 2 mounting none
switchroot:  mount failed: 22

<0> Kernel panic -not syncing:  Attempted to kill init!
Comment 2 Joseph Morton 2005-01-15 10:21:53 EST
Update to latest kernel 2.6.10-1.741_FC3smp still has problem.

Uniprocessor kernel 2.6.10-1.741_FC3 still kernel panics.  It scrolls
too much by for me to catch, but the last lines are:
Error:  /bin/lvm exited abnormally!
mount:  error 6 mounting ext3
mount:  error 2 mounting none
switchroot:  mount failed: 22
umount /initrd/dev failed: 2

<0> Kernel panic -not syncing:  Attempted to kill init!
Comment 3 Joseph Morton 2005-01-18 11:46:20 EST
Created attachment 109930 [details]
Unsuccessful and successful boots from  /var/log/messages

I erased /var/log/messages and rebooted using kernel 2.6.10-1.747FC3smp, then
rebooted using kernel 2.6.9-1.667smp.  So this log contains both a failed boot
using latest kernel and a successful boot using original kernel
Comment 4 Joseph Morton 2005-01-18 13:59:14 EST
Yoicks! a clue (maybe).

Probably should have done this first, but I'm still struggling at the
bottom of the learning curve.

I went over /var/log/messages and noted that both kernels register a
slave MATSHITA CD-RW CW-7585 ATAPI CD/DVD-ROM Drive.  There is ONLY
ONE CD drive on this computer, and neither IDE bus has a slave device
attached, it should only have HDA and HDC!

Moreover, kernel  2.6.9-1.667smp simply ignores it with "ide probe:
ignoring undecoded slave."   

Kernel 2.6.10-1.747FC3smp seems to try and configure the non-existant
drive, starting with "set_drive_speed_status:  status=0x01 ( Error )."

Hope this helps.
Comment 5 Joseph Morton 2005-01-26 13:26:19 EST
Finally had time to play with this some more, opened the case and
pulled the ribbon cable off the CD drive and rebooted using new
kernels.  Viola! Boots fine, no error messages in log.

Looks like it may be some issue between the 2.6 kernel and this
particular type of drive.  I guess the next step is to aquire another
CD drive and try it.
Comment 6 Joseph Morton 2005-02-05 14:28:33 EST
Just got a cheap no-name 52x cd drive and installed it.  Everything
works fine.  /var/log doesn't have any error messages for the new
drive, and it reads data and audio cds fine.

Note You need to log in before you can comment on or make changes to this bug.