Bug 1450894 - Ping6 support for Neutron router internal interfaces
Summary: Ping6 support for Neutron router internal interfaces
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: opendaylight
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ga
: 12.0 (Pike)
Assignee: Sridhar Gaddam
QA Contact: Itzik Brown
URL:
Whiteboard:
: 1497652 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-05-15 10:56 UTC by Itzik Brown
Modified: 2018-10-18 07:23 UTC (History)
7 users (show)

Fixed In Version: opendaylight-6.1.0-1.el7
Doc Type: If docs needed, set a value
Doc Text:
This update adds ping6 support to the Neutron router internal interfaces for OpenStack using OpenDaylight.
Clone Of:
Environment:
N/A
Last Closed: 2017-12-13 21:27:05 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenDaylight gerrit 56969 None None None 2017-05-15 10:56:01 UTC
OpenDaylight gerrit 57026 None None None 2017-05-15 10:56:47 UTC
OpenDaylight gerrit 57027 None None None 2017-05-15 10:57:21 UTC
Red Hat Bugzilla 1497652 None CLOSED [IPv6] ping from VM to router's IPv6 (2003::1) doesn't work on 1of2 VMs in tempest test 2019-07-22 23:24:56 UTC
Red Hat Product Errata RHEA-2017:3462 normal SHIPPED_LIVE Red Hat OpenStack Platform 12.0 Enhancement Advisory 2018-02-16 01:43:25 UTC

Description Itzik Brown 2017-05-15 10:56:01 UTC
Description of problem:
There is a need to support IPv6 in OpenStack when using OpenDaylight 

Version-Release number of selected component (if applicable):
opendaylight-5.2.0-8.el7ost.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Itzik Brown 2017-05-15 12:01:40 UTC
tempest IPv6 scenario tests relies on support for ping6.

Comment 2 Nir Yechiel 2017-07-20 09:02:28 UTC
@Itzik, @Sridhar, I guess this should be targeted to RHOSP 12 where we have IPv6 support?

Comment 3 Sridhar Gaddam 2017-07-20 09:32:07 UTC
Yes @Nir, we can target this to RHOSP12. 

This feature is implemented via 7 patches spread across different components.
All the necessary patches are merged in stable/carbon and Ocata.

We are even running the IPv6 tempest scenario tests in Upstream CSIT. You can find the sample report here [*].

Patches:
--------
Netvirt: Support ping6 for Neutron internal router interfaces - https://git.opendaylight.org/gerrit/#/c/58620/

networking-odl: Send port[fixed_ips] update to ODL Controller - https://review.openstack.org/#/c/477516/1

OpenflowPlugin: Bug 8535 Fix IPv6 OXMHeader Mask issue - https://git.opendaylight.org/gerrit/#/c/57694/
OpenflowPlugin: Nicira extension support for matching IPv6 Src/Dst (used with RegMove) - https://git.opendaylight.org/gerrit/#/c/56969/

GENIUS: Support API to configure IPv6 address as sourceAddress - https://git.opendaylight.org/gerrit/#/c/57026/
GENIUS: Support API for moving Src/Dest IPv6 addresses in NxRegMove action - https://git.opendaylight.org/gerrit/#/c/57027/
GENIUS: Utility api to configure icmpv6 type - https://git.opendaylight.org/gerrit/#/c/57072/

[*] https://jenkins.opendaylight.org/releng/job/netvirt-csit-1node-openstack-newton-nodl-v2-upstream-stateful-carbon/839/robot/netvirt-1node-openstack.txt/Tempest/Tempest/tempest.scenario.test_network_v6.TestGettingAddress.test_slaac_from_os/

Comment 6 Itzik Brown 2017-09-19 07:58:42 UTC
Used ping6 to ping the router's internal interface.
Version opendaylight-6.2.0-0.1.20170913snap58.el7.noarch

Comment 7 Waldemar Znoinski 2017-10-02 12:24:52 UTC
please check https://bugzilla.redhat.com/show_bug.cgi?id=1497652 for more low level info on the issue - it looks like it's affecting only one of two VMs spawned by the same tempest test (each on a different compute node)

Comment 8 Waldemar Znoinski 2017-10-02 12:25:23 UTC
*** Bug 1497652 has been marked as a duplicate of this bug. ***

Comment 9 Sridhar Gaddam 2017-10-10 12:20:51 UTC
Currently, tempest has 8 Scenario tests that validate ping6 support to router-interface along with other use-cases (like IPAM).

We have support for ping6 for a dual-stack network as well as IPv6 only network. However, multiprefix networks (i.e., a network with multiple IPv6 subnets) has some gaps and is not officially supported in Netvirt. 

The following 4 tempest tests fall in the first category (i.e., dual-stack/single IPv6 network use-case) and they are supported. These 4 tests are  validated in upstream OpenDaylight CSIT today.

test_dualnet_slaac_from_os
test_dualnet_dhcp6_stateless_from_os
test_dhcp6_stateless_from_os
test_slaac_from_os

The next set of 4 tempest tests use multiple IPv6 subnets in a network and they are not supported. This is more of an RFE/Enhancement than a Bug. So, we have a separate bug to track its progress - https://bugzilla.redhat.com/show_bug.cgi?id=1498031

test_dualnet_multi_prefix_dhcpv6_stateless
test_dualnet_multi_prefix_slaac
test_multi_prefix_slaac
test_multi_prefix_dhcpv6_stateless

Comment 17 errata-xmlrpc 2017-12-13 21:27:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462


Note You need to log in before you can comment on or make changes to this bug.