Bug 1450922 - RFE: allow assigning mount points to existing block devices in text mode
Summary: RFE: allow assigning mount points to existing block devices in text mode
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda
Version: 7.4
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
Petr Bokoc
URL:
Whiteboard:
Depends On:
Blocks: 1478303
TreeView+ depends on / blocked
 
Reported: 2017-05-15 12:14 UTC by Vit Ry
Modified: 2018-04-10 08:47 UTC (History)
11 users (show)

Fixed In Version: anaconda-21.48.22.128-1
Doc Type: Enhancement
Doc Text:
Assigning mount points to existing block devices is now possible in Kickstart installations A new "mount" command is now available in Kickstart. This command assigns a mount point to a particular block device with a file system, and it can also reformat it if you specify the "--reformat" option. The difference between "mount" and other storage-related commands like "autopart", "part", or "logvol" is that with "mount" you do not need to describe the entire storage configuration in the Kickstart file, you only need to make sure that the specified block devices exist on the system. However, if you want to create the storage configuration instead of using an existing one, and mount the various devices, then you must use the other storage configuration commands. You can not use "mount" with the other storage configuration commands in the same Kickstart file.
Clone Of:
: 1488428 (view as bug list)
Environment:
Last Closed: 2018-04-10 08:45:01 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0671 None None None 2018-04-10 08:47:04 UTC

Description Vit Ry 2017-05-15 12:14:34 UTC
Description of problem:

Is is impossible to do manual partitioning during text installation. It is even impossible to use *existed partitions* to map mount-points.

During server installation I often use text installation (it is light enough. I do not need extra VNC/graphic for that, especially on IBM Power). But I need to create custom disk partitioning, without /home, with hard raid or lvm, next to other OS and so on. It would be strongly cool, if anaconda has a screens like
> custom disk partitioning
>> map mountpoints to existed  partitions (and note, that user can use tty2 for custom partitioning)
>> run custom partitioning (run shell, or fdisk/parted) and then map


Version-Release number of selected component (if applicable):
anaconda-21.48.22.113 (or even rhel7-branch on GitHub)


How reproducible:
always


Steps to Reproduce:
1. run installation in text mode
2. try to create custom partitions in interactive way
3. or try to reuse existed partitions

Actual results:
there is no way for that (only automatic partitioning)

Expected results:
there is way to do that.

Comment 2 Vratislav Podzimek 2017-05-15 14:01:05 UTC
Let's make the bug summary more precise.

Comment 3 Samantha N. Bueno 2017-10-23 10:40:36 UTC
Backporting the work from Fedora to RHEL is non-trivial since it involves basically rewriting the patches. That's too invasive for this release, so the scope of this has been limited to kickstart support as far as 7.5 is concerned.

Comment 4 Vratislav Podzimek 2017-10-23 14:31:18 UTC
The pykickstart part is submitted as a PR now:
https://github.com/rhinstaller/pykickstart/pull/190

Comment 5 Vratislav Podzimek 2017-10-25 13:00:31 UTC
Anaconda part submitted as PR:
https://github.com/rhinstaller/anaconda/pull/1224

Comment 14 errata-xmlrpc 2018-04-10 08:45:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0671


Note You need to log in before you can comment on or make changes to this bug.