Bug 145097 - kernel panic during boot-up
kernel panic during boot-up
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-14 06:26 EST by Nick Bruton
Modified: 2015-01-04 17:15 EST (History)
3 users (show)

See Also:
Fixed In Version: kernel-2.6.12-1.1372_FC3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-25 05:45:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nick Bruton 2005-01-14 06:26:16 EST
Description of problem:

Kernel panic with 2.6.10-1.741_FC3
Error message is ... 
Setting up Logical Volume Management: Kernel panic - not syncing:
drivers/ide/pci/piix.c:232 spimn_lock(drivers/ide/ide.c:c0365448)
already locked by drivers/ide/ide-iops.c/1222
Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Reboot system and wait
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Stuart Clark 2005-02-08 00:02:31 EST
I get the exact same error as above, even the same numbers.

I get this when trying every UP or SMP kernels from this list:
/vmlinuz-2.6.10-1.760_FC3
/vmlinuz-2.6.10-1.760_FC3smp
/vmlinuz-2.6.10-1.741_FC3
/vmlinuz-2.6.10-1.741_FC3smp
/vmlinuz-2.6.10-1.737_FC3smp
/vmlinuz-2.6.10-1.737_FC3
/vmlinuz-2.6.9-1.724_FC3

I can only sussessfully boot the kernel:
/vmlinuz-2.6.9-1.681_FC3

I have to assert the kernal parameter "debug" and remove "rhgb quiet".

The result is the same as above, but seems to occur after the text
appears:
Mount local filesystem:  [OK]
enabling local filesystem quotas [OK]



#cat /proc/ide/piix

Controller: 0

                                Intel PIIX4 Ultra 100 Chipset.
--------------- Primary Channel ---------------- Secondary Channel
-------------
                 enabled                          enabled
--------------- drive0 --------- drive1 -------- drive0 ----------
drive1 ------
DMA enabled:    yes              no              yes               yes
UDMA enabled:   yes              yes             yes               yes
UDMA enabled:   3                2               5                 5
UDMA
DMA
PIO



#ls -ltR /proc/ide/
/proc/ide/:
total 4
-r--r--r--  1 root root 0 Feb  8 16:01 drivers
lrwxrwxrwx  1 root root 8 Feb  8 16:01 hda -> ide0/hda
lrwxrwxrwx  1 root root 8 Feb  8 16:01 hdb -> ide0/hdb
lrwxrwxrwx  1 root root 8 Feb  8 16:01 hdc -> ide1/hdc
lrwxrwxrwx  1 root root 8 Feb  8 16:01 hdd -> ide1/hdd
dr-xr-xr-x  4 root root 0 Feb  8 16:01 ide0
dr-xr-xr-x  4 root root 0 Feb  8 16:01 ide1
-r--r--r--  1 root root 0 Feb  8 16:01 piix

/proc/ide/ide0:
total 0
-r--r--r--  1 root root 0 Feb  8 16:01 channel
-rw-r--r--  1 root root 0 Feb  8 16:01 config
dr-xr-xr-x  2 root root 0 Feb  8 16:01 hda
dr-xr-xr-x  2 root root 0 Feb  8 16:01 hdb
-r--r--r--  1 root root 0 Feb  8 16:01 mate
-r--r--r--  1 root root 0 Feb  8 16:01 model

/proc/ide/ide0/hda:
total 0
-r--r--r--  1 root root 0 Feb  8 16:01 capacity
-r--r--r--  1 root root 0 Feb  8 16:01 driver
-r--------  1 root root 0 Feb  8 16:01 identify
-r--r--r--  1 root root 0 Feb  8 16:01 media
-r--r--r--  1 root root 0 Feb  8 16:01 model
-rw-------  1 root root 0 Feb  8 16:01 settings
-r--r--r--  1 root root 0 Feb  8 16:01 cache
-r--r--r--  1 root root 0 Feb  8 16:01 geometry
-r--------  1 root root 0 Feb  8 16:01 smart_thresholds
-r--------  1 root root 0 Feb  8 16:01 smart_values

/proc/ide/ide0/hdb:
total 0
-r--r--r--  1 root root 0 Feb  8 16:01 capacity
-r--r--r--  1 root root 0 Feb  8 16:01 driver
-r--------  1 root root 0 Feb  8 16:01 identify
-r--r--r--  1 root root 0 Feb  8 16:01 media
-r--r--r--  1 root root 0 Feb  8 16:01 model
-rw-------  1 root root 0 Feb  8 16:01 settings

/proc/ide/ide1:
total 0
-r--r--r--  1 root root 0 Feb  8 16:01 channel
-rw-r--r--  1 root root 0 Feb  8 16:01 config
dr-xr-xr-x  2 root root 0 Feb  8 16:01 hdc
dr-xr-xr-x  2 root root 0 Feb  8 16:01 hdd
-r--r--r--  1 root root 0 Feb  8 16:01 mate
-r--r--r--  1 root root 0 Feb  8 16:01 model

/proc/ide/ide1/hdc:
total 0
-r--r--r--  1 root root 0 Feb  8 16:01 cache
-r--r--r--  1 root root 0 Feb  8 16:01 capacity
-r--r--r--  1 root root 0 Feb  8 16:01 driver
-r--r--r--  1 root root 0 Feb  8 16:01 geometry
-r--------  1 root root 0 Feb  8 16:01 identify
-r--r--r--  1 root root 0 Feb  8 16:01 media
-r--r--r--  1 root root 0 Feb  8 16:01 model
-rw-------  1 root root 0 Feb  8 16:01 settings
-r--------  1 root root 0 Feb  8 16:01 smart_thresholds
-r--------  1 root root 0 Feb  8 16:01 smart_values

/proc/ide/ide1/hdd:
total 0
-r--r--r--  1 root root 0 Feb  8 16:01 cache
-r--r--r--  1 root root 0 Feb  8 16:01 capacity
-r--r--r--  1 root root 0 Feb  8 16:01 driver
-r--r--r--  1 root root 0 Feb  8 16:01 geometry
-r--------  1 root root 0 Feb  8 16:01 identify
-r--r--r--  1 root root 0 Feb  8 16:01 media
-r--r--r--  1 root root 0 Feb  8 16:01 model
-rw-------  1 root root 0 Feb  8 16:01 settings
-r--------  1 root root 0 Feb  8 16:01 smart_thresholds
-r--------  1 root root 0 Feb  8 16:01 smart_values





Comment 3 Stuart Clark 2005-02-08 00:08:25 EST
This is the same as bug 140788
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=140788

I get the same problem.
Comment 4 Stuart Clark 2005-02-08 00:22:42 EST
Sorry..  discard comment #3  - wrong Bug ID

It is actually very simmilar to 
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=144743
Comment 5 Brian Brock 2005-02-21 14:07:56 EST
fixing QA Contact and Owner fields.
Comment 7 Nick Bruton 2005-06-16 08:27:38 EDT
This is happening with ALL new kernels, can someone suggest a fix please?
Comment 8 Dave Jones 2005-07-15 16:00:09 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 9 Nick Bruton 2005-07-18 04:35:58 EDT
WooHoo the latest kernel boots BUT logs lots of dma_intr error messages
BUT at least it boots

Note You need to log in before you can comment on or make changes to this bug.