Bug 1450984 - tidy: Upgrade to the latest for epel
Summary: tidy: Upgrade to the latest for epel
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: tidy
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: compat-tidy
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-05-15 13:51 UTC by Matěj Cepl
Modified: 2018-04-11 07:35 UTC (History)
5 users (show)

Fixed In Version: tidy-5.4.0-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-10 04:28:57 UTC
Type: Bug


Attachments (Terms of Use)

Description Matěj Cepl 2017-05-15 13:51:49 UTC
Description of problem:
tidy 5.4.0-1 builds perfectly in Koji for EPEL7
https://koji.fedoraproject.org/koji/taskinfo?taskID=19567947

Version-Release number of selected component (if applicable):
tidy-5.4.0-1

How reproducible:
100%

Comment 1 Matěj Cepl 2017-05-15 15:10:25 UTC
The biggest problem I have with our current package in EPEL-7 is that it doesn’t support HTML5 at all, so it claims all HTML5 elements to be proprietary.

Comment 2 Rex Dieter 2017-05-15 15:27:25 UTC
True, while there's a concern of breaking api/abi with an update, I think we can agree the current package is not very useful

Comment 3 Rex Dieter 2017-05-16 15:56:06 UTC
So, looks like one blocker to update this will be php-extras, whose %check regression tests currently fail using newer libtidy,

https://koji.fedoraproject.org/koji/taskinfo?taskID=19588370

(I may have to consider creating a compat-libtidy)

Comment 4 Rex Dieter 2017-05-16 16:44:12 UTC
compat-tidy pkg submitted for review, bug #1451456

Comment 5 Rex Dieter 2017-05-16 17:22:39 UTC
fyi,
tidy-5.4.0-1.el7
libopkele-2.0.4-9.el7
mod_auth_openid-0.8-2.el7
psi-plus-0.16-0.22.20141205git440.el7

built in koji, waiting for compat-tidy (bug #1451456), to include in batch bodhi update

Comment 6 Matěj Cepl 2017-05-16 19:28:09 UTC
(In reply to Rex Dieter from comment #3)
> So, looks like one blocker to update this will be php-extras, whose %check
> regression tests currently fail using newer libtidy,
> 
> https://koji.fedoraproject.org/koji/taskinfo?taskID=19588370
> 
> (I may have to consider creating a compat-libtidy)

It seems the tests fail because tidy now defaults to HTML5 instead of HTML3.2. Wouldn’t it be better either to make a patch on tests, or to run tidy with the equivalent of --doctype transitional or something of that kind?

Comment 7 Rex Dieter 2017-05-17 14:16:07 UTC
I think doing both would be ideal: providing compat-tidy (at least temporarily), and fixing php-tidy checks to accomodate the newer version

Comment 8 Fedora Update System 2017-05-24 14:38:13 UTC
psi-plus-0.16-0.22.20141205git440.el7 mod_auth_openid-0.8-2.el7 libopkele-2.0.4-9.el7 compat-tidy-0.99.0-35.20091203.el7 tidy-5.4.0-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-c0b04702c2

Comment 9 Fedora Update System 2017-05-24 19:34:57 UTC
compat-tidy-0.99.0-37.20091203.el7 libopkele-2.0.4-9.el7 mod_auth_openid-0.8-2.el7 psi-plus-0.16-0.22.20141205git440.el7 tidy-5.4.0-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-c0b04702c2

Comment 10 Fedora Update System 2017-05-26 04:26:31 UTC
compat-tidy-0.99.0-37.20091203.el7, libopkele-2.0.4-9.el7, mod_auth_openid-0.8-2.el7, psi-plus-0.16-0.22.20141205git440.el7, tidy-5.4.0-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-c0b04702c2

Comment 11 Fedora Update System 2017-06-10 04:28:57 UTC
compat-tidy-0.99.0-37.20091203.el7, libopkele-2.0.4-9.el7, mod_auth_openid-0.8-2.el7, psi-plus-0.16-0.22.20141205git440.el7, tidy-5.4.0-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.