Bug 1451003 - subscription-manager identity reports redundant UUID info in the name field
Summary: subscription-manager identity reports redundant UUID info in the name field
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager
Version: 7.4
Hardware: Unspecified
OS: Unspecified
high
low
Target Milestone: rc
: ---
Assignee: Jiri Hnidek
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-05-15 14:36 UTC by John Sefler
Modified: 2017-08-01 19:23 UTC (History)
4 users (show)

Fixed In Version: subscription-manager-1.19.15-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 19:23:41 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github candlepin subscription-manager pull 1632 None None None 2017-05-22 14:42:08 UTC
Red Hat Product Errata RHBA-2017:2083 normal SHIPPED_LIVE python-rhsm and subscription-manager bug fix and enhancement update 2017-08-01 18:14:19 UTC

Description John Sefler 2017-05-15 14:36:25 UTC
Description of problem:
After the candlepin fix for Bug 1395747 - Candlepin consumer certificate subject alternative name uses URI incorrectly - the subscription-manager identity command includes an additional UUID in the name field. 


Version-Release number of selected component (if applicable):
[root@jsefler-rhel7 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 2.1.0-1  <=========== CANDLEPIN
subscription management rules: 5.23
subscription-manager: 1.19.12-1.el7

Candlepin commit 92bad0f88253b750fd450caac68dc27a017a7a6f 1395747: Fix incorrect semantics in identity certificate SANs.


How reproducible:


Steps to Reproduce:
[root@jsefler-rhel7 ~]# subscription-manager register --username=testuser1 --password=password --org=admin --name="My-System-Identity-Name" --serverurl=jsefler-candlepin7.usersys.redhat.com:8443/candlepin --insecure
Registering to: jsefler-candlepin7.usersys.redhat.com:8443/candlepin
The system has been registered with ID: d067e838-93ce-4d2d-9c85-51009220189a 

[root@jsefler-rhel7 ~]# subscription-manager identity 
system identity: d067e838-93ce-4d2d-9c85-51009220189a
name: d067e838-93ce-4d2d-9c85-51009220189a, My-System-Identity-Name  <=====
org name: Admin Owner
org ID: admin



Actual results:
name: d067e838-93ce-4d2d-9c85-51009220189a, My-System-Identity-Name

Expected results:
name: My-System-Identity-Name




Additional info:

[root@jsefler-rhel7 ~]# rct cat-cert /etc/pki/consumer/cert.pem 

+-------------------------------------------+
	Identity Certificate
+-------------------------------------------+

Certificate:
	Path: /etc/pki/consumer/cert.pem
	Version: 1.0
	Serial: 143567886235116525
	Start Date: 2017-05-15 12:51:56+00:00
	End Date: 2033-05-15 13:51:56+00:00
	Alt Name: DirName:/CN=d067e838-93ce-4d2d-9c85-51009220189a, DirName:/CN=My-System-Identity-Name

Subject:
	CN: d067e838-93ce-4d2d-9c85-51009220189a

Issuer:
	C: US
	CN: jsefler-candlepin7.usersys.redhat.com
	L: Raleigh

Comment 3 John Sefler 2017-05-15 20:33:20 UTC
This issue is also observed in the stdout feedback given to user of the rhn-migrate-classic-to-rhsm tool....

[root@jsefler-rhel7 ~]# rhn-migrate-classic-to-rhsm --no-auto --no-proxy
Legacy username: rhsm-client
Legacy password:
Destination username: testuser1
Destination password:
Org: admin

Retrieving existing legacy subscription information...

+-----------------------------------------------------+
System is currently subscribed to these legacy channels:
+-----------------------------------------------------+
rhel-x86_64-server-7

+-----------------------------------------------------+
Installing product certificates for these legacy channels:
+-----------------------------------------------------+
rhel-x86_64-server-7

Product certificates installed successfully to /etc/pki/product.

Preparing to unregister system from legacy server...
System successfully unregistered from legacy server.
Stopping and disabling legacy services...

Attempting to register system to destination server...
Registering to: jsefler-candlepin7.usersys.redhat.com:8443/candlepin
The system has been registered with ID: 43040b27-e1fe-440c-a3aa-f43a6cd13bc0
System '43040b27-e1fe-440c-a3aa-f43a6cd13bc0, jsefler-rhel7server.usersys.redhat.com' successfully registered.


^^^ Notice the last two lines of feedback.  Expected the system identity to report 'jsefler-rhel7server.usersys.redhat.com'; not both the UUID and name.

Comment 5 Shwetha Kallesh 2017-05-25 10:21:54 UTC
Reproducer:

[root@dhcp71-27 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 2.1.0-1
subscription management rules: 5.23
subscription-manager: 1.19.14-1.el7
python-rhsm: 1.19.6-1.el7

[root@dhcp71-27 ~]# subscription-manager register --force --serverurl skallesh-candlepin.usersys.redhat.com:8443/candlepin
Registering to: skallesh-candlepin.usersys.redhat.com:8443/candlepin
Username: admin
Password: 
Organization: admin
The system has been registered with ID: 69be5dc8-8cad-43a8-a637-7e13671c709e 

[root@dhcp71-27 ~]# subscription-manager identity
system identity: 69be5dc8-8cad-43a8-a637-7e13671c709e
name: 69be5dc8-8cad-43a8-a637-7e13671c709e, dhcp71-27.rhts.eng.bos.redhat.com
org name: Admin Owner
org ID: admin



Verification:

[root@dhcp71-27 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 2.1.0-1
subscription management rules: 5.23
subscription-manager: 1.19.16-1.el7
python-rhsm: 1.19.7-1.el7

[root@dhcp71-27 ~]# subscription-manager register --force
Unregistering from: skallesh-candlepin.usersys.redhat.com:8443/candlepin
The system with UUID 63b19d73-e821-4e1c-958b-0e0afd6eb2ac has been unregistered
All local data removed
Registering to: skallesh-candlepin.usersys.redhat.com:8443/candlepin
Username: admin
Password: 
Organization: admin
The system has been registered with ID: 788dc1e2-6a85-4c1e-b812-fa0cffb36e4f 
[root@dhcp71-27 ~]# subscription-manager identity
system identity: 788dc1e2-6a85-4c1e-b812-fa0cffb36e4f
name: dhcp71-27.rhts.eng.bos.redhat.com
org name: Admin Owner
org ID: admin

Comment 6 Shwetha Kallesh 2017-05-30 11:44:08 UTC

[root@hp-dl380pgen8-02-vm-11 ~]# rhn-migrate-classic-to-rhsm --no-auto --no-proxy 
Legacy username: rhsm-client
Legacy password: 
Destination username: shwetha_tier1_test
Destination password: 

Retrieving existing legacy subscription information...

+-----------------------------------------------------+
System is currently subscribed to these legacy channels:
+-----------------------------------------------------+
rhel-x86_64-server-7

+-----------------------------------------------------+
Installing product certificates for these legacy channels:
+-----------------------------------------------------+
rhel-x86_64-server-7

Product certificates installed successfully to /etc/pki/product.

Preparing to unregister system from legacy server...
System successfully unregistered from legacy server.
Stopping and disabling legacy services...
rhnsd.service is not a native service, redirecting to /sbin/chkconfig.
Executing /sbin/chkconfig rhnsd off

Attempting to register system to destination server...
Registering to: subscription.rhsm.stage.redhat.com:443/subscription
The system has been registered with ID: af5ff06b-6b39-412a-8711-3a2037b00aa2 
System 'hp-dl380pgen8-02-vm-11.lab.bos.redhat.com' successfully registered.

Comment 7 errata-xmlrpc 2017-08-01 19:23:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2083


Note You need to log in before you can comment on or make changes to this bug.