Bug 1451113 - virt-manager shows incorrect CPU list for aarch64
Summary: virt-manager shows incorrect CPU list for aarch64
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager
Version: 26
Hardware: aarch64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Cole Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: ARMTracker
TreeView+ depends on / blocked
 
Reported: 2017-05-15 20:08 UTC by Jeremy Linton
Modified: 2017-07-17 16:15 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-07-17 16:15:03 UTC


Attachments (Terms of Use)
Dump of running guest (3.39 KB, text/plain)
2017-07-17 14:40 UTC, Jeremy Linton
no flags Details

Description Jeremy Linton 2017-05-15 20:08:01 UTC
Description of problem: virt-manager when setup with KVM shows incorrect CPU list. The dropdown lists "host-passthrough", "hypervisor default" and then a bunch of x86 CPUs. 


Version-Release number of selected component (if applicable):


How reproducible: 100%


Steps to Reproduce:
1. On aarch64 acpi (although this may not matter) machine, setup new VM using ISO
2. Select settings, cpu try to change the cpu type.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Cole Robinson 2017-07-14 23:45:50 UTC
Can you provide a VM XML config that shows this behavior on the CPU page? sudo virsh dumpxml $vmname

Comment 2 Jeremy Linton 2017-07-17 14:40 UTC
Created attachment 1299884 [details]
Dump of running guest

Comment 3 Cole Robinson 2017-07-17 16:15:03 UTC
Thanks, I reproduced. Showing x86 models was a virt-manager error, fixed now:

commit ca56f74ed7314487ce286ac5d00cd1bbaedb66f6
Author: Cole Robinson <crobinso@redhat.com>
Date:   Mon Jul 17 11:29:54 2017 -0400

    capabilities: Fix model list caching for different archs (bz 1451113)


That said, libvirt's virConnectGetCPUModelNames doesn't support aarch64, so you won't get any model names listed in virt-manager now either. That's a separate issue though. (note, you can still manually type a model name cortex-a57 or whatever, we just don't show a list)

Since that fix is just a UI tweak I'm closing as 'upstream', not really important enough to track explicitly backporting IMO


Note You need to log in before you can comment on or make changes to this bug.