Bug 1451115 - Fedora26 fails boot in power9 machine as guest
Summary: Fedora26 fails boot in power9 machine as guest
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 26
Hardware: ppc64le
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: PPCTracker
TreeView+ depends on / blocked
 
Reported: 2017-05-15 20:20 UTC by IBM Bug Proxy
Modified: 2017-05-18 18:07 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-18 18:07:03 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
IBM Linux Technology Center 154526 None None None 2017-05-15 20:20:34 UTC

Description IBM Bug Proxy 2017-05-15 20:20:16 UTC

Comment 1 IBM Bug Proxy 2017-05-15 20:20:27 UTC
Fedora 26 which is currently have 4.11.0-2.fc26.ppc64le does not boot as guest in power9 host, same image boots fine in power8 host as guest.

This BZ is to provide the relevant patches required for fedora to include to boot as power9 guest.

OF stdout device is: /vdevice/vty@30000000
Preparing to boot Linux version 4.11.0-2.fc26.ppc64le (mockbuild@buildvm-ppc64le-05.ppc.fedoraproject.org) (gcc version 7.1.1 20170503 (Red Hat 7.1.1-1) (GCC) ) #1 SMP Tue May 9 15:06:25 UTC 2017
Detected machine type: 0000000000000101
command line: BOOT_IMAGE=/vmlinuz-4.11.0-2.fc26.ppc64le root=UUID=92d94062-0393-4f94-be16-b95c3769af51 ro console=ttyS0 LANG=en_US.UTF-8
Max number of cores passed to firmware: 1024 (NR_CPUS = 1024)
Calling ibm,client-architecture-support... done
memory layout at init:
  memory_limit : 0000000000000000 (16 MB aligned)
  alloc_bottom : 00000000046d0000
  alloc_top    : 0000000010000000
  alloc_top_hi : 0000000200000000
  rmo_top      : 0000000010000000
  ram_top      : 0000000200000000
instantiating rtas at 0x000000000daf0000... done
prom_hold_cpus: skipped
copying OF device tree...
Building dt strings...
Building dt structure...
Device tree strings 0x00000000046e0000 -> 0x00000000046e0adf
Device tree struct  0x00000000046f0000 -> 0x0000000004700000
Quiescing Open Firmware ...
Booting Linux via __start() @ 0x0000000002000000 ...

Comment 2 Josh Boyer 2017-05-15 20:38:11 UTC
Fedora has no access to a power9 machine.  I'm sure the kernel maintainers would be happy to merge changes required, but they will not be able to debug this issue.

Comment 3 IBM Bug Proxy 2017-05-18 11:30:21 UTC
------- Comment From lagarcia@br.ibm.com 2017-05-18 07:28 EDT-------
This is a host issue, not a Fedora 26 guest issue.

*** This bug has been marked as a duplicate of bug 153759 ***


Note You need to log in before you can comment on or make changes to this bug.