Bug 1451143 - neovim 0.2.0 - ppc64/le build failure
Summary: neovim 0.2.0 - ppc64/le build failure
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: neovim
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Andreas Schneider
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: PPCTracker
TreeView+ depends on / blocked
 
Reported: 2017-05-15 22:58 UTC by Michel Alexandre Salim
Modified: 2017-05-31 09:52 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-05-31 09:52:17 UTC


Attachments (Terms of Use)
build log on ppc64 (261.87 KB, text/plain)
2017-05-15 22:58 UTC, Michel Alexandre Salim
no flags Details
build log on ppc64le (261.89 KB, text/plain)
2017-05-15 22:59 UTC, Michel Alexandre Salim
no flags Details

Description Michel Alexandre Salim 2017-05-15 22:58:54 UTC
Created attachment 1279167 [details]
build log on ppc64

Description of problem:
neovim 0.2.0 does not build cleanly on ppc64 and ppc64le on epel7 (conflicting implicit declarations of 'do_sub_msg')

Version-Release number of selected component (if applicable):
0.2.0-2.el7

How reproducible:
Always

Steps to Reproduce:
1. remove ExcludeArch
2. koji scratch-build --target epel7

Actual results:
Fails with the attached error logs

Expected results:
Build succeeds


Additional info:

Comment 1 Michel Alexandre Salim 2017-05-15 22:59 UTC
Created attachment 1279168 [details]
build log on ppc64le

Comment 2 Ngo Than 2017-05-31 09:52:17 UTC
it's fixed in 0.2.0-3


Note You need to log in before you can comment on or make changes to this bug.