Bug 1451159 - rpcbind fails to start with assertion failure
Summary: rpcbind fails to start with assertion failure
Keywords:
Status: CLOSED DUPLICATE of bug 1450765
Alias: None
Product: Fedora
Classification: Fedora
Component: rpcbind
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Steve Dickson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-05-16 01:13 UTC by Frank Ch. Eigler
Modified: 2017-05-16 19:05 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-16 19:05:01 UTC


Attachments (Terms of Use)

Description Frank Ch. Eigler 2017-05-16 01:13:39 UTC
rpcbind-0.2.4-5.rc1.fc25.x86_64

# service rpcbind start  [...fails...]
# gdb -args rpcbind -w -f
(gdb) run
rpcbind: pmap_prot.c:50: xdr_pmap: Assertion `regs != NULL' failed.

Program received signal SIGABRT, Aborted.
__GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:58
58	}
Missing separate debuginfos, use: dnf debuginfo-install keyutils-libs-1.5.9-8.fc24.x86_64 krb5-libs-1.14.4-7.fc25.x86_64 libcap-2.25-2.fc25.x86_64 libcom_err-1.43.3-1.fc25.x86_64 libgcc-6.3.1-1.fc25.x86_64 libgcrypt-1.6.6-1.fc25.x86_64 libgpg-error-1.24-1.fc25.x86_64 libselinux-2.5-13.fc25.x86_64 lz4-1.7.5-1.fc25.x86_64 pcre-8.40-7.fc25.x86_64
(gdb) bt
#0  __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:58
#1  0x00007ffff73ee51a in __GI_abort () at abort.c:89
#2  0x00007ffff73e4da7 in __assert_fail_base (fmt=<optimized out>, assertion=assertion@entry=0x7ffff7bcaf4c "regs != NULL", 
    file=file@entry=0x7ffff7bcaf40 "pmap_prot.c", line=line@entry=50, function=function@entry=0x7ffff7bcaf60 <__PRETTY_FUNCTION__.4689> "xdr_pmap")
    at assert.c:92
#3  0x00007ffff73e4e52 in __GI___assert_fail (assertion=assertion@entry=0x7ffff7bcaf4c "regs != NULL", 
    file=file@entry=0x7ffff7bcaf40 "pmap_prot.c", line=line@entry=50, function=function@entry=0x7ffff7bcaf60 <__PRETTY_FUNCTION__.4689> "xdr_pmap")
    at assert.c:101
#4  0x00007ffff7bb5bf0 in xdr_pmap (xdrs=<optimized out>, regs=0x0) at pmap_prot.c:50
#5  0x00005555555582b3 in pmapproc_dump (rqstp=0x7fffffffdaf0, xprt=0x555555765740) at src/pmap_svc.c:387
#6  pmap_service (rqstp=0x7fffffffdaf0, xprt=0x555555765740) at src/pmap_svc.c:124
#7  0x00007ffff7bbbce4 in svc_getreq_common (fd=<optimized out>) at svc.c:714
#8  0x00007ffff7bbbe95 in svc_getreq_poll (pfdp=pfdp@entry=0x7fffffffe0c0, pollretval=pollretval@entry=1) at svc.c:775
#9  0x000055555555b78d in my_svc_run () at src/rpcb_svc_com.c:1142
#10 0x0000555555557726 in main (argc=<optimized out>, argv=<optimized out>) at src/rpcbind.c:310

Comment 1 Frank Ch. Eigler 2017-05-16 01:20:34 UTC
rpcbind-0.2.4-6.rc1 seems to work better, please bodhi the bad boy!

Comment 2 Eric 2017-05-16 14:50:55 UTC
Still not working for me.

$ rpm -q rpcbind
rpcbind-0.2.4-6.rc1.fc25.x86_64
$ uname -r
4.10.15-200.fc25.x86_64

(gdb) run
Starting program: /usr/sbin/rpcbind -w -f
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
*** Error in `/usr/sbin/rpcbind': free(): invalid pointer: 0x00007ffffffdd2c0 ***
======= Backtrace: =========
/lib64/libc.so.6(+0x791fb)[0x7ffff74301fb]
/lib64/libc.so.6(+0x8288a)[0x7ffff743988a]
/lib64/libc.so.6(cfree+0x4c)[0x7ffff743d2bc]
/lib64/libtirpc.so.3(xdr_bytes+0x6d)[0x7ffff7bc2bbd]
/usr/sbin/rpcbind(+0x6a20)[0x55555555aa20]
/usr/sbin/rpcbind(+0x4305)[0x555555558305]
/lib64/libtirpc.so.3(svc_getreq_common+0x224)[0x7ffff7bbbce4]
/lib64/libtirpc.so.3(svc_getreq_poll+0x75)[0x7ffff7bbbe95]
/usr/sbin/rpcbind(+0x777d)[0x55555555b77d]
/usr/sbin/rpcbind(+0x3726)[0x555555557726]
/lib64/libc.so.6(__libc_start_main+0xf1)[0x7ffff73d7401]
/usr/sbin/rpcbind(+0x392a)[0x55555555792a]

Comment 3 Eric 2017-05-16 14:52:45 UTC
Should be merged with 1450765

Comment 4 Steve Dickson 2017-05-16 19:05:01 UTC

*** This bug has been marked as a duplicate of bug 1450765 ***


Note You need to log in before you can comment on or make changes to this bug.