Bug 1451211 - File conflicts when updating totem
Summary: File conflicts when updating totem
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gstreamer1-plugins-base
Version: 7.4
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Wim Taymans
QA Contact: Desktop QE
Tomas Capek
URL:
Whiteboard:
: 1482962 (view as bug list)
Depends On:
Blocks: 1477211 1547138
TreeView+ depends on / blocked
 
Reported: 2017-05-16 06:54 UTC by Jiri Koten
Modified: 2018-10-30 10:20 UTC (History)
8 users (show)

Fixed In Version: 1.10.4-2
Doc Type: Known Issue
Doc Text:
Updating _totem_ alone fails Explicit dependency between the _totem_ and _gstreamer1-plugins-bad-free_ packages is missing. Consequently, when trying to update just the _totem_ package, the operation fails. To work around this problem, do not update the _totem_ package by itself and rely on the system update instead.
Clone Of:
Environment:
Last Closed: 2018-10-30 10:19:44 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2018:3140 None None None 2018-10-30 10:20:42 UTC
Red Hat Knowledge Base (Solution) 3156301 None None None 2017-08-24 20:19:02 UTC

Description Jiri Koten 2017-05-16 06:54:16 UTC
Description of problem:
Updating just to new totem pkg fails because of file conflict between gstreamer1-plugins-base-1.10.4-1.el7.x86_64 and gstreamer1-plugins-bad-free-1.4.5-6.el7_3.x86_64


Transaction check error:
  file /usr/lib64/gstreamer-1.0/libgstopus.so from install of gstreamer1-plugins-base-1.10.4-1.el7.x86_64 conflicts with file from package gstreamer1-plugins-bad-free-1.4.5-6.el7_3.x86_64


This happens because totem requires newer gstreamer1-plugins-base pkg but does not require newer gstreamer1-plugins-bad-free.

There should be explicit dependency also on newer gstreamer1-plugins-bad-free.

Version-Release number of selected component (if applicable):
totem-3.22.1-1.el7 
gstreamer1-plugins-base-1.10.4-1.el7
gstreamer1-plugins-bad-free-1.4.5-6.el7_3.x86_64



How reproducible:
100%

Comment 3 Bastien Nocera 2017-05-16 08:50:29 UTC
The conflict is between 2 GStreamer packages, nothing to do with totem.

Comment 4 Wim Taymans 2017-05-16 09:08:03 UTC
How can I fix this? How can I say in the spec file of gstreamer1-plugins-good that when you install version X, it should also upgrade to at least version X of another package. I can't put a Requires there because the -bad-free package is optional.

Comment 5 Tomas Pelka 2017-05-22 12:05:26 UTC
Ok it seems as more totem issue. Or to be more precise it should be fixed on totem site.

The issue he is as far as I understand that if user update just totem than depsolver would be satisfied with gst1-plugins-bad-free and gst1-plugins-good stat are older than gst1 and gst1-plugins-base that will be available in rhel7.4. Yes for some weird reason user might only want to update totem and its deps.

In case of whole gnome stack and other components that will be part of rhel7.4 release get updated everything will be fine.

Comment 6 Wim Taymans 2017-07-20 13:27:59 UTC
I think I need in the gstreamer1-plugins-bad-free spec:

  Requires: gstreamer1-plugins-base%{?_isa} >= %{version}

I think that this would solve the current problem but not when, for example, a plugin got moved to -good.

Is there no way to say that *when* an optional package is installed, it should be at least X version?

Comment 7 Joe Wright 2017-08-24 20:21:06 UTC
*** Bug 1482962 has been marked as a duplicate of this bug. ***

Comment 8 arthurz 2017-09-25 02:58:50 UTC
The same error occurs upgrading CentOS 7.3.1611 (Core)

Comment 9 John P Kissell 2017-11-03 22:20:34 UTC
This happened to me on CentOS Linux 7 Kernel 3.10.0-514.26.2.el7.x86_64. I did a yum remove gstreamer1. Now my GUI is gone. Any help would be appreciated.

Comment 10 Ron Wheeler 2017-11-19 16:58:51 UTC
Had the problem on CentOS as well.

Solved it by removing totem, cheese and their dependendant packages totem-naultilus, totem-pl-parser as well as farstream and farstream02 and modules that depend on them such as cheese-libs, libpurple, telepathy-for-stream and empathy.
You can verify these names by trying to delete totem, cheese and farstream which will fail because of the packages that use them (totem-nautilus, etc).

Then I applied all of the updates to gnome (and everything else).

Then I reinstalled totem, cheese, farstream and farstream02 and the higher level packages.
That solved the problem.
It is a bit of work but gets things back to normal with everything updated.

The update of the kernel wiped out my Ethernet interface but that is another bug.

Comment 17 errata-xmlrpc 2018-10-30 10:19:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2018:3140


Note You need to log in before you can comment on or make changes to this bug.