Bug 1451372 - Obsolete perl-ZeroMQ, perl-ZMQ-LibZMQ2, perl-ZMQ-LibZMQ3
Summary: Obsolete perl-ZeroMQ, perl-ZMQ-LibZMQ2, perl-ZMQ-LibZMQ3
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-obsolete-packages
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jason Tibbitts
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-05-16 14:11 UTC by Petr Pisar
Modified: 2017-06-21 21:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-21 21:12:07 UTC
Type: Bug


Attachments (Terms of Use)

Description Petr Pisar 2017-05-16 14:11:49 UTC
Fedora 26 removed zeromq2 and zeromq3 packages and their reverse dependencies like:

perl-ZeroMQ
perl-ZMQ-LibZMQ2
perl-ZMQ-LibZMQ3

were removed.

Fedora 27 will rebase perl and thus the three above-listed Perl packages will cause conflicts when upgrading distribution from 26 to 27 because nothing obsoletes them.

I think this is the reason for fedora-obsolete-packages packages. Please add Obsoletes on:

perl-ZeroMQ <= 0.23-13.fc25
perl-ZMQ-LibZMQ2 <= 1.09-9.fc25
perl-ZMQ-LibZMQ3 <= 1.19-5.fc25

to F27 fedora-obsolete-packages package.

Comment 1 Jason Tibbitts 2017-05-16 17:28:38 UTC
No problem, this will go out to rawhide shortly.

Just to make sure I understand the situation, none of these packages are in F26 currently.  But at this time there is no need to remove these packages in F26, because while they may persist after an upgrade to F26, they will not cause problems.  But once in F26 with the updated Perl, nothing provides the old perl(:MODULE_COMPAT_foo) dependency, and so dnf will behave poorly.

Comment 2 Petr Pisar 2017-05-17 05:44:51 UTC
(In reply to Jason Tibbitts from comment #1)
> No problem, this will go out to rawhide shortly.
> 
> Just to make sure I understand the situation, none of these packages are in
> F26 currently.  But at this time there is no need to remove these packages
> in F26, because while they may persist after an upgrade to F26, they will
> not cause problems.

Yes.

>  But once in F26 with the updated Perl, nothing provides
> the old perl(:MODULE_COMPAT_foo) dependency, and so dnf will behave poorly.

But once in F27. Otherwise yes.

Comment 3 Jason Tibbitts 2017-06-21 21:12:07 UTC
Not sure why I didn't close this earlier.


Note You need to log in before you can comment on or make changes to this bug.