Bug 145140 - Adding XHTML support to xmlto
Summary: Adding XHTML support to xmlto
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xmlto   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ondrej Vasik
QA Contact:
URL: http://sources.redhat.com/ml/docbook-...
Whiteboard:
Keywords: FutureFeature
Depends On: xhtml2fo-style-xsl
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-14 18:19 UTC by Ismael Olea
Modified: 2009-03-16 14:25 UTC (History)
0 users

Fixed In Version: xmlto-0.0.21-9.fc11
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-16 14:04:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xmlto new spec (4.12 KB, text/plain)
2005-01-14 18:21 UTC, Ismael Olea
no flags Details
xhtml2fo xmlto's patch (5.36 KB, patch)
2005-01-14 18:22 UTC, Ismael Olea
no flags Details | Diff

Description Ismael Olea 2005-01-14 18:19:59 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040922 Galeon/1.3.18

Description of problem:
I've packaged an xhtml2fo stylesheet into RPM and extended xmlto for
converting xhtml files into fo, ps, pdf, dvi and txt.

Version-Release number of selected component (if applicable):
xmlto-0.0.18-4

How reproducible:
Always

Steps to Reproduce:
Use the rpms I'm providing or apply the patch into sources. 
    

Additional info:

Comment 1 Ismael Olea 2005-01-14 18:21:47 UTC
Created attachment 109788 [details]
xmlto new spec

Comment 2 Ismael Olea 2005-01-14 18:22:23 UTC
Created attachment 109789 [details]
xhtml2fo xmlto's patch

Comment 3 Ismael Olea 2005-01-14 18:23:25 UTC
In the main URL of the bug report you'll find the link to the
xhtml2fo.xsl package.


Comment 4 Ondrej Vasik 2008-01-14 17:20:57 UTC
Sorry for such a long response, but I have some things to clarify with you. I
became upstream maintainer of xmlto in Oct 2007 and I thought about adding X3D
and your xhtml1 into xmlto package. I have following problem - no x3d-xsl(but
this is already in package review process in fedora rawhide branch) and no
xhtml2fo-style-xsl in Fedora. Have you tried to get your xhtml2fo package into
fedora's rawhide? I can't add this to xmlto because of the requires for xhtml2fo
package could not be met in Fedora. Do you have some plans about adding your
package to Fedora's rawhide?

Comment 5 Ismael Olea 2008-01-15 10:38:35 UTC
I could try to propose the xhtml2fo-style-xsl package. Could you help me with
some mentorship, please?

Comment 6 Ismael Olea 2008-01-15 10:49:46 UTC
Here is the proposal: https://bugzilla.redhat.com/show_bug.cgi?id=428793

Comment 7 Ismael Olea 2008-10-01 23:10:03 UTC
Ok, the xhtml2fo-style-xsl is here: https://admin.fedoraproject.org/pkgdb/packages/name/xhtml2fo-style-xsl  :-)

Comment 8 Ondrej Vasik 2008-10-02 14:41:46 UTC
Thanks for info, would you mind to have me as comaintainer of that package? Just requested ACL's for it. I just want to be able to change/fix any issue as soon as it happen. Will try to make new xmlto release with xhtml1 support as soon as the time frame allows.

Comment 9 Ismael Olea 2008-10-06 02:17:27 UTC
Yes, please. Will be a pleasure!

Comment 10 Ondrej Vasik 2009-03-16 14:04:48 UTC
Built as xmlto-0.0.21-9.fc11 (xmlto-xhtml subpackage) - if you don't mind, please approve those xhtml2fo-style-xsl acl's for me https://admin.fedoraproject.org/pkgdb/packages/name/xhtml2fo-style-xsl . Anyway, closing RAWHIDE.

Comment 11 Ismael Olea 2009-03-16 14:16:17 UTC
Done! Sorry the delay. I'm not still very used to this ACL system :-)

Thanks!

Comment 12 Ondrej Vasik 2009-03-16 14:25:38 UTC
Thanks, sorry for delay too :)


Note You need to log in before you can comment on or make changes to this bug.