Bug 1451504 - rpcbind: abort, Error in `/usr/bin/rpcbind': free(): invalid pointer
Summary: rpcbind: abort, Error in `/usr/bin/rpcbind': free(): invalid pointer
Keywords:
Status: CLOSED DUPLICATE of bug 1450765
Alias: None
Product: Fedora
Classification: Fedora
Component: rpcbind
Version: 26
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Steve Dickson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-05-16 20:27 UTC by nicofonk
Modified: 2017-05-18 17:45 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-18 17:45:41 UTC


Attachments (Terms of Use)
backtrace of the abort (19.64 KB, text/plain)
2017-05-16 20:27 UTC, nicofonk
no flags Details

Description nicofonk 2017-05-16 20:27:29 UTC
Created attachment 1279413 [details]
backtrace of the abort

Description of problem:

When I tried to mount a NFS partition rpcbind abort.


Version-Release number of selected component (if applicable):

rpcbind-0.2.4-7.rc1.fc26.x86_64


How reproducible:

Sometime it happen when I mount/unmount a NFS partition from a remote, and this is systematic from my Kodi client when it try to discover the NFS export lists on my network. I dont know a command to reproduce this behavior spotted on Kodi but the Kodi source code can help (https://github.com/xbmc/xbmc/blob/master/xbmc/filesystem/NFSDirectory.cpp)

Steps to Reproduce:
1. Have a Kodi client on a raspberry as example and a fedora 26 with a nfs server.
2. From Kodi try to add a NFS source.
3. Have a rpcbind abort

Actual results:

The NFS partition is not mounted/not discovered.

Expected results:

The NFS partition is right mounted.

Additional info:

the content of my exports cfg file

/home/nfk/Videos   192.168.1.0/24 (ro,all_squash,insecure)

Comment 1 Eric 2017-05-18 17:10:29 UTC
Same in F25, as mentioned in both 1450765 and 1451159 where my comment was blissfully ignored :(

Last working version rpcbind-0.2.4-5.fc25.x86_64

Comment 2 Steve Dickson 2017-05-18 17:45:41 UTC

*** This bug has been marked as a duplicate of bug 1450765 ***


Note You need to log in before you can comment on or make changes to this bug.