Bug 1451630 - anaconda does not fall back to text mode for non-graphical systems
Summary: anaconda does not fall back to text mode for non-graphical systems
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 26
Hardware: aarch64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-05-17 08:13 UTC by Robert Richter
Modified: 2017-12-17 08:58 UTC (History)
13 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2017-07-17 12:31:46 UTC


Attachments (Terms of Use)
log files from /tmp (57.89 KB, application/x-xz)
2017-05-22 15:05 UTC, Robert Richter
no flags Details

Description Robert Richter 2017-05-17 08:13:34 UTC
Description of problem:

When booting the installer, anaconda does not fall back to text mode. Instead installation hangs and something like the following is seen:

----
Starting installer, one moment...
anaconda 26.21.6-1 for Fedora 26 (pre-release) started.
 * installation log files are stored in /tmp during the installation
 * shell is available on TTY2
 * when reporting a bug add logs from /tmp as separate text/plain attachments

(anaconda:2434): Gtk-WARNING **: Allocating size to pyanaconda+ui+gui+MainWindow 0xaaab08e14280 without calling gtk_widget_get_preferred_width/height(). How does the code know the size to allocate?

(anaconda:2434): Gtk-WARNING **: Allocating size to pyanaconda+ui+gui+MainWindow 0xaaab08e14280 without calling gtk_widget_get_preferred_width/height(). How does the code know the size to allocate?

(anaconda:2434): Gtk-WARNING **: Allocating size to pyanaconda+ui+gui+MainWindow 0xaaab08e14280 without calling gtk_widget_get_preferred_width/height(). How does the code know the size to allocate?

(anaconda:2434): Gtk-WARNING **: Allocating size to pyanaconda+ui+gui+MainWindow 0xaaab08e14280 without calling gtk_widget_get_preferred_width/height(). How does the code know the size to allocate?

----

As a workaround I switched to the shell window (ESC tab) and started the installer manually. It then detected that no X is running and installation started fine:

----
[anaconda root@localhost ~]# killall -9 anaconda
[anaconda root@localhost ~]# /usr/libexec/system-python /sbin/anaconda
Starting installer, one moment...
anaconda 26.21.6-1 for Fedora 26 (pre-release) started.
 * installation log files are stored in /tmp during the installation
 * shell is available on TTY2
 * when reporting a bug add logs from /tmp as separate text/plain attachments
07:59:59 X startup failed, falling back to text mode
================================================================================
================================================================================
VNC



 1) Start VNC

 2) Use text mode

Please make a selection from the above ['c' to continue, 'q' to quit, 'r' to
refresh]: 2

...
----

Version-Release number of selected component (if applicable):

Iso image from May 16 2017
anaconda 26.21.6-1 for Fedora 26 (pre-release)

Comment 1 Fedora Blocker Bugs Application 2017-05-17 08:39:53 UTC
Proposed as a Blocker for 26-beta by Fedora user rric using the blocker tracking app because:

 Text mode installation of F26 would only work using a workaround.

Comment 2 Robert Richter 2017-05-17 12:04:02 UTC
I have used

 Fedora-Server-dvd-aarch64-26-20170515.n.0.iso

from here:

 https://dl.fedoraproject.org/pub/fedora-secondary/development/26/Server/aarch64/iso/

Comment 3 Robert Richter 2017-05-17 12:05:26 UTC
Tested on a Cavium CN88xx (ThunderX)

Comment 4 Martin Kolman 2017-05-17 12:11:07 UTC
Are there any logs in /tmp after the UI fails to start (& before you start Anaconda manually) ? That might help us debug what's happening.

Comment 5 Stephen Gallagher 2017-05-17 12:41:00 UTC
FYI, I'm +1 blocker under the "When using a dedicated installer image, the installer must be able to complete an installation using the text, graphical and VNC installation interfaces." criterion.

Comment 6 Adam Williamson 2017-05-17 15:14:04 UTC
Well for a start this would need verifying on a release-blocking arch; aarch64 is not one.

That criterion wasn't really written with the fallback mechanism in mind (in fact until this bug showed up I didn't know there *was* a fallback mechanism). It just means that these interfaces must work when used explicitly (by passing inst.text, for e.g.)

Comment 7 Robert Richter 2017-05-22 15:05 UTC
Created attachment 1281101 [details]
log files from /tmp

Adding log files from /tmp

Comment 8 Petr Schindler 2017-05-22 16:27:07 UTC
Discussed at 2017-05-22 blocker review meeting: [1]. 

This bug was rejected as Beta blocker: Right now this issue is only reported on non-blocking architectures. Please re-propose if it can be reproduced on a blocking install medium.

[1] https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2017-05-22

Comment 9 Robert Richter 2017-07-17 12:31:46 UTC
Fixed in Fedora26:

Starting installer, one moment...
anaconda 26.21.11-1 for Fedora 26 started.
 * installation log files are stored in /tmp during the installation
 * shell is available on TTY2
 * when reporting a bug add logs from /tmp as separate text/plain attachments
21:45:11 X startup failed, falling back to text mode
================================================================================
================================================================================
VNC



 1) Start VNC

 2) Use text mode

Please make a selection from the above ['c' to continue, 'q' to quit, 'r' to
refresh]: 2
================================================================================
================================================================================
Installation

 1) [x] Language settings                 2) [!] Time settings
        (English (United States))                (Timezone is not set.)
 3) [!] Installation source               4) [!] Software selection
        (Processing...)                          (Processing...)
 5) [!] Installation Destination          6) [ ] Network configuration
        (No disks selected)                      (Connecting...)
 7) [!] Root password                     8) [!] User creation
        (Password is not set.)                   (No user will be created)

Please make a selection from the above ['b' to begin installation, 'h' to help,
'q' to quit, 'r' to refresh]:

Comment 10 Robert Richter 2017-08-15 15:12:24 UTC
I got a report this is failing again:

---
Starting installer, one moment...

anaconda 26.21.11-1 for Fedora 26 started.

* installation log files are stored in /tmp during the installation

* shell is available on TTY2

* when reporting a bug add logs from /tmp as separate text/plain attachments


(anaconda:2049): Gtk-WARNING **: Allocating size to
pyanaconda+ui+gui+MainWindow 0xaaab19fa82a0 without calling
gtk_widget_get_preferred_width/height(). How does the code know the size to
allocate?


(anaconda:2049): Gtk-WARNING **: Allocating size to
pyanaconda+ui+gui+MainWindow 0xaaab19fa82a0 without calling
gtk_widget_get_preferred_width/height(). How does the code know the size to
allocate?


(anaconda:2049): Gtk-WARNING **: Allocating size to
pyanaconda+ui+gui+MainWindow 0xaaab19fa82a0 without calling
gtk_widget_get_preferred_width/height(). How does the code know the size to
allocate?
---

Will try to reproduce.

Comment 11 Robert Richter 2017-08-15 15:14:59 UTC
Here another workaround from pwhalen:

"as a work around you can also specify 'text' in the kernel args which should also work as well"


Note You need to log in before you can comment on or make changes to this bug.