Bug 1451777 - Octavia scenario tests fail with 'No such file or directory', because the Octavia tests subpackage does not bring in the 'golang' dependency
Summary: Octavia scenario tests fail with 'No such file or directory', because the Oct...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-octavia
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: Upstream M2
: 12.0 (Pike)
Assignee: Nir Magnezi
QA Contact: Alexander Stafeyev
URL:
Whiteboard:
: 1451789 (view as bug list)
Depends On:
Blocks: 1451829
TreeView+ depends on / blocked
 
Reported: 2017-05-17 13:44 UTC by Arie Bregman
Modified: 2019-09-10 14:09 UTC (History)
13 users (show)

Fixed In Version: openstack-octavia-1.0.0-0.20170719072610.208395f.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-13 21:27:05 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
RDO 6688 None None None 2017-05-18 12:47:31 UTC
Red Hat Product Errata RHEA-2017:3462 normal SHIPPED_LIVE Red Hat OpenStack Platform 12.0 Enhancement Advisory 2018-02-16 01:43:25 UTC

Description Arie Bregman 2017-05-17 13:44:52 UTC
Description of problem:

When running Octavia scenario tests, after deploying it with TripleO, the following tests are failing:

octavia.tests.tempest.v1.scenario.test_listener_basic.TestListenerBasic.test_load_balancer_basic
octavia.tests.tempest.v1.scenario.test_load_balancer_tree_minimal.TestLoadBalancerTreeMinimal.test_load_balancer_tree_minimal

The traceback:

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/tempest/test.py", line 103, in wrapper
    return f(self, *func_args, **func_kwargs)
  File "/usr/lib/python2.7/site-packages/octavia/tests/tempest/v1/scenario/test_load_balancer_tree_minimal.py", line 44, in test_load_balancer_tree_minimal
    self._start_backend_httpd_processes('server1')
  File "/usr/lib/python2.7/site-packages/octavia/tests/tempest/v1/scenario/base.py", line 249, in _start_backend_httpd_processes
    httpd = self._build_static_httpd()
  File "/usr/lib/python2.7/site-packages/octavia/tests/tempest/v1/scenario/base.py", line 239, in _build_static_httpd
    'httpd.go', cwd=builddir)
  File "/usr/lib/python2.7/site-packages/octavia/tests/tempest/v1/scenario/base.py", line 826, in execute
    proc = subprocess.Popen(args, **subprocess_args)
  File "/usr/lib64/python2.7/subprocess.py", line 711, in __init__
    errread, errwrite)
  File "/usr/lib64/python2.7/subprocess.py", line 1327, in _execute_child
    raise child_exception
OSError: [Errno 2] No such file or directory

Version-Release number of selected component (if applicable): openstack-octavia-housekeeping-0.10.0-6.el7ost.noarch


How reproducible: 100


Steps to Reproduce:
1. Deploy Director OSP 11 + Octavia
2. Run Octavia scenario tests

Actual results: Fail


Expected results: All tests passed successfully :)

Comment 2 Assaf Muller 2017-05-17 14:12:34 UTC
I think the test assumes that the 'go' binary is present on the test machine, and in our case it isn't?

Comment 4 Alexander Stafeyev 2017-05-17 15:05:16 UTC
*** Bug 1451789 has been marked as a duplicate of this bug. ***

Comment 5 Nir Magnezi 2017-05-18 12:49:21 UTC
(In reply to Assaf Muller from comment #2)
> I think the test assumes that the 'go' binary is present on the test
> machine, and in our case it isn't?

Looks like this is the case in u/s OpenStack Nodes, but indeed not in ours.
I've added this as a dependency for the Octavia tests package: https://review.rdoproject.org/r/#/c/6688/

Comment 23 errata-xmlrpc 2017-12-13 21:27:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462


Note You need to log in before you can comment on or make changes to this bug.