Bug 145180 - -arp flag to ifconfig doesn't work
-arp flag to ifconfig doesn't work
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: net-tools (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-14 19:26 EST by Dave Brown
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-09 03:58:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Brown 2005-01-14 19:26:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
Bringing and interface up using "ifconfig X.X.X.X netmask A.A.A.A
-arp" does not set the NOARP parameter on the interface and the ip
address responds to arpings from other machines on the network.

Additionally setting the ARP=no parameter in the ifcfg-ethX file
demonstrates the same behaviour.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. ifconfig ethX X.X.X.X netmask A.A.A.A -arp

OR ifcfg-ethX setup as 
DEVICE=eth0
ONBOOT=yes
BOOTPROTO=static
IPADDR=XX.XX.XX.XX
NETMASK=XX.XX.XX.XX
ARP=no
    

Actual Results:  eth0      Link encap:Ethernet  HWaddr :0:6B:84:C9:00
          inet addr:XX.XX.XX.XX  Bcast:XX.XX.XX.XX  Mask:XX.XX.XX.XX
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3807534 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2214409 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:477367079 (455.2 Mb)  TX bytes:873930766 (833.4 Mb)
          Interrupt:11 Base address:0x2000 Memory:c0100000-c0100038 

Expected Results:  eth0      Link encap:Ethernet  HWaddr :0:6B:84:C9:00
          inet addr:XX.XX.XX.XX  Bcast:XX.XX.XX.XX  Mask:XX.XX.XX.XX
          UP BROADCAST NOARP RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3807534 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2214409 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:477367079 (455.2 Mb)  TX bytes:873930766 (833.4 Mb)
          Interrupt:11 Base address:0x2000 Memory:c0100000-c0100038 

Additional info:
Interfaces with ARP flag set to no or -arp option set should not
respond to arpings but they do.
Comment 1 Radek Vokal 2005-02-09 03:58:11 EST
Hmm, this works for me as it's supposed to work. Would be great to
have your net-tools version here and also the kernel you're currently
using. Here's my test case

root@garfield ~# ifconfig
lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:10050 errors:0 dropped:0 overruns:0 frame:0
          TX packets:10050 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:6285371 (5.9 MiB)  TX bytes:6285371 (5.9 MiB)

root@garfield ~# ifconfig eth0 192.168.1.13 netmask 255.255.255.0 -arp
root@garfield ~# ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 00:0F:1F:78:0D:18
          inet addr:192.168.1.13  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::20f:1fff:fe78:d18/64 Scope:Link
          UP BROADCAST RUNNING NOARP MULTICAST  MTU:1500  Metric:1
                               ^^^^^
          RX packets:49866 errors:0 dropped:0 overruns:0 frame:0
          TX packets:48339 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:57890262 (55.2 MiB)  TX bytes:4388231 (4.1 MiB)
          Base address:0xdf40 Memory:fcfe0000-fd000000

root@garfield ~# ifconfig eth0 arp
root@garfield ~# ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 00:0F:1F:78:0D:18
          inet addr:192.168.1.13  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::20f:1fff:fe78:d18/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:49871 errors:0 dropped:0 overruns:0 frame:0
          TX packets:48342 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:57890721 (55.2 MiB)  TX bytes:4388443 (4.1 MiB)
          Base address:0xdf40 Memory:fcfe0000-fd000000


Note You need to log in before you can comment on or make changes to this bug.