Bug 1451804 - "AttributeError: 'tuple' object has no attribute 'append'" error observed during ipa upgrade with latest package.
Summary: "AttributeError: 'tuple' object has no attribute 'append'" error observed dur...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Nikhil Dehadrai
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-05-17 14:44 UTC by Nikhil Dehadrai
Modified: 2018-01-02 12:13 UTC (History)
6 users (show)

Fixed In Version: 4.5.0-13.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 09:50:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2304 normal SHIPPED_LIVE ipa bug fix and enhancement update 2017-08-01 12:41:35 UTC

Description Nikhil Dehadrai 2017-05-17 14:44:13 UTC
Description of problem:
"AttributeError: 'tuple' object has no attribute 'append'" error observed during ipa upgrade with latest package resulting in upgrade failure.

Version-Release number of selected component (if applicable):
ipa-server-4.5.0-12.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Setup IPA-server at RHEL 7.3.z.
2. Use the latest repo links for RHEL 7.4
3. Update the ipa server by executing commands:
# yum -y update 'ipa*' sssd selinux-policy 'python*'

Actual results:
After step 3, IPA upgrade fails.

IPA server upgrade failed: Inspect /var/log/ipaupgrade.log and run command ipa-server-upgrade manually.
Unexpected error - see /var/log/ipaupgrade.log for details:
AttributeError: 'tuple' object has no attribute 'append'
The ipa-server-upgrade command failed. See /var/log/ipaupgrade.log for more information

[root@bkr-hv01-guest17 ~]# tail -50 /var/log/ipaupgrade.log
ocspSigningCert cert-pki-ca                                  u,u,u
subsystemCert cert-pki-ca                                    u,u,u
caSigningCert cert-pki-ca                                    CTu,Cu,Cu
Server-Cert cert-pki-ca                                      u,u,u
auditSigningCert cert-pki-ca                                 u,u,Pu
 
2017-05-17T14:22:52Z DEBUG stderr=
2017-05-17T14:22:52Z DEBUG Configuring certmonger to stop tracking system certificates for CA
2017-05-17T14:22:52Z DEBUG Starting external process
2017-05-17T14:22:52Z DEBUG args=/bin/systemctl start messagebus.service
2017-05-17T14:22:52Z DEBUG Process finished, return code=0
2017-05-17T14:22:52Z DEBUG stdout=
2017-05-17T14:22:52Z DEBUG stderr=
2017-05-17T14:22:52Z DEBUG Starting external process
2017-05-17T14:22:52Z DEBUG args=/bin/systemctl is-active messagebus.service
2017-05-17T14:22:52Z DEBUG Process finished, return code=0
2017-05-17T14:22:52Z DEBUG stdout=active
 
2017-05-17T14:22:52Z DEBUG stderr=
2017-05-17T14:22:52Z DEBUG Starting external process
2017-05-17T14:22:52Z DEBUG args=/bin/systemctl start certmonger.service
2017-05-17T14:22:52Z DEBUG Process finished, return code=0
2017-05-17T14:22:52Z DEBUG stdout=
2017-05-17T14:22:52Z DEBUG stderr=
2017-05-17T14:22:52Z DEBUG Starting external process
2017-05-17T14:22:52Z DEBUG args=/bin/systemctl is-active certmonger.service
2017-05-17T14:22:52Z DEBUG Process finished, return code=0
2017-05-17T14:22:52Z DEBUG stdout=active
 
2017-05-17T14:22:52Z DEBUG stderr=
2017-05-17T14:22:52Z ERROR IPA server upgrade failed: Inspect /var/log/ipaupgrade.log and run command ipa-server-upgrade manually.
2017-05-17T14:22:52Z DEBUG   File "/usr/lib/python2.7/site-packages/ipapython/admintool.py", line 172, in execute
    return_value = self.run()
  File "/usr/lib/python2.7/site-packages/ipaserver/install/ipa_server_upgrade.py", line 46, in run
    server.upgrade()
  File "/usr/lib/python2.7/site-packages/ipaserver/install/server/upgrade.py", line 1905, in upgrade
    upgrade_configuration()
  File "/usr/lib/python2.7/site-packages/ipaserver/install/server/upgrade.py", line 1782, in upgrade_configuration
    certificate_renewal_update(ca, ds, http),
  File "/usr/lib/python2.7/site-packages/ipaserver/install/server/upgrade.py", line 1002, in certificate_renewal_update
    ca.stop_tracking_certificates()
  File "/usr/lib/python2.7/site-packages/ipaserver/install/cainstance.py", line 1026, in stop_tracking_certificates
    super(CAInstance, self).stop_tracking_certificates(False)
  File "/usr/lib/python2.7/site-packages/ipaserver/install/dogtaginstance.py", line 336, in stop_tracking_certificates
    nicknames.append(self.server_cert_name)
 
2017-05-17T14:22:52Z DEBUG The ipa-server-upgrade command failed, exception: AttributeError: 'tuple' object has no attribute 'append'
2017-05-17T14:22:52Z ERROR Unexpected error - see /var/log/ipaupgrade.log for details:
AttributeError: 'tuple' object has no attribute 'append'
2017-05-17T14:22:52Z ERROR The ipa-server-upgrade command failed. See /var/log/ipaupgrade.log for more information




Expected results:
IPA upgrade should complete successfully without any errors.

Additional info:
Similar behavior is observed for other paths:
1. RHEL 7.3(ga) to 7.4
2. RHEL 7.2.z to RHEL 7.4
3. RHEL 7.1.z to RHEL 7.4

Comment 3 Petr Vobornik 2017-05-18 07:44:22 UTC
Is this the similar regression as the uninstaller issue which Flo fixed?

Comment 4 Jan Cholasta 2017-05-18 07:45:54 UTC
It is the very same regression.

Comment 7 Nikhil Dehadrai 2017-05-22 10:17:01 UTC
IPA server version: ipa-server-4.5.0-13.el7.x86_64

Tested the bug with following observations:

1) Verified that upgrade of IPA server to latest version is successful.
2) No errors/ failures are observed during upgrade process.
3) All the basic commands work successfully after upgrade.
4) Verified the same for other upgrade paths:
  - RHEL 7.1.z > Rhel 7.4
  - RHEL 7.2.z > Rhel 7.4
  - RHEL 7.3 > Rhel 7.4
  - RHEL 7.3.z > Rhel 7.4
5) For log through UI after upgrade we are unable to login for which a separate bug is logged BZ#1451733

Thus n the basis of above observations, marking status of bug to "VERIFIED"

Comment 9 errata-xmlrpc 2017-08-01 09:50:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2304


Note You need to log in before you can comment on or make changes to this bug.