Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.

Bug 1451909

Summary: hawkular-metrics 3.6.0 pod will not start - openssl: command not found
Product: OpenShift Container Platform Reporter: Mike Fiedler <mifiedle>
Component: HawkularAssignee: Matt Wringe <mwringe>
Status: CLOSED DUPLICATE QA Contact: Liming Zhou <lizhou>
Severity: high Docs Contact:
Priority: unspecified    
Version: 3.6.0CC: aos-bugs
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2017-05-17 20:19:17 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Mike Fiedler 2017-05-17 20:02:31 UTC
Description of problem:

registry.ops.openshift.com/openshift3/metrics-hawkular-metrics    3.6.0               12f3f49d713a

Deployed metrics with the openshift-logging byo playbook with the inventory below and the hawkular pod failed to start with the following errors:

2017-05-17 19:50:18 Starting Hawkular Metrics
/opt/hawkular/scripts/hawkular-metrics-wrapper.sh: line 49: openssl: command not found
/opt/hawkular/scripts/hawkular-metrics-wrapper.sh: line 53: openssl: command not found
The service account has read permissions for its project. Proceeding
Creating the Hawkular Metrics keystore from the Secret's cert data
/opt/hawkular/scripts/hawkular-metrics-wrapper.sh: line 104: openssl: command not found
Failed to create a PKCS12 certificate file with the service-specific certificate. Aborting.



Version-Release number of selected component (if applicable): metrics 3.6.0 on OCP 3.6.75


How reproducible: Always


Steps to Reproduce:
1.  Run the openshift-logging playbook with the inventory below (adjust hostnames)


Actual results:

hawkular-metrics pod fails to start with the errors above

Expected results:

hawkular-metrics starts successfully

Additional info:

Ansible inventory

[oo_first_master]
ip-172-31-11-103

[oo_first_master:vars]
openshift_deployment_type=openshift-enterprise
openshift_release=v3.6.0

openshift_metrics_install_metrics=true
openshift_metrics_hawkular_hostname=hawkular-metrics.0517-ja5.qe.rhcloud.com
openshift_metrics_project=openshift-infra
openshift_metrics_image_prefix=registry.ops.openshift.com/openshift3/
openshift_metrics_image_version=3.6.0
openshift_metrics_cassandra_replicas=1
openshift_metrics_hawkular_replicas=1
openshift_metrics_cassandra_storage_type=dynamic
openshift_metrics_cassandra_pvc_size=50Gi

Comment 1 Mike Fiedler 2017-05-17 20:19:17 UTC

*** This bug has been marked as a duplicate of bug 1445568 ***