Bug 1451914 - [abrt] gnome-shell: GjsMaybeOwned<JS::Value>::trace(): gnome-shell killed by signal 6
Summary: [abrt] gnome-shell: GjsMaybeOwned<JS::Value>::trace(): gnome-shell killed by ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gjs
Version: 26
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Colin Walters
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:0ab05b899c4bb7e164219048e75...
: 1451935 (view as bug list)
Depends On:
Blocks: F26FinalBlocker F26FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2017-05-17 20:40 UTC by Mikhail
Modified: 2018-05-15 16:59 UTC (History)
12 users (show)

Fixed In Version: gjs-1.48.4-1.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-18 23:55:09 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (68.91 KB, text/plain)
2017-05-17 20:40 UTC, Mikhail
no flags Details
File: cgroup (319 bytes, text/plain)
2017-05-17 20:40 UTC, Mikhail
no flags Details
File: core_backtrace (40.39 KB, text/plain)
2017-05-17 20:40 UTC, Mikhail
no flags Details
File: cpuinfo (1.26 KB, text/plain)
2017-05-17 20:40 UTC, Mikhail
no flags Details
File: dso_list (25.92 KB, text/plain)
2017-05-17 20:40 UTC, Mikhail
no flags Details
File: environ (1.74 KB, text/plain)
2017-05-17 20:40 UTC, Mikhail
no flags Details
File: limits (1.29 KB, text/plain)
2017-05-17 20:40 UTC, Mikhail
no flags Details
File: maps (190.08 KB, text/plain)
2017-05-17 20:40 UTC, Mikhail
no flags Details
File: open_fds (9.14 KB, text/plain)
2017-05-17 20:40 UTC, Mikhail
no flags Details
File: proc_pid_status (1.28 KB, text/plain)
2017-05-17 20:40 UTC, Mikhail
no flags Details
File: var_log_messages (1.53 KB, text/plain)
2017-05-17 20:40 UTC, Mikhail
no flags Details


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 781799 None None None 2017-05-24 16:10:20 UTC

Description Mikhail 2017-05-17 20:40:17 UTC
Description of problem:
gnome-shell session ended when I watching movie in Totem player

Version-Release number of selected component:
gnome-shell-3.24.2-1.fc26

Additional info:
reporter:       libreport-2.9.1
backtrace_rating: 4
cmdline:        /usr/bin/gnome-shell
crash_function: GjsMaybeOwned<JS::Value>::trace
executable:     /usr/bin/gnome-shell
journald_cursor: s=a904c01ca9734563afe62370c5f48ca4;i=d0c5;b=fb9011e634a64bc6805cc45d242dc6d5;m=14f4ae6fdd;t=54fbe080aa62d;x=dc6ff67540b02f46
kernel:         4.11.0-2.fc26.x86_64+debug
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 1 Mikhail 2017-05-17 20:40:24 UTC
Created attachment 1279786 [details]
File: backtrace

Comment 2 Mikhail 2017-05-17 20:40:26 UTC
Created attachment 1279787 [details]
File: cgroup

Comment 3 Mikhail 2017-05-17 20:40:28 UTC
Created attachment 1279788 [details]
File: core_backtrace

Comment 4 Mikhail 2017-05-17 20:40:30 UTC
Created attachment 1279789 [details]
File: cpuinfo

Comment 5 Mikhail 2017-05-17 20:40:32 UTC
Created attachment 1279790 [details]
File: dso_list

Comment 6 Mikhail 2017-05-17 20:40:34 UTC
Created attachment 1279791 [details]
File: environ

Comment 7 Mikhail 2017-05-17 20:40:36 UTC
Created attachment 1279792 [details]
File: limits

Comment 8 Mikhail 2017-05-17 20:40:38 UTC
Created attachment 1279793 [details]
File: maps

Comment 9 Mikhail 2017-05-17 20:40:41 UTC
Created attachment 1279794 [details]
File: open_fds

Comment 10 Mikhail 2017-05-17 20:40:42 UTC
Created attachment 1279795 [details]
File: proc_pid_status

Comment 11 Mikhail 2017-05-17 20:40:44 UTC
Created attachment 1279796 [details]
File: var_log_messages

Comment 12 Jan Doumont 2017-05-17 22:57:12 UTC
*** Bug 1451935 has been marked as a duplicate of this bug. ***

Comment 13 Mikhail 2017-05-20 15:20:43 UTC
Similar problem has been detected:

This crash catalysing by playing and rewinding video in Totem player.

reporter:       libreport-2.9.1
backtrace_rating: 4
cmdline:        /usr/bin/gnome-shell
crash_function: GjsMaybeOwned<JS::Value>::trace
executable:     /usr/bin/gnome-shell
journald_cursor: s=4b44205f8c97439e9d0ad63351d56689;i=32df;b=e87c79a1abbd413a8ec5758409e4acc1;m=39137fca7;t=54ff44be86358;x=12969c06426aa11b
kernel:         4.11.1-300.fc26.x86_64+debug
package:        gnome-shell-3.24.2-1.fc26
reason:         gnome-shell killed by signal 6
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 14 Christian Stadelmann 2017-05-22 13:42:36 UTC
Upstream bug: https://bugzilla.gnome.org/show_bug.cgi?id=781799

Duplicates:
https://bugzilla.redhat.com/show_bug.cgi?id=1452901

Possible duplicates or at least related:
https://bugzilla.redhat.com/show_bug.cgi?id=1451805
https://bugzilla.redhat.com/show_bug.cgi?id=1452453

This issue happens quite often and thus it should be a prioritized bug at least. There is no formal criterium to make it block the final release, but I'd say it qualifies as such anyway.

Comment 15 Fedora Blocker Bugs Application 2017-05-22 13:43:37 UTC
Proposed as a Blocker and Freeze Exception for 26-final by Fedora user genodeftest using the blocker tracking app because:

 This issue happens quite often and crashes the whole session on the default desktop, GNOME on wayland. This results in data loss. It should be a prioritized bug at least. There is no formal criterium (as far as I know) to make it block the final release, but I'd say it qualifies as such anyway.

Comment 16 Mikhail 2017-05-24 02:51:46 UTC
Similar problem has been detected:

1. # dnf install gstreamer1-libav
2. Watching your favorite H.264 video with Totem player

reporter:       libreport-2.9.1
backtrace_rating: 4
cmdline:        /usr/bin/gnome-shell
crash_function: GjsMaybeOwned<JS::Value>::trace
executable:     /usr/bin/gnome-shell
journald_cursor: s=4b44205f8c97439e9d0ad63351d56689;i=a827;b=710f3f1a70614f429ad86b7cd6788c00;m=dd95e9b;t=5503c0af6e688;x=99330cfcee549085
kernel:         4.11.1-300.fc26.x86_64+debug
package:        gnome-shell-3.24.2-1.fc26
reason:         gnome-shell killed by signal 6
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 17 Michael Catanzaro 2017-05-24 16:10:21 UTC
We really ought to have a blocker criterion that covers *commonly-encountered* full desktop crashes. I admittedly can't find one either, but I bet the QA folks will be able to think of one that applies.

Comment 18 Vít Ondruch 2017-05-28 20:47:53 UTC
These are possibly duplicates:

https://bugzilla.redhat.com/buglist.cgi?quicksearch=GjsMaybeOwned&list_id=7404884

Comment 19 Mikhail 2017-06-03 09:57:05 UTC
Similar problem has been detected:

gnome-shell session ended when I watching movie in Totem player

reporter:       libreport-2.9.1
backtrace_rating: 4
cmdline:        /usr/bin/gnome-shell
crash_function: GjsMaybeOwned<JS::Value>::trace
executable:     /usr/bin/gnome-shell
journald_cursor: s=a904c01ca9734563afe62370c5f48ca4;i=d0c5;b=fb9011e634a64bc6805cc45d242dc6d5;m=14f4ae6fdd;t=54fbe080aa62d;x=dc6ff67540b02f46
kernel:         4.11.0-2.fc26.x86_64+debug
package:        gnome-shell-3.24.2-1.fc26
reason:         gnome-shell killed by signal 6
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 20 Mikhail 2017-06-03 22:20:40 UTC
Similar problem has been detected:

Crashed when played video in Totem player

reporter:       libreport-2.9.1
backtrace_rating: 4
cmdline:        /usr/bin/gnome-shell
crash_function: GjsMaybeOwned<JS::Value>::trace
executable:     /usr/bin/gnome-shell
journald_cursor: s=4b44205f8c97439e9d0ad63351d56689;i=28f25;b=d014ffaf9e2647fc8cdbdd9067e324cb;m=2aa4672c73;t=5511594ce5825;x=147e751b68bab5f9
kernel:         4.11.3-300.fc26.x86_64+debug
package:        gnome-shell-3.24.2-1.fc26
reason:         gnome-shell killed by signal 6
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 21 Adam Williamson 2017-06-05 16:36:52 UTC
How about https://bugzilla.redhat.com/show_bug.cgi?id=1450639 ? the trace is different, but the descriptions sound very similar - crash when playing videos with Totem, often with libav...

Comment 22 Adam Williamson 2017-06-05 18:52:20 UTC
Discussed at 2017-06-05 blocker review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2017-06-05/f26-blocker-review.2017-06-05-16.01.html . Notwithstanding the question of exactly what is a dupe of what, we agreed that the general issue - many people seem to be able to crash GNOME Shell frequently just by playing a video in Totem - counts as a blocker, with reference to two criteria:

"All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test." - playing a video is pretty 'basic functionality' in Totem, and it shouldn't crash Totem, let alone GNOME.

"All known bugs that can cause corruption of user data must be fixed or documented at Common F26 bugs." - any GNOME Shell crash under Wayland can be argued to fall under this criterion, as GNOME cannot currently recover from Shell crashes gracefully as it does under X11; it just immediately kills the session and all running apps.

Comment 23 Christian Stadelmann 2017-06-07 11:19:37 UTC
This issue happens way less often (or even never) when using GNOME/Xorg instead of GNOME/Wayland.

For anyone running into this bug, I can recommend using GNOME/Xorg as a workaround. In case this bug cannot be fixed soon, this could also be a fallback strategy for the Fedora 26 Final release.

Comment 24 Florian Müllner 2017-06-08 13:30:40 UTC
This happens during javascript garbage collection, so either in gjs or mozjs38.

Comment 25 Christian Stadelmann 2017-06-12 07:38:47 UTC
The upstream bug report https://bugzilla.gnome.org/show_bug.cgi?id=781799 has some patches attached. Can you please provide a build with these patches applied so we can test? If you don't want to push the build to updates-testing, a koji link should be sufficient.

Comment 26 Fedora Update System 2017-06-14 04:58:14 UTC
gjs-1.48.3-3.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-0ee2da9169

Comment 27 Fedora Update System 2017-06-15 13:58:35 UTC
gjs-1.48.3-3.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-0ee2da9169

Comment 28 Fedora Update System 2017-06-16 06:51:10 UTC
gjs-1.48.4-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-f93990025d

Comment 29 Fedora Update System 2017-06-16 22:25:07 UTC
gjs-1.48.4-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-f93990025d

Comment 30 Fedora Update System 2017-06-18 23:55:09 UTC
gjs-1.48.4-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 31 Chris Coughlan 2017-08-07 07:00:33 UTC
I'm seeing a very similar problem on gjs-1.48.5:

Aug 07 15:43:56 ravenholm systemd-coredump[15151]: Process 4840 (gnome-shell) of user 1000 dumped core.
                                                   
                                                   Stack trace of thread 4840:
                                                   #0  0x00007f0bfec27085 n/a (libgjs.so.0)
                                                   #1  0x00007f0bf746cc27 g_idle_dispatch (libglib-2.0.so.0)
                                                   #2  0x00007f0bf7470247 g_main_context_dispatch (libglib-2.0.so.0)
                                                   #3  0x00007f0bf74705e8 g_main_context_iterate.isra.25 (libglib-2.0.so.0)
                                                   #4  0x00007f0bf7470902 g_main_loop_run (libglib-2.0.so.0)
                                                   #5  0x00007f0bfbe8daec meta_run (libmutter-0.so.0)
                                                   #6  0x00005630b29914a7 main (gnome-shell)
                                                   #7  0x00007f0bf58aa4da __libc_start_main (libc.so.6)
                                                   #8  0x00005630b29915ba _start (gnome-shell)

Comment 32 Christian Stadelmann 2017-08-07 16:45:37 UTC
(In reply to Chris Coughlan from comment #31)
> I'm seeing a very similar problem on gjs-1.48.5:

How do you even know your problem is similar? Please install debug symbols before posting any such backtraces. Without debug symbols they are useless.

Anyway, gjs-1.48.6 has been released a week ago, you should try installing the update first.


Note You need to log in before you can comment on or make changes to this bug.