Bug 145198 - rdiff-backup segfaults when run on a 64-bit kernel
Summary: rdiff-backup segfaults when run on a 64-bit kernel
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-15 06:01 UTC by Bill Nottingham
Modified: 2015-01-04 22:15 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-15 18:27:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bill Nottingham 2005-01-15 06:01:21 UTC
Description of problem:

rdiff-backup segfaults while backing up, but only
when run on a 64-bit kernel.

The matrix is:

32-bit rdiff-backup running on 32-bit kernel -> works
32-bit rdiff-backup running on 64-bit kernel (chroot) -> segfaults
64-bit rdiff-backup running on 64-bit kernel -> segfaults

The segfault is at random places in python.

Version-Release number of selected component (if applicable):

kernel-2.6.10-1.741

How reproducible:

Every time so far.

Dunno if it's actually kernel. But that seems to be the common
factor. :/

Comment 1 Bill Nottingham 2005-02-05 02:58:54 UTC
So, turning off:

"Unused PCI Slot clock"
"Cool & Quiet Support"

in the BIOS magically fixes everything.

Comment 2 Bill Nottingham 2005-02-05 04:36:29 UTC
OK, it's just Cool&Quiet being enabled that triggers the bug.

Comment 3 Dave Jones 2005-07-15 18:25:01 UTC
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.

Comment 4 Bill Nottingham 2005-07-15 18:27:36 UTC
HW/BIOS bug.


Note You need to log in before you can comment on or make changes to this bug.