Bug 1452000 - Spacing issue in fix-layout status output
Summary: Spacing issue in fix-layout status output
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: distribute
Version: 3.11
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: ankit
QA Contact:
URL:
Whiteboard:
Depends On: 1412045 1437748
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-05-18 06:52 UTC by ankit
Modified: 2017-05-30 18:52 UTC (History)
6 users (show)

Fixed In Version: glusterfs-3.11.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1437748
Environment:
Last Closed: 2017-05-30 06:30:23 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Worker Ant 2017-05-18 08:48:46 UTC
REVIEW: https://review.gluster.org/17327 (dht:Spacing issue in fix-layout o/p) posted (#2) for review on release-3.11 by ankitraj

Comment 2 Worker Ant 2017-05-25 15:06:58 UTC
REVIEW: https://review.gluster.org/17327 (dht:Spacing issue in fix-layout o/p) posted (#3) for review on release-3.11 by Shyamsundar Ranganathan (srangana@redhat.com)

Comment 3 Worker Ant 2017-05-25 21:16:27 UTC
COMMIT: https://review.gluster.org/17327 committed in release-3.11 by Shyamsundar Ranganathan (srangana@redhat.com) 
------
commit 1fd0fd5cc5bdb47d725c8eaaffa78754c3f6ff17
Author: AnkitRaj <anraj@redhat.com>
Date:   Mon May 8 17:52:33 2017 +0530

    dht:Spacing issue in fix-layout o/p
    
    There is a spacing issue in the status output of
    the rebalance fix-layout operations. If the local
    host name is big then we will have spacing issue.
    This is the backport of below given ID.
    
    > Bug 1437748
    > Reviewed-on: https://review.gluster.org/17203
    > Smoke: Gluster Build System <jenkins@build.gluster.org>
    > Tested-by: ankitraj <anraj@redhat.com>
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    >Reviewed-by: Jeff Darcy <jeff@pl.atyp.us>
    
    Change-Id: I2fcc4fd382723fb7e93cb4d4dad03dae682cc1a8
    BUG: 1452000
    Signed-off-by: AnkitRaj <anraj@redhat.com>
    Reviewed-on: https://review.gluster.org/17327
    Tested-by: ankitraj
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Shyamsundar Ranganathan <srangana@redhat.com>
    Tested-by: Shyamsundar Ranganathan <srangana@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>

Comment 4 Shyamsundar 2017-05-30 18:52:40 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.11.0, please open a new bug report.

glusterfs-3.11.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-May/000073.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.