Bug 1452003 - smbclient kills the connection when receives ioctl()-reponse STATUS_NOT_SUPPORTED
Summary: smbclient kills the connection when receives ioctl()-reponse STATUS_NOT_SUPPO...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: samba
Version: 7.4
Hardware: x86_64
OS: Linux
urgent
urgent
Target Milestone: rc
: ---
Assignee: Andreas Schneider
QA Contact: Andrej Dzilský
URL:
Whiteboard:
Keywords: ZStream
: 1452028 (view as bug list)
Depends On:
Blocks: 1484723
TreeView+ depends on / blocked
 
Reported: 2017-05-18 07:02 UTC by amitkuma
Modified: 2018-04-10 17:29 UTC (History)
7 users (show)

(edit)
Clone Of:
: 1484723 (view as bug list)
(edit)
Last Closed: 2018-04-10 17:28:22 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0937 None None None 2018-04-10 17:29 UTC
Samba Project 12808 None None None 2019-04-25 17:55 UTC

Description amitkuma 2017-05-18 07:02:51 UTC
Description of problem:
    [netApps SMB-server]                       [smb-Client]
                |      =SMB 2=                    |
                |                                 |  
                | <=FSCTL_VALIDATE_NEGOTIATE_INFO=|
                | =STATUS_NOT_SUPPORTED=>         | Drops Connection
                | <=TCP Fin=                      |

Either there should be option to disable the option to revalidate server capabilities by sending FSCTL_VALIDATE_NEGOTIATE_INFO.
OR smbclient should not drop the connection after getting STATUS_NOT_SUPPORTED from samba-server.

Version-Release number of selected component (if applicable):
smbclient-4.4.4-12.el7_3

How reproducible:
Always

Steps to Reproduce:
1. Configure samba server not having SMB3 enabled, speciafically returing STATUS_NOT_SUPPORTED for FSCTL_VALIDATE_NEGOTIATE_INFO request.
2. Connect using smbclient. client will send FSCTL_VALIDATE_NEGOTIATE_INFO.
3. On reception of STATUS_NOT_SUPPORTED, client will drop the connection

Actual results:
Connection drop

Expected results:
Connection should not be dropped

Additional info:

Comment 2 Andreas Schneider 2017-05-30 15:03:59 UTC
We have a patch for this. We could create a test package for this. Can the customer test the patch and report feedback?

Comment 3 amitkuma 2017-05-31 05:32:56 UTC
Hello Andreas,

Customer is willing to test the patch in his Test Env.

I would be looking forward for 1 patch having code changes for:
1. Current bugzilla. (as you mentioned you have patch)
2. And this https://bugzilla.redhat.com/show_bug.cgi?id=1452028 Also.

Thanks
Amit

Comment 13 Andreas Schneider 2017-08-17 14:18:29 UTC
This bug is not part of RHEL 7.4. As you can see it is considered for RHEL 7.5. We did not get positive feedback that the fix works in time ...

Comment 14 amitkuma 2017-08-21 13:43:42 UTC
Hello Andreas,

Since Issue appeared in 7.3 and we provided test packs having "samba-libs-4.6.2-4.1.el7.x86_64", which was released on 7.4

Hence customer was expecting fix on 7.4, since samba-4.6 is part of 7.4.
Even in comment#6 you mentioned to run test-rpms on 7.4.

But now fix is not in 7.4, what rest can be done?

Thanks

Comment 21 Andreas Schneider 2017-09-05 14:19:36 UTC
*** Bug 1452028 has been marked as a duplicate of this bug. ***

Comment 25 errata-xmlrpc 2018-04-10 17:28:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0937


Note You need to log in before you can comment on or make changes to this bug.