Bug 145202 - new package request: fish fillets game
new package request: fish fillets game
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marius Andreiana
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-15 04:20 EST by Marius Andreiana
Modified: 2013-01-09 22:38 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-02 08:45:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marius Andreiana 2005-01-15 04:20:34 EST
Please add fish fillets
http://fillets.sourceforge.net/download.php

It already has source rpm on that page, needs recompile on fedora 3. 
Dependencies are already in extras: SDL_ttf and lua.

Would be nice to add a .desktop file too.
If this is accepted, but there are no resources to work on it, I'll
work on .desktop file and upadated .spec if needed. Thanks!
Comment 1 Michael Schwendt 2005-01-15 05:50:43 EST
Every package in Fedora Extras needs a maintainer (= package owner).
There are no resources to review or include arbitrary packages found
on websites.

I've added Michal Ambroz to Cc of this ticket, because he appears to
be the author of the Fedora Core 2 packages on upstream project's website.

Maybe you two like to team up on maintaining the package when Fedora
Extras will open up further. Currently, the process of adding new
submissions is not known/documented beyond the old fedora.us package
submission policies.

> $ wget
http://download.sourceforge.net/fillets/fillets-ng-0.6.0-1.src.rpm
> HTTP request sent, awaiting response... 200 OK
> Length: 95,407,761 [application/x-redhat-package-manager]
Comment 2 Marius Andreiana 2005-01-15 06:05:52 EST
Michal, do you have FC3 and would like to maintain this in fedora
extras for future releases? If not, I'll be glad to do it as it's a
nice game and we don't have many on linux.

Comment 3 Michal Ambroz 2005-01-15 09:12:18 EST
I would be glad to maintain this package for Fedora extras.
I am using FC3 just now and going to be usig next releases too.
What is needed to do to get this package to Fedora?
Is there any planned date to openning Fedora extras?

I wuold like to propose for adding also the other game I maintain for
fedora - crack-attack http://rebus.webz.cz/#crack-attack

Comment 4 Marius Andreiana 2005-01-15 09:37:08 EST
Hi Michal!

Please see this document as a guideline, but not as a strict one
http://www.fedora.us/wiki/PackageSubmissionQAPolicy

Currently, the process of adding new submissions is not
known/documented beyond the old fedora.us package submission policies.

Crack attack looks nice, I'd like to play it too. Please open a new
request for it.

Please post here the FC3 package address for fish fillets, I'll test
it intensively :)

Thanks a lot!
Comment 5 Michael Schwendt 2005-01-15 11:56:06 EST
"crack-attack" was dropped from early fedora.us, most likely because
it copies/covers a Super Nintendo game. I see the free packagers at
http://rpm.livna.org have picked it up, as it is included there.
Comment 6 Michal Ambroz 2005-01-16 13:50:42 EST
Re: Marius Andreiana (marius_bugs@galuna.ro)
Official site for fish fillets src.rpm packages is on :
http://fillets.sourceforge.net/download.php

The binaries are for FC2, but src.rpm is actual and it has also the
.desktop file.

If you need binary packages for FC3 please let me know, I can arrange
that for you.

Re: Michael Schwendt (bugs.michael@gmx.net) 
The package at livna doesn't include the sound patch (it is more fun t
o play with sounds :). May be I should try to convince them to add a
sound patch there.

have a nice day 

Michal Ambroz
Comment 7 Marius Andreiana 2005-01-17 06:07:24 EST
I have recompiled and tested the source rpm on FC3. It works as
expected. .desktop file is included.


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

941c5942c68b49084b5c95d7d8b0bb96 *fillets-ng-0.6.0-1.src.rpm
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.6 (GNU/Linux)

iD8DBQFB65vukeWmSlFkLIMRAjytAKC3a4/8Xyeqf+jU0OPP4qhyBYOvHACfbv/V
l5bjS0SsMge5fW/xy10yfg0=
=MkU3
-----END PGP SIGNATURE-----

Michael, what is the next step to add this to FC3 extras?
Comment 8 Michael Schwendt 2005-01-18 07:22:13 EST
Please see my recent post to fedora-extras-list and fedora-devel-list.
Comment 9 Marius Andreiana 2005-01-18 08:24:47 EST
Ok, we'll wait until the infrastructure similar to fedora.us is in place

This is the Michael's post:
https://www.redhat.com/archives/fedora-extras-list/2005-January/msg00046.html
Comment 10 Matthias Saou 2005-02-01 05:28:30 EST
For the time being, I'd be willing to proxy changes to the spec
file(s) in CVS, as well as review the package on the way. Looks like a
neat game that many could enjoy having on FC just one ckick away.
Comment 11 Marius Andreiana 2005-02-01 06:10:35 EST
Thanks Matthias, the spec file is in src rpm here
http://prdownloads.sourceforge.net/fillets/fillets-ng-0.6.0-1.src.rpm?download
Comment 12 Matthias Saou 2005-02-01 06:46:30 EST
Alright, I'll post on the fedora-extras@ list just in case before
importing anything, but in the meantime that package could use some
changes.

The very first obvious one, without even having looked at the spec yet
would be to keep the data, which is already a separate tarball, as a
separate .src.rpm/.noarch.rpm in order to share those 60MB+ between
supported archs.
The same applies even stronger to the data-cs tarball/package that
most users won't be needing, and wastes 30MB of download and at least
as much disk space.

Any objections? (I doubt it, as the resulting sub-packages are even
already split that way)
Comment 13 Marius Andreiana 2005-02-01 06:56:30 EST
These are good changes, please go ahead
Comment 14 Matthias Saou 2005-02-01 10:26:58 EST
I've imported the following new packages in Extras's CVS :

fillets-ng
fillets-ng-data
fillets-ng-data-cs

I've made quite some changes to the spec file, I hope Michal won't mind too
much. I tested the game, works fine for me. I'll be requesting an initial build
shortly, so do let me know if you want further changes made before I do so.
Comment 15 Michal Ambroz 2005-02-02 05:46:59 EST
Hello,
Sure I don't mind. I am glad that fillets made its way to the FC Extras.
Your arguments about spliting src are sane - I also think it is a good idea.

I am sorry I won't be able to make tests of it just now, I am having my wedding
this saturday. 

Please Marius would you test it? 

Thank you guys 

Michal Ambroz
Comment 16 Marius Andreiana 2005-02-02 06:01:21 EST
Congratulations Michal!

Matthias tested it, and I'll test when it's in extras. After that the sf.net
download page could be updated with links to FC extras packages, rather than
maintaining a separate package.
Comment 17 Matthias Saou 2005-02-02 08:45:01 EST
Yup, congratulations Michal, and best wishes to the both of you!

I've requested a build of the 3 packages, so expect them to show up in
pre-extras very soon. I'll close the bug now, don't hesitate to send
me directly changes you'd like made or to open new bugs for possible
issues.
Comment 18 Michael Schwendt 2005-02-03 07:09:16 EST
Who shall be the default package owner in bugzilla?

Note You need to log in before you can comment on or make changes to this bug.